Введение

EMMA Labs web site

Navigation: »No topics above this level«

Advanced Direct Remailer
No contents entries on this page
Contents
Topic functions menu
Menu
This is the first topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Advanced Direct Remailer (сокращенно ADR) – это уникальная программа для отправки электронной почты. ADR делает отправку более быстрой, более безопасной, более контролируемой. И этим помогает Вам сэкономить время и деньги. Вам не нужно что-то менять и отказываться от привычной для Вас системы, если Вы этого не хотите - используемое Вами сейчас программное обеспечение можно легко настроить для работы с ADR. И вдобавок Вы получаете простой и мощный инструмент для массированной и персонифицированной рассылки!

Быстрая отправка. Рассмотрим два случая. В первом случае – Вы обычный пользователь электронной почты, который отправляет в день несколько писем. Во втором случае у Вас есть свой список рассылки, и Вы отправляете несколько сотен или тысяч писем в день. Но в обоих случаях Вы используете для отправки почтовый сервер своего провайдера.

Итак, случай первый. Как идет Ваше письмо? Вначале Ваша почтовая программа отправляет письмо на почтовый сервер провайдера. Сервер провайдера ставит Ваше письмо в очередь исходящих писем. Когда до Вашего письма доходит очередь, оно отправляется на почтовый сервер Вашего корреспондента. И только после этого Ваш корреспондент может его получить.

Обычно, если узел не перегружен, отправка письма занимает несколько секунд. Но может занять и несколько минут, и несколько часов! А как часто нам нужно, чтобы партнер получил письмо до того, как он уйдет на обед, так как после обеда он улетает на встречу? И те десять минут, что письмо простояло в очереди исходящих писем провайдера, могут сыграть решающую роль. ADR в такой ситуации отправит Ваше письмо моментально, ведь он отправляет письма напрямую на сервер получателя письма, минуя почтовый сервер Вашего провайдера. И экономит такие дорогие подчас минуты. Никаких лишних задержек, никаких очередей!

Рассмотрим второй случай. Вам знакома ситуация, когда несчастная тысяча писем размером по 1 кБ отправляются через почтовый сервер провайдера 2..3 часа? Да, у Вас быстрое соединение, но используется даже не на половину мощности - протокол отправки почты SMTP очень медленный, и Ваш провайдер в этом не виноват.

ADR использует прямую и многопоточную отправку – одновременно отправляется несколько писем прямо на почтовые сервера Ваших корреспондентов.

Безопасная отправка. ADR исключает из пути следования письма сервер Вашего провайдера и этим делает отправку более безопасной. Во многих странах законодательство требует, чтобы оператор услуг связи предоставлял доступ спецслужбам к корреспонденции своих пользователей. Поэтому Ваши письма, скорее всего, какое-то время хранятся в системе провайдера. Но если письмо не проходит через почтовую систему провайдера, оно не отражается ни в его логах, ни, тем более, нигде у него не хранится – так же, как не хранятся скаченные по FTP файлы или просмотренные браузером веб-страницы.

Да, конечно, провайдер при желании может обнаружить Ваш почтовый трафик и перехватить его. Но и ADR не претендует на то, чтобы стать гарантом Вашей приватности, раз уж и системы шифрования корреспонденции не всегда претендуют на это.

Контролируемая отправка. Теперь в Вашем распоряжении есть полнофункциональный почтовый сервер! Это дает Вам возможность контролировать почтовый трафик. Например, Вы можете запускать отправку больших объемов почты, посланной по списку рассылки, только во время обеденного перерыва и полдника. Вы можете просматривать содержимое всех исходящих писем и создавать архив исходящей почты Вашей организации. Журналы ADR смогут дать ответ кто, когда и кому отправлял письма. Да и сама отправка писем Вашими сотрудниками теперь будет осуществляться гораздо быстрее – ведь теперь почтовый сервер находится в локальной сети организации!

Часто организации, использующие массированную рассылку, сталкиваются с проблемой мертвых адресов – иногда до 20%..30% писем возвращаются назад с припиской, что адрес электронной почты больше не существует. Это означает, что половина трафика была потрачена впустую. ADR, использующий прямую отправку, отлавливает до 90% “мертвых” адресов в самом начале отправки, тем самым решая эту проблему.

Более того, ADR может сам выполнять рассылку по списку и Вам не нужно приобретать для этого отдельную программу. Система поддержки пользовательских программ обработки писем, называемых плагинами, позволит Вам легко сконфигурировать программу для решения задач любой сложности – от простейшей персонифицированной рассылки и рассылки новых серийных номеров и паролей Вашим пользователям, до создания специальных приложений, осуществляющих связь почтовой системы с базой данных организации.

Легкость настройки. Вы хотите использовать ADR для более быстрой отправки почты, но не хотите отказываться от привычной для Вас системы персонифицированной рассылки? Нет ничего проще! Достаточно заменить адрес сервера исходящей почты (SMTP) в программе персонифицированной рассылки с сервера Вашего провайдера на локальный сервер ADR – 127.0.0.1 И все!

Описание программы

© 2009-2014 EMMA Labs


Описание программы
No contents entries on this page
Contents
Topic functions menu
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Advanced Direct Remailer (сокращенно ADR) отличается от многих программ для массированной рассылки почты тем, что не имеет встроенного редактора писем. Современные почтовые программы очень сложны – они умеют создавать письма в формате HTML, со звуком, скриптами, графикой, сложной версткой; поддерживают много языков и национальных кодировок; умеют шифровать письма при помощи PGP или другой системы. ADR не заставляет Вас изучать новую систему для создания сообщений электронной почты, ведь у Вас уже есть программа которой Вы научились пользоваться и к которой привыкли, где у Вас адресная книга, архив почты, настроенная система шифрования и свои собственные шаблоны писем.

В ADR есть свой внутренний почтовый сервер SMTP и любую программу можно научить отправлять письма через ADR. Достаточно изменить в настройках Вашей программы всего одну строчку! Вы можете прочитать в статье “Настройка почтовых программ” как настроить наиболее популярные программы. После настройки почтовая программа будет отправлять Ваше письмо не провайдеру, а передавать его ADR, который будет оперативно отправлять его.

После запуска программы в углу возле системных часов появляется ее значок. Щелкнув левой кнопкой мыши, либо через пункт “Открыть Монитор…” в меню, вызываемому правой кнопкой мыши, Вы можете открыть главное окно программы – Монитор.

Монитор отображает содержимое трех папок – Исходящие, Отправленные и Плохие. Вы можете переключаться между папками при помощи закладок справа или через меню “Окно”. Когда внутренний почтовый сервер принимает письмо от почтовой программы, то оно попадает в папку Исходящие. После отправки письма оно сохраняется в папке Отправленные. Если письмо отправить не удалось, то письмо перемещается в папку Плохие. Рассмотрим эти папки более подробно.

В папке Исходящие Вы видите всю очередь исходящих писем. Синими треугольниками помечены письма, которые в данный момент отправляются. Число писем в Исходящих отображается в статусной строке в графе “Исх.”, число писем, которые сейчас отправляются – в графе ”Отпр.”. Вы можете включать/выключать отправку через меню “Отправка”, изменять сортировку писем щелкая по заголовку колонки или через меню “Вид”, через меню ”Письмо” Вы можете просматривать журнал отправки письма, удалять выделенное письмо или группу писем из очереди.

После успешной отправки письмо попадает в папку Отправленные. В целях экономии дискового пространства Вы можете настроить программу таким образом, чтобы она удаляла письмо после отправки, а не помещала его в папку Отправленные. Или удаляла письма в папке по прошествии нескольких дней. Вы можете также удалить письма из этой папку вручную или послать их заново, через меню “Письмо”.

В папку Плохие попадают письма, которые отправить невозможно. В колонке “Причина” программа выдает причину невозможности отправки. Вы также можете посмотреть журнал отправки письма и послать его в службу поддержки ADR, Вашему системному администратору или администратору узла Вашего корреспондента, если Вы сомневаетесь или не уверены в правильности работы программы. Если письмо не было отправлено из-за временных сбоев на узле получателя, то вы можете послать его заново через меню “Письмо”.

Вы можете управлять ADR через меню Монитора, но некоторые команды вынесены также на панель инструментов:

close | Закрыть окно Монитора. Чтобы открыть Монитор снова, щелкните на иконке ADR рядом с системными часами левой кнопкой мыши, или щелкните правой и выберите соответствующий пункт меню.
isp | Переключить прямую доставку (прямо на сервер получателя письма) на доставку через почтовый сервер провайдера. Полезно, когда почтовые сервера некоторых Ваших адресатов временно недоступны, а у Вас нет постоянного подключения к Интернет.
play | Запустить отправку. Число потоков доставки писем (число одновременно отправляемых писем) можно задать на закладке “Доставка” в настройках программы. На закладке “Задания” можно задать условия, при которых ADR сам автоматически запустит доставку.
pause | Пауза. Предпочтительный метод останова доставки писем. После включения паузы ADR отправит те письма, которые уже начал отправлять и остановится.
stop | Остановить отправку почты. Отправка будет прекращена немедленно.
log | Просмотр журнала выбранного сообщения. Вы можете настроить журналы так, чтобы в них фиксировались все попытки доставки письма или только последняя.
resend | Послать письмо заново. Вы можете отправить письмо заново из папок Отправленные или Плохие.
delete | Удалить сообщение. Удаляет файл с письмом и его журнал с жесткого диска, так что письмо не может быть восстановлено.
help | Справка программы. Также обратите внимание, что все окна настройки ADR имеют контекстную справку для данной страницы и каждого управляющего элемента.
homepage | Домашняя страница программы в Интернет. Здесь Вы можете найти свежую информацию о программе, обновления и другие программы для работы с электронной почтой.

Локальный почтовый сервер и почтовые ящики


Советы по работе с программой
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Эта статья содержит несколько небольших советов, которые помогут Вам более эффективно использовать Advanced Direct Remailer и, возможно, узнать о нем что-то новое.

Как начать работу с ADR после установки?

Если Вы имеете прямое подключение к Сети, то Вы можете даже не изменять настройки ADR. Вам только нужно настроить почтовую программу для отправки почты через ADR, заменив адрес сервера SMTP исходящей почты на localhost (см. “Настройка почтовых программ»). Если Вы подключены к Интернет через локальную сеть и не имеете реального адреса IP (а, например, адрес вида 10.1.1.5), то Вам нужно настроить программу для работы через прокси-сервер Socks5 (см. “Подключение через прокси»).

Как настроить рассылку по базе данных?

ADR поддерживает списки, формируемые на лету по SQL запросу к базе данных (см. “Форматы списков рассылки»). Для слияния рассылки с базой данных, с распечаткой полей базы по полям письма-шаблона, используйте плагин FromSQL (см. “О плагине FromSQL»).

Как сделать, чтобы плагин Xray обрабатывал все письма?

Начиная с версии 1.3, Вы можете обрабатывать плагинами всю исходящую почту, а не только рассылаемую по списку рассылки. Просто создайте ящик с именем adr-any и добавьте к нему плагин XRay (см. “Специальные почтовые ящики»).

Как увеличить скорость рассылки писем?

Когда ADR доставляет почту не через провайдера, а напрямую («Доставка через ISP” отключена) он извлекает адрес почтового сервера из DNS, подключается к серверу и отправляет сообщение. Подключение к серверам DNS, используемым программой по умолчанию, может у некоторых пользователей занять до 2..3 секунд. Чтобы сократить это время до половины секунды, рекомендуется установить сервера DNS Вашего провайдера (см. “Настройка DNS»). Также Вы можете увеличить число одновременно отправляемых сообщений (см. “Настройка доставки почты»).

Как лучше останавливать доставку почты?

Вы можете закончить доставку почты кнопками Стоп и Пауза. В первом случае доставка почты прекращается сразу, и есть вероятность, что доставка некоторых сообщений будет прервана в тот момент, когда почтовый сервер уже принял письмо, но сессия еще не была завершена. Такое сообщение не будет засчитано как отправленное, и ADR доставит его в следующий сеанс, и пользователь получит две копии письма. Второй вариант более предпочтителен, поскольку ADR завершит отправку тех сообщений, которых он в данный момент отправляет, и после этого доставка остановится.

Как настроить программу X для работы с ADR?

Если программа отправляет почту по протоколу SMTP, то Вы сможете настроить ее для работы через ADR. Просто замените в программе X адрес сервера SMTP исходящей почты на localhost (см. “Настройка почтовых программ»). Так, Вы можете настроить для работы с ADR любую почтовую программу, почтовый сервер, программу для рассылки и т.д.

Как отправлять через провайдера только письма на определенные домены?

Если Вы хотите переключить весь почтовый поток на провайдера, то включите “Доставку через ISP” в окне Монитора. Но если Вы хотите отправлять через провайдера почту только для определенных доменов, а для всех остальных – напрямую, то в ADR, начиная с версии 1.52, вы можете сделать это через “список задержек”.

Описание программы


Использование списка задержек
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Некоторые почтовые сервера имеют “продвинутую” защиту от спамеров, такую, что часть вполне легальных писем не достигает своих адресатов. Наиболее известный пример - America On-Line (AOL.COM). Даже если Вы отправили всего несколько десятков писем пользователям AOL за небольшой промежуток времени, то уже есть шанс, что фильтры AOL сработают и Ваши письма будут выброшены. AOL не сообщает, что Ваш адрес IP заблокирован или что письма с Вашего адреса электронной почты более не принимаются. AOL молча принимает всю почту и… выбрасывает ее. Обратите внимание, что проблема касается только тех, кто рассылает письма по списку, но не тех, кто использует ADR как ремайлер для одиночных писем.

Первый путь обойти фильтры AOL, это посылать письма по одиночке с интервалами в 1-2 минуты. Для этого ADR имеет специальный список доменов, для которых Вы хотите отправлять почту с задержками. Он называется “список задержек” (delay list). Список находится в файле DELAY.LST в каталоге с Advanced Direct Remailer. Файл содержит записи вида:

Aol.com 180

Эта запись означает, что следующее письмо на AOL.COM будет послано спустя 180 секунд (3 минуты) после отправки предыдущего письма на AOL.COM. Так, письма на AOL.COM будут послаться с интервалом в три минуты, а письма на другие домены (не вошедшие в список) будут отправляться без задержек.

Обратите внимание, что список задержек загружается один раз, когда программа запускается. Перезапустите программу, если Вы внесли изменения в список задержек. Число доменов в списке не ограничено. Включить или выключить список задержек можно на закладке “Общие” в настройках программы.

Задержки не работают, когда почта доставляется через провайдера, задержки работают только при прямой доставке. Задержка, если она нужна, происходит между обращением к DNS и подключением к серверу SMTP. Поэтому для несуществующих доменов ADR отправляет письма сразу в “Плохие” безо всяких задержек.

Например, вы включили задержку на 3 минуты для домена AOL.COM и отправили письма на адреса 1@AOL.COM, 2@AOL.COM и 3@AOL.COM. Отправка всех трех писем начнется одновременно (и они будут помечены голубым треугольником в “Исходящих»), но одно письмо будет послано сразу, а два других – через 3 и 6 минут соответственно. В журналах писем Вы увидите такие записи:

Жду согласно списку задержек...

Означающие, что письма были задержаны на определенное время согласно настройкам списка задержек.

Второй путь обойти фильтры AOL, это отправлять почту для AOL через провайдера. AOL имеет список “доверенных” серверов, с которых принимает почту без ограничений. Так, крупные провайдеры могут отправлять AOL десятки писем в минуту. Чтобы всегда отправлять (независимо от переключателя) почту для данного домена через провайдера, установите 0 в списке задержек для данного домена. Например:

Aol.com 0

В этом случае все письма на AOL.COM будут отправляться через сервер провайдера, независимо от состояния переключателя “Доставка через ISP”.

Описание программы


Установка как сервиса Windows
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Вы можете установить ADR как сервис под Windows XP и старше. Это позволит ADR отправлять и принимать почту когда Вы еще не вошли в систему или уже завершили сеанс, так как сервисы работают даже тогда, когда пользователь не входил в систему. Смотрите справочную систему Windows чтобы узнать больше о сервисах.

Чтобы установить ADR как сервис, просто запустите программу ADR Service Manager

Описание программы


Локальный почтовый сервер и почтовые ящики
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

ADR не имеет встроенного редактора сообщений, но имеет встроенный почтовый сервер SMTP, и Вы можете настроить свою почтовую программу для работы через ADR, как это описано в статье “Настройка почтовых программ”.

Помимо того, что внутренний почтовый сервер осуществляет связь почтовой программы и ADR, он имеет еще одну важную функцию – поддержку списков рассылки. Настройка списков рассылки осуществляется через конфигурацию почтовых ящиков на закладке ”Ящики” в настройках программы.

Почтовый ящик в ADR – это не хранилище писем. При настройке почтового ящика с ним связываются списки рассылки и плагины. Когда письмо попадает в ящик, оно рассылается по спискам рассылки, связанным с ящиком и обрабатывается связанными с ящиком плагинами. Все полученные в результате письма попадают в папку Исходящие.

При установке программы было настроено несколько почтовых ящиков. Вы можете свободно отправлять письма по этим спискам, они содержат специальные тестовые адреса нашей службы.

Самый простой ящик – simple, который содержит только один список рассылки. Письмо, отправленное на адрес simple@localhost (если Вы изменили локальный домен почтового сервера, то внесите в адрес коррективы), будет “размножено” согласно списку, находящемуся в файле simple.lst.

Обычно, когда программа отправляет письмо по списку рассылки, в поле “То:” письма стоит адрес списка рассылки. ADR умеет заменять этот адрес на адрес действительного получателя письма, если включена соответствующая опция. К почтовому ящику withname добавлен список withname.lst, в котором адреса электронной почты приведены в стандартном формате. При рассылке со включенной опцией по этому списку получатель увидит в поле “To:” свое реальное имя.

Более сложный пример – sendnum, который содержит список и плагин, пользовательскую программу обработки письма. При отправке письма на sendnum@localhost каждое письмо, рассылаемое по списку sendnum.lst, будет обработано программой sendnum.exe, которая ищет в теле письма последовательность %SENDNUM% и заменяет ее первой строкой из файла sendnum.dat. После чего первая строчка файла sendnum.dat удаляется. Этот плагин полезен при рассылке пользователям новых серийных номеров. Вам нужно сформировать sendnum.lst с адресами Ваших пользователей и файл sendnum.dat со списком серийных номеров. И работа, которая могла занять не один день, будет выполнена за несколько минут! Программа sendnum.exe поставляется с исходным текстом на языке C, который Вы можете свободно модифицировать, чтобы расширить возможности этого плагина.

Аналогично работает пример realname, предназначенный для персонифицированной рассылки. В файле realname.dat собраны адреса электронной почты и реальные имена их обладателей. Плагин ищет последовательность %REALNAME% в письме и заменяет ее на реальное имя получателя письма. Если в файле realname.dat нет имени сопоставленного данному адресу электронной почты, то используется имя по умолчанию, задаваемое после одиночного символа @ в файле realname.dat. Например, в письме начинаюшемся со строк:

Hello, %REALNAME%!

будет произведена замена на

Hello, John Smith!

Этот плагин можно использовать и для других целей – например, для рассылки пользователям серийных номеров или другой персонифицированной информации.

Если к Вашему ящику привязано несколько списков рассылки (m1.txt, m2.txt, m3.txt) и несколько плагинов (e1.exe, e2.exe, e3.exe), то система будет работать следующим образом. Для первого адреса из файла m1.txt программа сформирует письмо. Затем запустит программу e1.exe, передав ей первым параметром в командной строке имя и путь файла с письмом. Когда программа e1.exe закончит обработку письма, будет запущена программа e2.exe с именем письма в командной строке, затем – e3.exe. После того, как письмо обработано всеми плагинами, оно попадает в конец очереди в папке Исходящие и начнет отправляться, как только очередь до него дойдет. После того, как письмо перемещено в папку Исходящие, будет сформировано письмо для второго адреса из списка m1.txt и т.д. Когда адреса в списке m1.txt закончатся, программа начнет обрабатывать список m2.txt, а затем – m3.txt.

Плагин может удалить письмо, переданное ему для обработки, если считает, что письмо нельзя отправлять. Например, в списке серийных номеров закончились номера. В качестве плагина могут выступать выполняемые файлы (.exe и .com) и командные файлы (.bat).

Формат писем ADR очень прост и Вы или Ваши программисты могут легко создавать программы специальной обработки писем.

О DLL-версиях плагинов, О плагине FromSQL, Описание программы, Информация для программистов


Специальные почтовые ящики
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Начиная с версии 1.3, пользовательские программы обработки писем (плагины) могут обрабатывать всю почту, проходящую через ADR, а не только письма рассылаемые по спискам рассылки. Если Вы не знакомы с идеологией плагинов в ADR, то прочтите вначале статью “Внутренний почтовый сервер и почтовые ящики”.

Так, в версии 1.3 добавлено три специальных почтовых ящика: adr-any, adr-list, adr-notlist. Они имеют следующую особенность: Вы можете добавлять к ним только плагины, но не можете добавлять к ним списки рассылки. Плагины, добавленные к adr-any будут обрабатывать всю проходящую через ADR почту. Плагины, добавленные к ящику adr-list будут обрабатывать письма, рассылаемые по всем спискам рассылки. А плагины, добавленные к adr-notlist обрабатывают всю почту, кроме той, что рассылается по спискам рассылки.

Например, Вы хотите чтобы плагин XRay обрабатывал всю исходящую почту, то создайте ящик adr-any и добавьте к нему этот плагин. Аналогично, если Вы хотите, чтобы плагин realname обрабатывал всю почту, рассылаемую по всем спискам рассылки, то создайте ящик adr-list и добавьте к нему этот плагин.

Обработка сообщений ведется в следующем порядке. Сообщения, рассылаемые не по списку рассылки, вначале обрабатываются плагинами добавленными к ящику adr-notlist (конечно, если он создан), и затем плагинами добавленными к ящику adr-any. Сообщения рассылаемые по списку рассылки, вначале обрабатываются плагинами добавленными к ящику со списком, затем плагинами добавленными к ящику adr-list (конечно, если он создан) и только затем плагинами добавленными к ящику adr-any.

Внутренний почтовый сервер и почтовые ящики


Форматы списков рассылки
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Программа поддерживает четыре следующих формата списков рассылки:

1. Простые списки рассылки (.TXT, .LST)

2. Значения разделенные запятыми (.CSV) lists

3. Списки SQL (.SQL)

4. Адресные книги Windows (.WAB)

Описание программы


О DLL-версиях плагинов
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Начиная с версии 1.5, ADR поддерживает новый формат плагинов, это обычные DLL (Dynamic Link Libraries, .DLL) с определенным набором экспортируемых функций. С пользовательской точки зрения, они ничем не отличаются от обычных .EXE версий. И если Вы имеете две версии плагина (.EXE и .DLL), то можете использовать любой из них. Однако, новые DLL-плагины предпочтительней, так как они работают в 2..4 раза быстрее. Все плагины ADR теперь имеют и DLL-версию.

EXE-плагины запускаются для каждой копии письма. И если Вы обрабатываете плагином рассылку из 1000 сообщений, то плагин будет запущен 1000 раз. Новые плагины в формате DLL загружаются один раз перед тоссингом писем по списку и для каждого письма вызывается одна функция из библиотеки. .DLL будет выгружена после окончания тоссинга. Новые версии плагинов не только работают в 2..4 раза быстрее, но и существенно снижают нагрузку на CPU и диск.

Описание ниже рассчитано на программистов. После загрузки DLL-плагина, ADR пытается импортировать из DLL функцию AdrPlugin. Если это не удалось, ADR импортирует функцию _AdrPlugin и если это опять не удалось – функцию под номером 10. Эта функция должна иметь следующий прототип:

DWORD WINAPI AdrPlugin(char* MessageFileName); /* в нотации C/C++ */

function AdrPlugin(MessageFileName : PChar) : Integer; stdcall; /* в нотации Delphi */

ADR не использует кодов возврата функций. Но рекомендуется возвращать значений 0 или 1, чтобы избежать конфликтов с будущими версиями. ADR вызывает функцию плагина для обработки сообщения и указывает при вызове полный путь и имя файла с сообщением. Большинство плагинов ADR поставляется с исходными текстами на C или Delphi, и вы можете ознакомиться с ними, если у Вас возникли вопросы.

Утилита TestDLL создана специально, чтобы проверять DLL-плагины без ADR. Утилита распространяется вместе с исходным текстом. Вы можете посмотреть его, если Вас интересуют подробности механизма загрузки плагинов.

Внутренний почтовый сервер и почтовые ящики, Информация для программистов


О плагине SendNum
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Смотрите пример sendnum на закладке “Ящики” в настройках программы. Он содержит список и плагин (пользовательскую программу обработки почты). Когда Вы отправляете письмо на sendnum@localhost, то письмо будет размножено по списку sendnum.lst, и каждое письмо будет обработано программой sendnum.exe (sendnum.dll). Программа ищет последовательности %SENDNUM% и заменяет их первой строчкой из файла sendnum.dat. После этого, первая строка файла sendnum.dat удаляется. Например, этот плагин может быть полезен при рассылке новых серийных номеров пользователям. Вы создаете список с адресами электронной почты и файл sendnum.dat, содержащий серийные номера. И работа, которая может отнять несколько дней, займет всего несколько минут! Sendnum.exe (sendnum.dll) распространяется с исходными текстами на языке C, и Вы можете свободно модифицировать и расширять возможности этого плагина. Мы поставляем обе версии (.EXE и .DLL) этого плагина, но предпочтительней использовать более быструю DLL-версию.

Внутренний почтовый сервер и почтовые ящики


О плагине RealName
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Пример realname иллюстрирует простейшую персонифицированную рассылку. Файл realname.dat содержит почтовые адреса и имена получателей. Плагин ищет последовательности %REALNAME% в письме и заменят их реальным именем получателя. Если файл realname.dat не содержит имени, соответствующего адресу, то используется имя, указанное после одиночного символа @ в этом файле (имя по умолчанию). Например, письмо начинающееся с этой строки:

Hello, %REALNAME%!

В письме, отправленном на адрес john@domain.com, превратится в:

Hello, John Smith!

Этот же плагин может использоваться и в других целях – например, для рассылки серийных номеров или другой персональной информации пользователям. Realname.exe (realname.dll) распространяются с исходным текстом на языке C. Мы поставляем обе версии (.EXE и .DLL) этого плагина, но предпочтительней использовать более быструю DLL-версию.

О плагине RealName2, Внутренний почтовый сервер и почтовые ящики


О плагине RealName2
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Плагин RealName2 выполняет ту же работу, что и плагин RealName. Файл realname2.dat содержит адреса и реальные имена получателей в следующем формате:

Default User Name

John Smith <john@domain.com>

Vlad Kat <kitten@soft.com>

Плагин ищет в письме последовательности %REALNAME% в сообщениях и заменяет их на реальное имя получателя. Если realname2.dat не содержит имени, соответствующему данному адресу, то используется имя, заданное в первой строке файла. Например, строка:

Hello, %REALNAME%!

В письме, отправленном на адрес john@domain.com, превратится в:

Hello, John Smith!

Этот же плагин может использоваться и в других целях – например, для рассылки серийных номеров или другой персональной информации пользователям. Realname2.exe (realname2.dll) распространяются с исходным текстом на языке C. Мы поставляем обе версии (.EXE и .DLL) этого плагина, но предпочтительней использовать более быструю DLL-версию.

О плагине RealName, Внутренний почтовый сервер и почтовые ящики


О плагине XRay
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Пример xray (см. закладку “Ящики” в настройках программы) содержит список рассылки и плагин XRay, распространяемый с исходными текстами для Borland Delphi v3. Плагин предназначен для вырезания некоторых строк из заголовка письма с технической информацией (kludges), начало вырезаемых строк задается в файле XRay.CFG. Например, Вы можете вырезать строки с идентификатором Вашей почтовой программы (X-Mailer) или путем сообщения по внутренней почтовой системе Вашей организации. Этот плагин и его исходный код для Borland Delphi v3 находятся в подкаталоге \plugins каталога с Advanced Direct Remailer. Мы поставляем обе версии (.EXE и .DLL) этого плагина, но предпочтительней использовать более быструю DLL-версию. Чтобы обработать этим плагином всю исходящую почту, добавьте этот плагин к ящику “adr-any” (см. статью “Специальные почтовые ящики»). Полной противоположностью этого плагина является AdKludge.

Внутренний почтовый сервер и почтовые ящики


О плагине AdKludge
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Плагин AdKludge добавляет служебные строки (kludges) из файла AdKludge.CFG к заголовку сообщения. Например, Вы можете добавить клудж “ List-Unsubscribe:” к сообщению, рассылаемому по Вашему списку рассылки. Плагин и его исходный код для Borland Delphi v3 находится в подкаталоге \plugins каталоге с Advanced Direct Remailer. Мы поставляем обе версии (.EXE и .DLL) этого плагина, но предпочтительней использовать более быструю DLL-версию. Чтобы обработать этим плагином всю исходящую почту, добавьте этот плагин к ящику “adr-any” (см. статью “Специальные почтовые ящики»). Полной противоположностью этого плагина является XRay.

Внутренний почтовый сервер и почтовые ящики


О плагине FromSQL
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Плагин FromSQL предназначен для слияния базы данных со списком рассылки. FromSQL работает с базой данных через ODBC, поэтому может взаимодействовать как с мощной БД под управлением Microsoft SQL Server или Oracle, так и с файлом Microsoft Excel. Если Вы не знакомы с идеологией плагинов в Advanced Direct Remailer, то вначале прочтите пожалуйста статью “Локальный почтовый сервер и почтовые ящики”.

Данная статья ориентирована на опытного пользователя, обладающего навыками работы с одной из СУБД или Microsoft Excel, знающего основы языка SQL. В статье рассказывается о назначении плагина, его настройке и приводятся примеры решения практических задач при помощи этого плагина.

Предположим, у Вас есть таблица следующего вида:

customers

------------------------------------------

name email account

------------------------------------------

Smith recycled0@pisem.net 756320

Doe recycled1@pisem.net 89201

Green recycled2@pisem.net 103990

------------------------------------------

и каждому пользователю в конце месяца Вы должны послать письмо следующего содержания:

Dear Mr. Smith,

thank you for your interest to our project.

Your account is $756320 now.

Support Team,

support@support.com

Вы можете автоматизировать этот процесс при помощи плагина FromSQL. Для этого Вам нужно создать почтовый ящик, добавить к нему список рассылки с адресами тех, кто должен получить письмо, и плагин FromSQL. Настройка плагина FromSQL осуществляется через файл FromSQL.INI, который находится в одном каталоге с плагином.

В настройках Вы должны указать имя источника данных ODBC, имя и пароль для доступа к данным. Пароль и имя пользователя могут быть пустыми. Для выборки данных из базы Вам нужно настроить SQL-запрос, имя файла с которым задается в параметре Request имя файла. Если путь к файлу с SQL-запросом опущен, то он должен находится в одном каталоге с плагином.

Запрос для данного случая должен быть такого вида:

SELECT name, account FROM customers WHERE email='%recipient%'

Макрос %recipient% будет заменен в запросе на адрес электронной почты получателя данного письма. В самом же письме плагин заменит макросы %%1%%, %%2%% и т.д. на, соответственно, значения первой, второй и следующих колонок первой строки результата SQL-запроса. Например, исходное письмо:

Dear Mr. %%1%%,

thank you for your interest to our project.

Your account is $%%2%% now.

Support Team,

support@support.com

будет после выполнения запроса:

SELECT name, account FROM customers WHERE email='recycled0@pisem.net'

иметь вид, приведенный в самом начале статьи. Обратите внимание, что если SQL-запрос вернет несколько строк, то все строки после первой будут проигнорированы.

Как уже писалось выше, в качестве источника данных может выступать файл документ Microsoft Excel. Для этого должны быть установлены драйвера ODBC для Excel, входящие в поставку Microsoft Office. В каталоге с плагином есть файл FromSQL.XLS, предназначенный для демонстрации разобранного выше примера.

Зайдите в “Панель управления” и выберите пункт “Источники данных ODBC”. Создайте пользовательский DSN, выбрав драйвер Excel. Назовите создаваемый источник данных “FromSQL” и укажите рабочую книгу FromSQL.XLS, расположенную в каталоге с плагином. При установке программа создала почтовый ящик fromsql, который сконфигурирован для вышеприведенного примера. Вам оставалось только создать источник данных “FromSQL”, чтобы сделать пример рабочим.

Теперь Вы можете послать письмо на адрес fromsql@localhost, чтобы удостовериться, что Вы все настроили правильно. Вы также можете просмотреть содержимое сформированных писем в каталоге MAIL\OUT, чтобы абсолютно в этом убедиться.

Необходимо сделать еще один важный комментарий, касающийся документов Excel. Перед использованием документа в качестве таблицы базы данных задайте имя для каждой области листа, играющей роль таблицы. Так, в файле FromSQL.XLS ячейкам диапазона $A$1:$C$33 присвоено имя customers ("Вставка" -> "Имя" -> "Присвоить"). А имена колонок таблицы – это значения первых ячеек определенной области, в данном случае, ячеек A1, B1, C1.

Мы не приводим здесь специально примеры для крупных СУБД, таких как Microsoft SQL Server, так как считаем, что администраторы таких баз сумеют настроить плагин FromSQL для работы с базой данных и без наших подсказок. В противном случае мы будем рады оказать посильную помощь.

Начиная с версии 1.1, ADR поддерживает списки рассылки, создаваемые налету по запросу SQL. Прочтите статью “Форматы списков рассылки”, чтобы узнать больше о SQL-списках.

О плагине SQLTable, О плагине FromCSV, Локальный почтовый сервер и почтовые ящики, Форматы списков рассылки


О плагине SQLTable
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Плагин SqlTable аналогичен плагину FromSQL, но работает с SQL-запросами, возвращающими несколько строк. Если FromSQL берет только первую строку результатов, полученную на запрос SELECT и заменяет макросы в письме значениями из этой строки (например, все макросы %%1%% в письме будут заменены значением из первой колонки первой строки результата запроса), то плагин SqlTable обрабатывает все строки результата запроса.

Для этого введен дополнительный макрос %sqltable%. Пример использования:

Dear sir,

plese, see our price list below.

%sqltable%

Position: %%1%%

Price: $%%2%%

%sqltable%

WBR,

Sales Team

Для каждой строки результата запроса плагин будет повторять блок между макросами %sqltable% и пропечатывать по нему значения из колонок строки. Например, в результате запроса

SELECT position, price FROM price_list

исходное письмо может быть модифицировано плагином следующим образом:

Dear sir,

plese, see our price list below.

Position: Advanced Direct Remailer

Price: $40

Position: Advanced Maillist Verify

Price: $40

Position: Advanced Email Parser

Price: $149

Position: Advanced Email Extractor

Price: $40

Position: Advanced Email Extractor PRO

Price: $99

WBR,

Sales Team

Файл конфигурации плагина аналогичен файлу конфигурации плагина FromSQL и расширен следующими параметрами:

Rowname - позволяет заменить макрос %sqltable% на любой другой. Например, чтобы обрабатывать письмо в несколько проходов.

FormatLeft и FormatRight - устанавливают параметры форматирования для длинных строк результата. Установите эти значения в 0, чтобы отменить форматирование.

Файлы плагина SqlTable находятся в подкаталоге plugins каталога с Advanced Direct Remailer.

О плагине FromSQL, О плагине FromCSV, Локальный почтовый сервер и почтовые ящики


О плагине FromCSV
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Плагин FromCSV предназначен для слияния рассылки с информацией из файла CSV (Comma Separated Values), аналогично тому, как плагин FromSQL обеспечивает слияние с базой данных. Экспорт данных в файлы формата CSV поддерживаются Microsoft Excel, Outlook Express и другими популярными программами. Если Вы не знакомы с идеологией плагинов в Advanced Direct Remailer, то вначале прочтите пожалуйста статью “Локальный почтовый сервер и почтовые ящики”.

.EXE и .DLL версии плагина находятся в подкаталоге \plugins\FromCSV каталога с Advanced Direct Remailer. Плагин использует файл настроек FromCSV.INI и файл данных FromCSV.CSV. Также в каталоге с плагином находится его полный исходный код на языке C++, плагин компилировался Microsoft Visual C++ 6.0.

Файл формата CSV представляет собой таблицу. Первая строка файла – шапка таблицы, остальные строки – данные. Пример файла CSV:

Name, Email, Web Page, ID

Alexander Gorlach, gorlach@mail.com, www.mail.com, 10282

Andrey Cherezov, ac@eserv.ru, www.etype.net, 12992

TheBat Team, support@ritlabs.com, www.ritlabs.com, 11020

Vlad Kat, vkat@soft.com, www.elomsoft.com, 10230

Значения в файле должны быть взяты в кавычки (например, “Vladimir Katalov, Managing Director»), если они содержат символ разделителя. Символ разделителя списка задается в региональных настройках операционной системы. Вы также можете переопределить эту настройку в конфигурационном файле FromCSV.INI.

Для подстановки значений в письмо-шаблон используются макросы %%1%%, %%2%% и т.д., ссылающиеся на данные из первой, второй и следующих “столбцов” файла CSV. Также для данного примера можно использовать %%Name%% вместо %%1%%, %%Email%% вместо %%2%%, %%Web Page%% вместо %%3%% и так далее, в соответствии с названиями столбцов в файле CSV. Обратите внимание, что макросы чувствительны к регистру (%%EMAIL%% не эквивалентен %%Email%%). Например, такое письмо:

From: info@mydomain.com

To: %%Name%% <ac@eserv.ru>

Hello, %%1%%!

We add your web-page %%Web Page%% to our directory. Please,

check us here:

http://mydomain.com/%%ID%%.html

Thank you, %%1%%!

MyDomain Team

www.mydomain.com

Превратится в следующее (будут использованы данные из строки, содержащей адрес получателя этого письма ac@eserv.ru) после обработки его плагином FromCSV:

From: info@mydomain.com

To: Andrey Cherezov <ac@eserv.ru>

Hello, Andrey Cherezov!

We add your web-page www.etype.net to our directory. Please,

check us here:

http://mydomain.com/12992.html

Thank you, Andrey Cherezov!

MyDomain Team

www.mydomain.com

Пример письма и пример файла CSV находятся в каталоге с плагином.

О плагине FromSQL, Внутренний почтовый сервер и почтовые ящики


О плагине AdrDelay
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

ADR создает отдельную копию письма для каждого адреса в списке рассылки, так что при рассылке большого письма по большому списку требуется просто громадное дисковое пространство. AdrDelay решает эту проблему.

Плагин читает параметр MaxOutboxMessages (значение 500 по умолчанию) из файла AdrDelay.INI. Когда плагин запускается для обработки следующего сообщения, он проверяет число сообщений в каталоге с исходящей почтой и ждет, пока их число не станет меньше значения MaxOutboxMessages. Так, создание сообщений по списку временно приостанавливается и возобновляется только после отправки части сообщений. Также рекомендуется установить опцию “Удалять посланные сообщения” для сохранения дискового пространства.

AdrDelay.exe (AdrDelay.dll) распространяется с исходными текстами на языке C. Мы поставляем обе версии (.EXE и .DLL) этого плагина, но предпочтительней использовать более быструю DLL-версию.

Внутренний почтовый сервер и почтовые ящики


О плагине MsgID
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Каждое сообщение может содержать в заголовке уникальный идентификатор (Message-ID), по которому почтовый сервер может ловить и удалять дубликаты сообщений. Некоторые программы, например, Aureate GroupMail, не используют при формировании писем идентификаторы.

Плагин MsgID добавляет идентификатор в заголовок обрабатываемого сообщения, и заменяет его, если в сообщении уже есть идентификатор. Например, сообщение Outlook Express имеет идентификатор, но если ADR разошлет его по списку рассылки, то все его “потомки” будут иметь одинаковый идентификатор. Неизвестно о практических случаях потери таких сообщений, но это теоретически возможно из-за ошибок в серверном ПО. Поэтому рекомендуется обрабатывать исходящие письма эти плагином.

Плагин распространяется вместе с исходными текстами и только в виде DLL-версии.

Внутренний почтовый сервер и почтовые ящики


О плагине ExclList
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Плагин ExclList предназначен для создания списков исключений. Добавив этот плагин к ящику со списком рассылки, Вы сможете исключить из рассылки адреса, занесенные в отдельный список исключений. Добавив этот плагин к специальному ящику (например, adr-any), Вы можете глобально запретить отправку почты через ADR на адреса из списка исключений. Чтобы блокировать почтовый домен полностью, используйте * вместо имени почтового ящика. Например, *@ftc.org запретит отправлять письма на все адреса домена FTC.ORG.

.EXE и .DLL версии плагина находятся в подкаталоге \plugins\ExclList каталога с Advanced Direct Remailer. Плагин использует файл настроек ExclList.INI и файл данных ExclList.LST. Также в каталоге с плагином находится его полный исходный код на языке C++, плагин компилировался Microsoft Visual C++ 6.0.

Согласно настройкам в файле ExclList.INI, плагин может либо удалять письма, адреса получателей которых есть в списке ExclList.LST, либо сохранять их в указанной папке. Файл ExclList.LST содержит список адресов, по одному адресу в строке. Например:

John Smith <xxx@xxx.com>

gates@microsoft.com

"Join to us!" <jointo@ourentrants.com>

"this @ is dog" <dog@ask.com>

*@ftc.org

bgates@micro$oft.com <bgates@microsoft.com>

Внутренний почтовый сервер и почтовые ящики


О плагине Recipient
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Плагин заменяет строку %recipient% в письме на адрес получателя письма. Это может оказаться полезным, если Вам надо написать в письме подобное следующему:

-----------------------------------------

ЧТОБЫ ОТПИСАТЬСЯ, ПОШЛИТЕ ПУСТОЕ ПИСЬМО

MAILTO:ROBOT@MYDOMAIN.COM?SUBJECT=%recipient%

-----------------------------------------

Макрос %recipient% чувствителен к регистру, и должен быть написан в нижнем регистре. .EXE и .DLL версии плагина находятся в подкаталоге \plugins\Recipient с Advanced Direct Remailer. Также в каталоге с плагином находится его полный исходный код на языке C.

Внутренний почтовый сервер и почтовые ящики


Настройка Advanced Direct Remailer
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Настройка программы вызывается в меню “ Отправка ” Монитора выбором пункта “Настройка...”. В появившемся окне Вы увидите несколько закладок с настройками: Общие, Задания, DNS, Доставка, Сервер, Ящики, Прокси, Журналы


Общие настройки
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Запускать программу при загрузке Windows

Альтернатива – поместить ярлык программы в папку “Автогзагрузка” в кнопке “Пуск”.

Окно Монитора поверх остальных

Пометьте, чтобы открытое окно Монитора располагалось поверх всех остальных окон на рабочем столе.

Удалять посланные сообщения

Удалять отправленные письма, не помещая их в папку ”Отправленные”. Рекомендуется использовать эту настройку или очищать время от времени папку “Отправленные” вручную. Также можно настроить ADR, чтобы он хранил письма в “Отправленных” указанное число дней.

Возвращать отправителю, не помещать в “Плохие”

Если данная опция не включена, то письмо отправленное на несуществующий почтовый адрес будет помещено в папку “Плохие”. В противном случае письмо будет возвращено отправителю. Для этого сформируется новое письмо (с прикрепленным исходным сообщением и журналом отправки), с адреса отправителя письма на его же адрес электронной почты, которое будет помещено в очередь писем и доставлено в общем порядке. Если сообщение не удается вернуть (т.е. адрес отправителя также неверный), то сообщение будет помещено в папку “Плохие”.

Интеграция с Eserv

Eserv (www.eserv.ru) это мощный Интернет/Интранет сервер (SMTP, POP3, NNTP, WEB, FTP, hhtp-proxy, ftp-proxy, socks5-proxy, TCP и UDP маппинг и много чего еще) для Windows 9x/NT/2000. Если Вы используете ADR и Eserv на одном компьютере, то включите эту опцию, чтобы Eserv не разрывал соединения удаленного доступа, когда ADR отправляет почту; звонил, когда ADR захочет отправить почту и разрывал связь, когда ADR закончил доставку почты и больше нет процессов, работающих с Интернет.

Сигнал, когда сообщение попадает в “Плохие”

Короткий звуковой сигнал. Издается через звуковую карту, а не через встроенный динамик PC-Speaker, когда ADR не может доставить сообщение и помещает его в папку “Плохие”.

Менять цвет иконки при попадании в “Плохие”

Цвет иконки на панели задач рядом с системными часами поменяется с синего на красный, если эта опция включена. Иконка станет синей снова, когда Вы откроете папку “Плохие” или перезапустите программу. Если сообщение попадает в “Плохие” тогда, когда Вы просматриваете эту папку, то цвет значка не изменится.

Сигнал, когда вся почта отправлена

Короткий звуковой сигнал. Издается через звуковую карту, а не через встроенный динамик PC-Speaker, когда ADR отправил всю почту из “Исходящих”.

Разрывать dial-up, когда вся почта отправлена

Разрывает все соединения удаленного доступа после того, как будет отправлено последнее сообщение из папки “Исходящие”.

Использовать приоритет сообщений в “Исходящих”

В этом режиме ADR пытается вначале доставить почту с высокой важностью, затем почту с обычной важностью и лишь затем – с низкой. Новые сообщения с высокой важностью автоматически попадают в начало очереди писем в “Исходящих”, а письма с низкой важностью – в конец очереди. Обычно почтовые сервера не используют важность сообщения как приоритет в очереди писем, эта возможность добавлена по просьбам пользователей.

Использовать список задержек

Список задержек был разработан для обмана спам-фильтров крупных почтовых систем и тестировался на спам-фильтре AOL. Но список может быть полезен и для мирных целей. Пожалуйста, смотрите детали здесь.

Не показывать заставку при запуске

Включает / выключает появление заставки программы при запуске.

Настройка Advanced Direct Remailer


Настройка заданий
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Запуск доставки почты

Настройки этой группы задают правила автоматического запуска доставки почты. Вы также можете запускать доставку почты вручную через меню программы.

Вручную через меню программы

Не использовать автоматический запуск, запускать отправку только вручную.

Когда установлено соединение удаленного доступа

Запускать отправку при установленном выбранном соединении. Если выбрано “Любое соединение” – то при любом установленном соединении удаленного доступа. Отправка прекращается, если соединение разрывается.

Когда почта есть в “Исходящих”

Автоматический запуск отправки почты, как только письма появляются в папке “Исходящие”. Для тех, у кого постоянное подключение к Интернет.

Удалять старую почту

Настройки этой группы позволяют хранить в папках “Отправленные” и “Плохие” письма только за указанное число дней. Более старые письма будут автоматически удаляться ADR.

В “Отправленных” через несколько дней

Хранение писем в папке “Отправленные” только указанное число дней. Включите опцию, чтобы стало доступно поле ввода.

В “Плохих” через несколько дней

Хранение писем в папке “Плохие” только указанное число дней. Включите опцию, чтобы стало доступно поле ввода.

Настройка Advanced Direct Remailer


Настройка DNS
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Первый DNS

Основной DNS-сервер. Может быть задан как доменом, так и IP-адресом. Advanced Direct Remailer работает с DNS-серверами только по протоколу UDP. У некоторых пользователей время доступа к DNS-серверам, которые по умолчанию используются программой, составляет 2-3 секунды. Вы можете сократить это время до половины секунды, обратившись к своему провайдеру услуг Интернет за адресом его DNS сервера, если он не предоставил вам эту информацию при заключении договора. Windows при определенных условиях может получать адрес DNS-сервера автоматически, и многие провайдеры используют это, чтобы не заставлять пользователя делать лишние настройки. ADR пытается определить текущие настройки и показать их в окне “Системные настройки DNS ”. Вы также можете самостоятельно определить адреса DNS-серверов, запустив утилиту IPCONFIG с ключом /ALL Вы также можете взять адреса DNS из этого небольшого списка.

Второй DNS

Дополнительный DNS-сервер, может быть не указан. Может быть задан как доменом, так и IP-адресом. Используется, только если основной DNS-сервер не ответил положительно на запрос.

Пытаться доставить по имени хоста

Прямая доставка. Например, для адреса alex@gorlach.koenig.su на сервер gorlach.koenig.su . Если даже прямая доставка включена, то она используется только в том случае, если DNS-серверы не вернули адресов почтовых серверов. Использование прямой доставки НЕ РЕКОМЕНДУЕТСЯ.

Не использовать внутренний кэш DNS

Если в списке есть два адреса с одного домена (например, a@hotmail.com и b@hotmail.com), то второй раз программа не станет обращаться к DNS - адреса почтовых серверов будет выбраны из внутреннего кэша программы. Отметкой этой опции Вы можете отключить кэш.

Системные настройки DNS

Информация в этом окне обновляется каждую секунду автоматически. Программа пытается определить настройки DNS Windows и показать их в этом окне. Если Вы пользователь удаленного доступа, то вначале установите соединение, чтобы ADR смог определить Ваши настройки. Вы также можете самостоятельно определить адреса DNS-серверов, запустив утилиту IPCONFIG с ключом /ALL, если Вы работаете под Windows NT, или утилиту WINIPCFG, если вы работаете под Windows 95 или Windows 98. Эти утилиты входят в состав операционной системы. Вы также можете самостоятельно определить адреса DNS-серверов, запустив утилиту IPCONFIG с ключом /ALL Эта утилита входит в состав операционной системы.

Обновлять настройки DNS

Автоматически заменять первичный и вторичный сервера системными DNS, если они обнаружены. Проверка и обновление настроек происходит примерно раз в секунду. При открытом окне настройки программы автоматического обновления не происходит.

Список серверов DNS, Настройка Advanced Direct Remailer


Настройка доставки почты
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Домен для “HELO”

Ваш домен, используемый для представления SMTP-серверам. Рекомендуется использовать свой настоящий домен. Если домен не указан, программа постарается сама определить Ваш домен, если определить домен не удастся, будет использован домен localhost. Использование чужого домена или псевдонима localhost возможно, но не рекомендуется - серверы с высоким уровнем безопасности могут отказаться с Вами работать.

Если Вы настроили программу для работы через прокси-сервер Socks5, то здесь следует указать домен прокси-сервера – программа не сможет сама его определить.

Потоки отправки (0..399)

Число одновременно отправляющихся писем. Увеличивая число потоков, Вы увеличиваете сетевой трафик и нагрузку на машину. Рекомендуется 15..25 потоков для модема на 33.6k.

Таймаут

Максимальное время ожидания в минутах, после истечения которого отправка письма прекращается. Значение 0 отключает проверку таймаута. Время считается от момента последнего получения из Сети данных.

Доставлять только через основной сервер SMTP

По умолчанию, если недоступен сервер с наивысшим приоритетом, то программа пытается отправить письмо через менее приоритетные сервера, найденные в DNS для этого адреса. Эта настройка заставляет программу отправлять письма только через сервера с наивысшим приоритетом и не пробовать другие сервера, если он недоступен.

Доставлять через провайдера (ISP) после X попыток

Если за указанное число попыток письмо не удастся доставить на сервер получателя, то оно автоматически будет доставлено через почтовый сервер провайдера. Это удобней, чем включать режим “Доставка через ISP” вручную.

Настройки SMTP сервера провайдера

В меню Монитора («Отправка” -> “Доставка через ISP») Вы можете переключить прямую отправку (с Вашего компьютера на сервер получателя письма) на доставку через почтовый сервер провайдера (ISP). Это полезно, когда почтовые сервера Ваших получателей временно недоступны и Вы не имеете постоянного подключения к Интернет.

Сервер

Сервер исходящей почты (SMTP) Вашего провайдера. Может быть задан доменом или адресом IP. Примеры: smtp.isp.com, 195.2.83.112. Особенность: если указано NULL вместо имени сервера (для программистов: в данном случае это строка, а не указатель ;-), тогда письмо, при попытке доставить его через сервер провайдера, сразу попадет в папку “Плохие”. Например, совместно с настройкой “Доставлять через провайдера после X попыток” Вы можете выбрасывать сообщения, которые не удалось доставить за X попыток; совместно со списком задержек Вы сможете заблокировать некоторые почтовые домены. Вторая особенность: Вы можете задать до пяти серверов провайдера через запятую (например, “smtp.isp.com, mx1.isp.com, mx2.isp.com»). Обратите внимание, что все сервера должны иметь одинаковый порт и одинаковые настройки аутентификации.

Порт

TCP-порт сервиса. Обычно, это 25. Не путайте, пожалуйста, сервис SMTP с POP3 или NNTP, которые обычно расположены на портах 110 и 119.

Использовать аутентификацию на сервере SMTP

Обычно сервера SMTP не требуют аутентификации, в отличии от POP3 и IMAP4 серверов. ADR поддерживает только аутентификацию типов PLAIN и LOGIN, другие схемы в данный момент не реализованы.

Логин

Логин или имя пользователя сервера SMTP. Включите “Использовать аутентификацию” чтобы окно ввода стало доступным.

Пароль

Пароль для доступа к серверу SMTP. Включите “Использовать аутентификацию” чтобы окно ввода стало доступным.

Настройка Advanced Direct Remailer


Настройка внутреннего сервера
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Внутренний почтовый сервер (SMTP) принимает почту от почтовых программ и помещает ее в очередь исходящих писем в папке “Исходящие”. Более подробно о сервере – в статье “Почтовый сервер и почтовые ящики”.

TCP порт сервера

TCP-порт, на котором расположен сервер, по умолчанию – 25. Не рекомендуется изменять номер этого порта, так как почтовые программы по умолчанию подключаются именно к этому порту. Если Вы изменили номер порта, Вам придется внести изменения и в настройки почтовой программы.

Разрешенные IP

Маски IP адресов, с которых можно соединяться с внутренним почтовым сервером. Если Вы хотите, чтобы к Вашему серверу могли подключаться и слать через него письма с любого компьютера в Интернет, то поставьте маску *.*.*.*, если у Вас локальная сеть с диапазоном адресов 10.1.1.1-10.1.1.255, то поставьте маску 10.1.1.*. Вы можете перечислить несколько масок через запятую, например, 127.0.0.1, 10.*.*.*. Адрес 127.0.0.1 – это IP адрес Вашего локального компьютера; по этому адресу нельзя обратиться к компьютеру извне, так как этот адрес всегда и везде является адресом локального компьютера.

Интерфейс сети

Можно указать один сетевой интерфейс, на котором программа будет принимать соединения (bind). Например, при указании интерфейса 127.0.0.1, программа будет принимать соединения только с локальной машины. Данный способ менее гибок, чем маски IP адресов, но зато позволяет запустить несколько серверов SMTP, каждый на своем сетевом интерфейсе. Если поле пустое, то соединения принимаются на всех доступных интерфейсах.

Локальный домен

Локальный домен почтового сервера, рекомендуется заменить на Ваш почтовый домен. Все письма, отправленные не на этот домен, почтовый сервер будет пропускать как сквозные. Если Вы заменили домен сервера на elcomsoft.com, то чтобы Ваше письмо попало в локальный ящик maillist, Вам нужно отправить его на адрес maillist@elcomsoft.com.

Клудж X-Server

Содержимое строки X-Server, добавляемой в заголовок каждого письма. Если строка не введена, то клудж в письмо не добавляется.

Ставить получателя в “To:”, а не адрес списка

Обычно при послылке письма на список рассылки в поле “To:” остается адрес списка. ADR может заменять этот адрес на адрес реального получателя письма. Если в качестве списка рассылки используется файл CSV, то ADR подставляет только адрес электронной почты получателя. Если используется LST или TXT файл, то подставляется ВСЯ СТРОКА с данным адресом электронной почты. Более подробно читайте в описании формата списков рассылки.

Детальные журналы с протоколом SMTP

Эта опция включает полную запись протокола SMTP (за исключением тел передаваемых писем) в журнал сервера.

Использовать аутентификацию (RFC 2554)

Установить имя и пароль для доступа ко внутреннему почтовому серверу. ADR поддерживает схему аутентификации PLAIN (используется Netscape Messenger) и LOGIN (описана в RFC 2554, используется Microsoft Outlook, Microsoft Outlook Express и TheBat!).

Разрешить команду EXPN

Эта команда сервера SMTP позволяет получать адреса из списков рассылки по его имени. Например, пример сессии TELNET с запросом адресов из списков ящика “simple”, созданного при установке ADR:

220 Advanced Direct Remailer ESMTP is Ready

expn simple

220-recycled1@pisem.net

220-recycled2@pisem.net

220-recycled3@pisem.net

220-recycled4@pisem.net

220 recycled5@pisem.net

quit

221 Service closing transmission channel

ADR также имеет четыре виртуальных списка: @outbox, @sent, @bad и @stat. Запрос списка @outbox вернет адреса всех получателей, письма к которым находятся в ящике Outbox. Запрос списка @stat вернет общую статистику по всем ящикам:

220 Advanced Direct Remailer ESMTP is Ready

expn @stat

220-Outbox: 0

220-Sent: 41

220-Bad: 0

220-In delivery: 0

220 State: delivery stopped

quit

221 Service closing transmission channel

По умолчанию команда EXPN отключена в целях безопасности.

Настройка Advanced Direct Remailer


Настройка почтовых ящиков
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Внутренний почтовый сервер (SMTP) принимает почту от почтовых программ и помещает ее в очередь исходящих писем в папке “Исходящие”. Помимо того, что внутренний почтовый сервер осуществляет связь почтовой программы и ADR, он имеет еще одну важную функцию – поддержку списков рассылки. Более подробно о сервере и идеологии почтовых ящиков – в статье “Сервер и почтовые ящики”.

Добавлять и удалять почтовые ящики, добавлять к ящикам списки рассылки и пользовательские программы обработки (плагины) Вы можете либо при помощи панели кнопок, либо щелкнув правой кнопкой мыши по дереву элементов.

При установке программа создает несколько примеров почтовых ящиков.

Настройка Advanced Direct Remailer


Настройка подключения через прокси

EMMA Labs web site

Navigation: Настройка программы:

Настройка прокси
No contents entries on this page
Contents
Topic functions menu
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Подключаться через прокси-сервер Socks v5

Прокси сервер - это специальная программа, позволяющая пользователям локальной сети работать с Интернет. Обратитесь, пожалуйста, к администратору Вашей локальной сети, если у Вас возникают проблемы с настройкой программы. По протоколу Socks5 работает в локальной сети такая популярная программа, как ICQ. Если Вы используете прокси-сервер, то строго рекомендуется указать домен прокси сервера в настройках доставки почты.

Адрес

Адрес прокси сервера. Может быть как доменом, так и IP-адресом. Примеры: proxy.isp.com, 10.1.1.1.

Порт

Порт сервера. Обычно, это порт 1080. Очень многие путают Socks5-proxy с http-proxy и ftp-proxy и указывают, соответственно, номер порта 3128 или 3121. Через http-proxy или ftp-proxy программа работать не будет.

Использовать аутентификацию (RFC 1929)

Сервер требует авторизацию – предъявить имя и пароль пользователя. Большинство реализаций прокси-серверов Socks5 поддерживают простейшую реализацию, в которой имя и пароль передаются открытым текстом, как описано в документе RFC 1929.

Логин

Имя или логин пользователя прокси-сервера Socks5.

Пароль

Пароль пользователя прокси-сервера Socks5.

Маппинг для DNS

Использовать маппинг (отображение) портов для работы с DNS по протоколу UDP. Некоторые реализации прокси-серверов, например, WinGate 3.0 некорректно работают по протоколу UDP, и использовать маппинг в таком случае необходимо. Если Ваш прокси сервер имеет адрес 10.1.1.1, то отобразите UDP-порт 53 первого DNS, например ns.ml.org, на локальный порт 53, а порт второго DNS – на локальный порт 54. И в настройках DNS укажите эти адреса – 10.1.1.1 и 10.1.1.1:54 (порт 53 используется по умолчанию).

Настройка Advanced Direct Remailer


Настройка ведения журналов
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Хранить записи несколько дней

ADR поддерживает автоматическое обрезание журналов работы (не журнала отправки письма!), расположенных в каталоге \log. ADR обрезает журналы один раз в день, оставляя в журналах записи за указанное число дней. ADR ведет шесть журналов работы:

·ОБЩИЙ – с общей информацией о функционировании системы;

·СЕРВЕРА – журнал внутреннего SMTP-сервера, прием писем;

·ТОССЕРА –информация об обработке принятых писем;

·ДОСТАВКИ – журнал о ходе отправки писем и состоянии очередей;

·SQL – журнал с информацией о SQL-списках рассылки;

·ОШИБОК – служебная информация о возникающих в системе ошибках.

·АДРЕСНЫХ КНИГ – журнал о работе с адресными книгами Windows (.WAB).

Рекомендуется использовать обрезание журналов для экономии дискового пространства.

В журнале письма только последняя запись

Если опция не включена, в журнал будут записываться все попытки доставить письмо.

Отключить журналы программы, кроме сообщений

Отключает ведение всех перечисленных выше журналов, за исключением журнала доставки сообщений.

Отключить журналы сообщений

Пункт меню “Письмо” / “Журнал” станет недоступным.

Записывать время событий в журнал письма

В журнал доставки сообщения будет записано время, когда получена каждая строка. Полезно для определения источника проблем со скоростью доставки почты.

Программа просмотра

Для просмотра журналов работы, запускаемого через меню “Журнал” окна монитора, используется внешняя программа. Здесь необходимо указать путь к программе, которой в командной строке будет передано имя файла с журналом. Запускаемый файл программы также можно найти, воспользовавшись кнопкой “Файл…”. По умолчанию используется программа Notepad (Notepad.exe).

Настройка Advanced Direct Remailer


Настройка почтовых программ
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Единственная настройка в почтовой программе, которую Вам предстоит изменить - это адрес сервера исходящей почты (SMTP). Почтовая программа получает почту с почтового сервера, работающего по протоколу POP3, а отправляет Ваши письма через сервер, работающий по протоколу SMTP. Изменять адрес сервера входящей почты (POP3) не требуется, так как Вы продолжаете получать почту через сервер Вашего провайдера.

Если Вы установили ADR на свой компьютер, то новый адрес почтового сервера - localhost или 127.0.0.1. Если Вы установили ADR на компьютер в локальной сети, например имеющий адрес 10.1.1.1, то новый адрес почтового сервера - 10.1.1.1. Во всех примерах ниже мы будем считать, что Вы установили программу на свой компьютер и будем использовать адрес 127.0.0.1

Обычно, настройка почтовой программы не вызывает трудностей и занимает одну-две минуты. В описании настройки программ предполагается, что Ваша почтовая программа уже настроена для работы с почтой и приводятся описания необходимых изменений для работы через ADR. Если это не так, то вначале настройте программу для работы через почтовый сервер провайдера, а потом сделайте описанные изменения.

Настройка Microsoft Outlook Express, Настройка The Bat, Настройка Mozilla ThunderBird


Настройка Microsoft Outlook Express / Windows Mail / Windows Live
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Приводится описание настройки Outlook Express версии 5.0, более ранние версии Outlook Express ничем в настройке не отличаются. В меню "Tools" выберите пункт "Accounts...". В появившемся окне "Internet Accounts" перейдите на закладку "Mail", как показано на рисунке.

Выберите учетную запись, которую Вы хотите настроить для работы через ADR и нажмите кнопку "Properties". Если Вы имеете несколько учетных записей для почты и хотите настроить их все для работы с ADR, то Вам придется выполнить описываемую здесь операцию несколько раз. В появившемся окне "account name Properties" перейдите на закладку "Servers". Измените адрес "Outgoing mail (SMTP)" на localhost (см. рисунок ниже). Нажмите кнопку "Apply" и настройка закончена! Теперь можно отправить тестовое письмо с настроенной учетной записи.

Замечания:

1.Если Вы изменили TCP порт сервера ADR с 25 на любой другой, то измените номер порта SMTP сервера на закладке "Advanced".

2.Если Вы использовали защищенное соединение SSL/TLS для соединения с SMTP сервером, то снимите соответствующий флажок на закладке "Advanced". ADR не поддерживает защищенное соединение.

Настройка почтовых программ


Настройка The Bat
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Настройка The Bat описана на примере версии 1.34. Выберите аккаунт, который Вы хотите настроить, и в меню "Account" выберите пункт "Properties...". В появившемся окне "Edit User - Имя Пользователя" перейдите на раздел настроек "Transport", как показано на рисунке. Если Вы хотите настроить все аккаунты для работы через ADR, то Вам придется выполнить описанную ниже операцию несколько раз.

Измените поле "SMTP Server" на 127.0.0.1 Нажмите кнопку "OK" и настройка закончена! Теперь можно отправить тестовое письмо с настроенной учетной записи.

Замечания:

1.Если Вы изменили TCP порт сервера ADR с 25 на любой другой, то измените номер порта SMTP сервера в разделе настроек "Mail management".

2.Если Вы использовали аутентификацию для работы с SMTP сервером, то нажмите кнопку "More..." в разделе настроек "Transport" и отключите ее. ADR не требует аутентификации.

Настройка почтовых программ


Настройка Mozilla Thunderbird
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Описание настройки программы дается на базе версии 4.61. Выберите в меню "Edit" пункт "Preferences...". В открывшемся окне "Preferences" перейдите на ветвь "Mail & Newsgroups -> Mail Servers", как показано на рисунке. Измените значение "Outgoing mail (SMTP) server" на localhost. Нажмите кнопку "OK" и настройка закончена! Теперь можно отправить тестовое письмо.

Замечания:

1.Если Вы использовали защищенное соединение SSL или TSL, то Вы должны отключить защиту выбрав "None", как показано на рисунке. ADR не поддерживает защищенное соединение.

Настройка почтовых программ


Введение
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Программист получает с ADR две мощных возможности – возможность выполнять почтовую рассылку не углубляясь в тонкости программирования сокетов и возможность создавать собственные программы обработки писем (плагины).

· Простая генерация писем для ADR

· Система плагинов

Начиная с версии 2.0, ADR имеет COM интерфейс. COM это объектная модель на которой построены управляющие элементы ActiveX и OLE. COM позволяет объектам предоставлять их функциональность другим компонентам и приложениям. COM определяет связь объектов, взаимодействие объектов между процессами и сетями. Теперь Вы можете использовать возможности Advanced Direct Remailer в любом языке программирования и в любом программном обеспечении поддерживающем COM.

Теперь Вы можете использовать отправку писем через ADR в Microsoft Visual C++, Borland Delphi, CBuilder и Microsoft Visual Basic и из множества других средств разработки. Вы можете использовать сервис ADR на своих веб-страницах ASP (Active Server Pages, Microsoft Technology) и ColdFusion. Вы можете работать с ADR установленным на другом компьютере через DCOM (Distributed COM Service). И вы можете взаимодействовать с локальной копией ADR из VBScript и JavaScript. Вы можете все!

· Интерфейс COM/ActiveX IAdrMessage

· Методы интерфейса IAdrMessage

· Типичный код программы

· Примеры и исходные тексты

Форматы списков рассылки


Простая генерация писем для ADR
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Ваша программа может просто генерировать текстовые файлы с письмами и подкладывать их в каталог MAIL\OUT, возложив на Advanced Direct Remailer отправку писем. Письма имеют следующий формат:

>>> you@yourisp.com

<<< recipient@recipient.com

From: "You" <you@yourisp.com>

To: <recipient@recipient.com>

Subject: TEST!

Dear Recipient, it is test !

.

В первой строке – адрес отправителя письма, во второй – адрес получателя. После пустой строки идет тело письма, заканчивающееся точкой с переводом строки. Рекомендуется посмотреть исходящие письма в каталоге MAIL\OUT, чтобы узнать, какие еще поля к заголовку письма добавляют почтовые программы и подробней ознакомиться с форматом писем.

После того, как Ваша программа сгенерировала письма, нужно чтобы ADR перечитал каталог OUT и добавил письма в очередь исходящих сообщений. ADR не делает это постоянно, так как сканирование каталога может достигать десятков секунд и приводить к сильной загрузке системы из-за интенсивной работы с диском. Сканирования каталога можно добиться тремя способами:

1.Перезапустить ADR

2.Запустить программу Utils\Sync\Sync.exe

3.Послать сообщение окну ADR.

При получении окном ADR сообщения WM_USER+5 программа сканирует заново каталог OUT. Программа Sync.exe вызывает новое сканирование каталога OUT также посылкой этого сообщения, Вы можете посмотреть ее исходный текст в файле Utils\Sync\Sync.c, он состоит буквально из нескольких строк.

Если ADR настроен так, что запустить отправку почты можно только вручую, то Вы можете также послать окну ADR сообщение WM_USER+6, чтобы ADR начал отправку почты или запустить программу Utils\Mailing\Mailing.exe, ее исходный код также находится в этом каталоге. Мы будем рады услышать Ваши предложения по развитию Advanced Direct Remailer API.

Информация для программистов


Система плагинов
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

С идеологией пользовательских программ обработки писем (плагинов) Вы можете познакомиться в статье “Сервер и почтовые ящики”. Плагин – это программа или командный файл, вызываемый для обработки письма. Полное имя файла с письмом передается плагину в качестве первого аргумента командной строки. Плагин может модифицировать письмо так, как ему вздумается и даже стереть его, если это нужно.

Все плагины, поставляемые с Advanced Direct Remailer, поставляются с исходными текстами на языке C или Delphi. Вы можете изучать их и свободно модифицировать.

Плагины для ADR могут быть написаны на любом языке программирования, они могут быть оконными или консольными приложениями и даже командными файлами. При разработке плагинов следует иметь в виду, что плагин запускается последовательно для обработки каждого письма и пока обработка предыдущего письма не завершена, то обработка следующего не начинается.

О DLL-версиях плагинов, Локальный почтовый сервер и почтовые ящики, Информация для программистов


Интерфейс COM/ActiveX IAdrMessage

EMMA Labs web site

Navigation: Информация для программистов > Интерфейс COM/ActiveX:

Интерфейс IAdrMessage
No contents entries on this page
Contents
Topic functions menu
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Интерфейс IAdrMessage компонента “Advanced Direct Remailer Component 1.1” позволяет передавать письма для дальнейшей доставки средствами Advanced Direct Remailer. Фактически, ADR теперь может принимать письма тремя различными способами:

· Через встроенный сервер SMTP

· Через файлы, создаваемые на диске

·Через интерфейс COM/ActiveX

IAdrMessage - это дуальный интерфейс (dual-interface). Так, вы можете использовать сервис ADR через disp-интерфейс (Visual Basic, JavaScript, ASP) или через vtbl-интерфейс (Microsoft Visual C++, Borland Delphi). С программой поставляются исходный код примеров, использующих оба метода.

Стандартный заголовок C++ для интерфейса Вы можете найти в файле

COM Samples\ADR_MFC\adr_h.h

в подкаталоге Advanced Direct Remailer.

Методы интерфейса, Примеры и исходные тексты,Типичный код программы


Методы интерфейса IAdrMessage
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

virtual /* [propput] */ HRESULT __stdcall put_Kludges(/* [in] */ BSTR bstrKludges);

Необязательный для вызова метод. Добавляет строки служебной информации в заголовок письма. Каждая строка должна обязательно завершаться последовательностью CRLF (перевод строки, символы с кодами 13 и 10).

Примеры:

X-Mailer: MyApplication

X-Mailer-Version: 1.0

Возвращаемое значение – S_OK. При недостатке памяти для сохранения переданного значения возвращается код E_FAIL.

virtual /* [propput] */ HRESULT __stdcall put_From(/* [in] */ BSTR bstrEmail);

Задает адрес отправителя письма. Вы можете задавать адрес в любом известном формате, например.:

support@elcomsoft.com

Support <support@elcomsoft.com>

“Alex Gorlach” <gorlach@mailutilities.com>

Возвращаемое значение – S_OK. При недостатке памяти для сохранения переданного значения возвращается код E_FAIL. Данная функция не проверяет правильность синтаксиса адреса. Правильность установленных значений проверяет метод Send (см. ниже).

virtual /* [propput] */ HRESULT __stdcall put_To(/* [in] */ BSTR bstrEmail);

Задает адрес получателя письма. Вы можете задавать адрес в любом известном формате, например.:

support@elcomsoft.com

Support <support@elcomsoft.com>

“Alex Gorlach” <gorlach@mailutilities.com>

Возвращаемое значение – S_OK. При недостатке памяти для сохранения переданного значения возвращается код E_FAIL. Данная функция не проверяет правильность синтаксиса адреса. Правильность установленных значений проверяет метод Send (см. ниже). Вы можете задать только один адрес получателя. Если необходимо отправить письмо нескольким адресатам, то следует соответствующее число раз установить получателя и вызвать Send (см. ниже).

virtual /* [propput] */ HRESULT __stdcall put_Subject(/* [in] */ BSTR bstrSubject);

Необязательный для вызова метод. Задание поля “Тема” письма. Обратите внимание, что Вы сами должны обеспечивать соответствие кодировки письма и темы. ADR записывает полученную строку в поле “Тема” письма в том виде, в каком он ее получил. Возвращаемое значение – S_OK. При недостатке памяти для сохранения переданного значения возвращается код E_FAIL.

virtual /* [propput] */ HRESULT __stdcall put_Body(/* [in] */ BSTR bstrBody);

Необязательный для вызова метод. Задание тела письма. Обратите внимание, что Вы сами должны обеспечивать кодирование письма в национальные кодировки. ADR записывает полученный текст в тело письма в том виде, в каком он его получил. Размер письма не ограничен. Возвращаемое значение – S_OK. При недостатке памяти для сохранения переданного значения возвращается код E_FAIL.

virtual HRESULT __stdcall Reset( void);

Необязательный для вызова метод. Сброс всех значений, устанавливаемых перечисленными выше функциями. Возвращаемое значение – S_OK.

virtual HRESULT __stdcall Send( void);

Отправка письма. Перед вызовом этого метода должны быть установлены поля “To” и “From” письма, остальные поля могут быть пустыми. Отправка не вызывает сброса установленных значений (для этого есть метод Reset), и два последовательных вызова Send отправят два одинаковых сообщения, отличающиеся только временем создания. Для рассылки письма по списку надо установить все поля, а потом вызывать пары методов put_To – Send для каждого получателя.

Возвращаемые значения:

S_OK – письмо успешно отправлено;

S_FALSE – письмо отправить не удалось.

Во втором случае можно вызвать метод get_LastError чтобы узнать причину неудачи (см. ниже).

virtual /* [propget] */ HRESULT __stdcall get_LastError(/* [retval][out] */ long __RPC_FAR *lCode);

Необязательный для вызова метод. Записывает в переданную переменную код последнего вызова метода Send. Возможные значения:

CAE_NO_ERROR (значение 0) – вызовов Send не было, или при последнем вызове письмо было успешно отправлено;

CAE_INAVLID_SENDER (1) – неправильный адрес электронной почты отправителя письма, или адрес не был задан перед вызовом Send;

CAE_INAVLID_RECIPIENT (2) – неправильный адрес электронной почты получателя письма, или адрес не был задан перед вызовом Send;

CAE_FILE_ERROR (3) – произошла ошибка при записи письма в файл на диске, информация о такой ошибке также попадает в журнал ошибок ADR;

CAE_NO_MEMORY (4) – во время отправки письма не удалось получить требуемый объем памяти.

Число кодов ошибок может увеличиться в следующих версиях ADR. Все коды больше CAE_NO_MEMORY (lCode = 4) должны обрабатываться приложением как “неизвестная ошибка”.

Возвращаемое значение – S_OK.

Типичный код программы


Типичный код программы
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

var msg, result;

msg = new ActiveXObject('AdvancedDirectRemailer.AdrMessage');

msg.From = ‘Alexander Gorlach <gorlach@mailutilities.com>';

msg.To = ‘Vladimir Katalov <vkatalov@elcomsoft.com>';

msg.Subject = ‘Sorry, it is test!’;

msg.Body = ‘Hello!\r\nIt is test…’;

msg.Kludges = 'X-Source: web mail\r\nX-Form: AdrMsg.html\r\n';

msg.Send();

switch (msg.LastError)

{

case 0: result = "Message was successfully sent"; break;

case 1: result = "Invalid sender email"; break;

case 2: result = "Invalid recipient email"; break;

case 3: result = "File read/write error"; break;

case 4: result = "Not enough memory"; break;

default: result = "Unknown error";

}

Примеры и исходные тексты


Интерфейсы конфигурирования и управления
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

В версию 2.12 было добавлено восемь новых COM/ActiveX интерфейсов для управления и конфигурирования Advanced Direct Remailer из других приложений. Семь интерфейсов обеспечивают доступ к закладкам настроек:

IAdrGeneral – к свойствам закладки “Общие”.

IAdrActions – к свойствам закладки “Задания”.

IAdrDns – к свойствам закладки “DNS”.

IAdrDelivery – к свойствам закладки “Доставка”.

IAdrServer – к свойствам закладки “Сервер”.

IAdrProxy – к свойствам закладки “Прокси”.

IAdrLogs – к свойствам закладки “Журналы”.

Через интерфейсы невозможно получить доступ только к закладке настроек “Ящики”. Восьмой интерфейс – IAdrControl – обеспечивает средства управления Advanced Direct Remailer. При помощи методов этого интерфейса можно управлять доставкой (запускать, останавливать, направлять поток почты через провайдера), SMTP-сервером программы, перезагружать настройки программы из реестра Windows и сохранять их, синхронизировать ящики, узнавать состояние программы и прочее. Смотрите пример AdrCntr использования этих интерфейсов. Методы интерфейсов можно узнать через библиотеку типа компонента или заголовочный файл adr_h.h, поставляемый с примером Adr_MFC.

Примеры и исходные тексты


Примеры и исходные тексты
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

В подкаталоге COM каталога с ADR Вы можете найти несколько примеров с полным исходным текстом. Обратите внимание, что запуск некоторых примеров (особенно, примера 5) может потребовать настройки прав доступа к компоненту “Advanced Direct Remailer Component 1.1”. Это можно сделать при помощи утилиты DCOMCNFG.EXE, входящей в состав операционной системы. В общем случае, если ADR запущен как обычное приложение (а не как сервис Windows NT), то для запуска примеров 1..4 и 6 никаких дополнительных настроек не требуется.

1.AdrVB6 - пример программы на Microsoft Visual Basic 6.

2.AdrVC – пример программы на Microsoft Visual C++ 6, чистый Win32 API.

3.AdrDelphi3 – пример программы на Borland Delphi v3.

4.AdrMsg.html – пример на JavaScript, исполняющийся на стороне клиента. Требуется Microsoft Internet Explorer 3.0 или выше.

5.AdrMsg.asp - пример на ASP (Active Server Pages, Microsoft Technology), исполняющийся на стороне веб-сервера под управлением Microsoft IIS.

6.AdrCntr - пример на Microsoft Visual Basic демонстрирует использование интерфейсов конфигурирования и управления.

Типичный код программы


Перенос почтовых папок в другой каталог
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

По умолчанию, папки с сообщениями (Исходящие, Отправленные, Плохие) находятся в подкаталоге Advanced Direct Remailer. Вы можете перенести эти и другие папки в любой другой каталог, задав их пути в секции реестра Windows HKEY_LOCAL_MACHINE\Software\MailUtilities\Advanced Direct Remailer. Обратите внимание, что указанная папка должна существовать и путь к ней должен быть задан с завершающей косой чертой (\). Ключи реестра:

@SystemLogFolder – папка где ADR хранит журналы работы, по умолчанию это подкаталог \logs каталога с Advanced Direct Remailer.

@MailFolder – подкаталог \mail, где находятся папку Исходящие (\mail\out), Отправленные (\mail\sent) и т.д. Изменив этот параметр, Вы можете перенести всю иерархию папок. Вы также можете перенести папки по отдельности, см. ниже.

@OutboxFolder – папка для исходящих сообщений (\mail\out).

@SentFolder – папка с отправленными сообщениями (\mail\sent).

@BadboxFolder – папка с “плохими” сообщениями (\mail\bad).

@SpoolFolder – специальная папка для тоссера сообщений (\mail\spool).

@LogFolder – папка, где хранятся журналы сообщений (\mail\log).

Чтобы вернуть папки на старое место, просто удалите данные ключи из реестра Windows.

Информация для программистов


Настройка кодов ответа SMTP сервера
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Некоторые сервера SMTP обрабатывают тело письма и могут отвергнуть сообщение после передачи тела письма (после команды DATA). В RFC 821 даны следующие коды для этой ситуации:

552 Requested mail action aborted: exceeded storage allocation

554 Transaction failed

451 Requested action aborted: error in processing

452 Requested action not taken: insufficient system storage

И ни один из этих кодов не означает, что ошибка критическая и сообщение доставить не удастся. И ADR будет пытаться доставить сообщение еще и еще. В версии 1.42 в реестр была добавлена переменная типа DWORD с названием DataBreakCode. По умолчанию она не установлена. Младшие и старшие слова этой переменной содержат коды ответа SMTP сервера после команды DATA, при получении которых ADR выбросит сообщение в папку “Плохие” и прекратит попытки его доставить.

Информация для программистов


Другие настройки
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Некоторые настройки ADR по ряду причин можно сделать только через реестр (программой REGEDIT.EXE операционной системы). Все ключи, описываемые ниже, должны быть помещены в секции реестра Windows HKEY_LOCAL_MACHINE\Software\MailUtilities\Advanced Direct Remailer. Ключи вступают в действие после перезапуска ADR. Для отмены действия ключей нужно удалить их из реестра и перезапустить ADR.

Ключ CsvDelimeter

Тип – строка. Если этот ключ задан, то ADR использует первый символ строки как разделитель в файлах CSV (Comma Separated Values). В противном случае, используется символ заданный в региональных настройках системы.

Ключ SafeSockRead

Тип - DWORD. Некоторые почтовые клиенты имеют неправильную реализацию SMTP-клиента, отправляя несколько команд внутреннему почтовому серверу ADR не дожидаясь его ответов (например, Bounce Spam Mail v1.8). Установка этого ключа в 1, заставляет ADR более “осторожно” (но и более медленно) работать с почтовыми клиентами. Мы пока не знаем ни одной программы кроме Bounce Spam Mail v1.8, которая бы требовала включение этой настройки.

Ключ ServerAuthUseLogin

Тип – DWORD. Выбор схемы аутентификации для работы с почтовым сервером провайдера. Почтовый сервер, использующий аутентификацию, должен сообщать почтовому клиенту о поддерживаемых им типах аутентификации (ADR поддерживает схемы PLAIN и LOGIN). Если почтовый сервер не сообщает о поддерживаемых схемах, но аутентификация требуется, то ADR по умолчанию использует схему PLAIN. Установите этот параметр в 1, чтобы ADR использовал по умолчанию схему LOGIN.

Ключ MailOkWav

Тип – строка. Задает полный путь к звуковому файлу в формате WAV, который будет проигран вместо стандартного звука когда вся почта будет доставлена (если включена соответствующая опция на закладке “Общие»).

Ключ MailBadWav

Тип – строка. Задает полный путь к звуковому файлу в формате WAV, который будет проигран вместо стандартного звука когда одно из сообщений попало в папку “Плохие” (если включена соответствующая опция на закладке “Общие»).

Ключ HELOCmd

Команда приветствия удаленного сервера. В качестве значения может быть задана команда EHLO или HELO, по-умолчанию используется EHLO. Также здесь может быть задана вся строка приветствия целиком, например, “HELO mydomain.com”. Значение этой переменной проверяется при отправке каждого письма.

Перенос почтовых папок, Настройка кодов


Утилита AdrSplit
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Максимальное число адресов в одном списке рассылки, поддерживаемом ADR - 1000000. Если Ваши файлы больше, Вы должны разделить из на части и можете сделать это при помощи данной утилиты. AdrSplit находится в подкаталоге Utils каталога с Advanced Direct Remailer.

Синтаксис:

ADRSPLIT.EXE lines input_file

Где lines это максимальное число адресов в выходном файле, input_file это файл, который Вы хотите разрезать. Выходные файлы будут сохранены в одном каталоге со входным файлом, и будут иметь имена вида input_file.NNN, где NNN это номер части.

Примеры:

ADRSPLIT.EXE 1000 my.lst

ADRSPLIT.EXE 10000 “C:\Program Files\Eserv\forward.lst”

Для объединения частей в один файл, используйте команду COPY. Например:

COPY my.lst.001+my.lst.002+my.lst.003 my_checked.lst

COPY my.lst.0?? my_checked.lst

Утилита AdrNoDup, Описание программы


Утилита AdrNoDup
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Эта программа предназначена для удаления дублирующихся адресов электронной почты из списков рассылки. AdrNoDup находится в подкаталоге Utils каталога с Advanced Direct Remailer.

Синтаксис:

ADRNODUP.EXE infile outfile

Где infile это исходный список рассылки, outfile это выходной файл.

Примеры:

ADRNODUP.EXE customers.lst cust_clean.lst

ADRNODUP.EXE "C:\Program Files\My List.txt" mylst.txt

Утилита AdrSplit, Описание программы


Утилита TestDLL
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Эта утилита предназначена для программистов. Вы можете тестировать ей DLL-плагины без Advanced Direct Remailer.

Синтаксис:

TestDLL.EXE plugin.dll File1.msg [File2.msg … [FileN.msg]]

Где:

Plugin.dll – тестируемый плагин;

File1.msg – файл с письмом в формате ADR.

Примеры:

TestDLL.EXE sendnum.dll 111ix5l-000-0000.msg

TestDLL.EXE msgid.dll 1.msg 2.msg 3.msg 4.msg

Программа загружает плагин для теста методом ADR и обрабатывает им указанный файл. Утилита вместе с исходным кодом находится в подкаталоге utils.

О DLL-версиях плагинов


Регистрация
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Регистрация программы платная После регистрации программы Вам будет выслан ключ, который снимет с программы все ограничения. Ключ будет работать и со всеми будущими минорными версиями Advanced Direct Remailer.

Наша компания принимает все виды оплаты от физических и юридических лиц, предоставляя покупателям необходимые для отчетности финансовые документы. Перейти на страницу регистрации программы можно по прямой ссылке http://www.massmail.ru/purchase/

Преобретая программу легально, Вы стимулируете автора развивать и совершенствовать программу, которая нужна Вам, помогаете создавать в России цивилизованный рынок программного обеспечения.


Ограничения незарегистрированной копии
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Незарегистрированная копия ADR полностью функциональна и имеет ограничение только по времени использования. Вы можете использовать программу в течении 30 дней бесплатно. Если Вы хотите использовать ее и дальше, то Вы должны ее зарегистрировать.

После регистрации программы Вы получите регистрационный код, который уберет ограничения. Регистрационный код будет работать со всеми будущими минорными версиями ADR (если система регистрации по каким-либо причинам поменяется, Вам будет выслан новый код).

Регистрация программы, Техническая поддержка


Сайт в Интернет
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

На веб-сайте вы можете узнать последние новости, подписаться на список рассылки о программе и скачать последнюю версию программы. Помимо Advanced Direct Remailer, на нашем сайте Вы найдете еще несколько полезных программ:

Advanced Email Extractor

Advanced Direct Remailer

High Speed Verify

Mailing List Wizard

и другие.

Не забывайте заходить на наш сайт, мы всегда рады видеть вас! Пожалуйста, обращайтесь в службу технической поддержки, если у вас возникли вопросы, предложения или пожелания.


Техническая поддержка
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Мы обещаем ответить на ваше письмо, если Вы будете придерживаться следующих правил, когда обращетесь в службу технической поддержки:

·Если Ваш вопрос касается некорректной работы программного обеспечения, то не забудьте сообщить версию операционной системы, пакета обновления и установленного Microsoft Internet Explorer.

·Пожалуйста, сообщите все дополнительные детали, какие сочтете нужными, чтобы разработчики могли в точности воспроизвести вашу ситуацию.

·Ознакомьтесь со списком в Интернет, возможно, что необходимое уже добавлено или исправлено в более новой версии.

·Уважайте чужое время. Мы знаем, где скачать самый лучший мейлер и знаем, почему ваша звонилка не ловит сигнал "занято". Но мы Вам этого не скажем.

·Если Вы зарегистрированный пользователь, то сообщите в письме Вашу регистрационную информацию. Это позволит нам обработать Ваш запрос быстрее.

Связаться со службой технической поддержки можно через web сайт. Также рекомендуем посетить наш сайт в Интернет, на котором можно найти дополнительную информацию о программе.


Advanced Email Extractor
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

EmEx 3 предназначен для сбора информации (e-mail адресов, номеров телефонов, номеров ICQ/MSN/Skype и многого другого) из публичных источников, размещенных в сети Интернет.

При создании EmEx были решены наиболее частые задачи, с которыми сталкивались пользователи нашего популярного продукта Advanced Email Extractor (AEE), а так же учтены новейшие технологии защиты e-mail адресов от подобного сбора.

Интерфейс пользователя стал проще и удобнее, а возможности программы - практически неограниченны.

Более 300 поисковых машин по всему миру могут обрабатывать ваши запросы. Мы постоянно отслеживаем актуальность баз данных скриптов для обработки результатов ответов от поисковых машин, поэтому вам не придется обновлять программу если поисковая машина изменила формат возвращаемых данных. При каждом запуске EmEx 3 вы получите обновленные настройки для поиска.

Посмотрите на краткий перечень возможностей EmEx 3 и убедитесь сами:

·Поиск как с заданного источника, так и по поисковым машинам

·Одновременный поиск по более чем 300 поисковым машинам мира

·Поддержка авторизации по HTTP или через веб форму

·Ограничение поиска по стране, доменной зоне или кодовой странице документа

·Гибко настраиваемый фильтр исключений

·"Черный" и "Белый" списки

·Список игнорируемых доменов

·Фильтр ключевых слов, поддерживающий логические выражения

·Фильтр ограничения активности запросов к сканируемым сайтам (анти-хаммер)

·Работа по расписанию

·Динамическая замена содержимого документа

·Маскировка по User-Agent

·Фильтрация по MIME типам

·Многопоточное сканирование, позволяющее обрабатывать до 50 ссылок одновременно

·Ограничение скорости загрузки

·Постоянно обновляемые скрипты для распознавания собираемой информации

·Использование прокси серверов

·Обновляемые списки прокси серверов1

·Возможность создания собственных схем для сбора информации2

·И многое другое!.

Вы можете загрузить пробную версию EmEx 3 с нашего веб-севера и попробовать ее в работе.


Advanced Maillist Verify
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Advanced Mail List Verify (AMV, ранее называвшаяся Check Email Pro) предназначена для проверки адресов электронной почты в базах данных, адресных книгах и списках рассылки. Новая версия ПО еще более тесно интегрируется в существующие системы за счет открытого интерфейса COM/ActiveX. С программой идут примеры интеграции Advanced Maillist Verify в веб сервера, построенные на технологии Active Server Pages корпорации Microsoft и технологии ColdFusion корпорации Allaire, примеры использования сервисов приложения из систем разработки Microsoft Visual C++, Borland Delphi, Microsoft Visual Basic и других.

Программа поддерживает все популярные форматы файлов, от простых списков рассылки до адресных книг Windows, умея не только показывать несуществующие адреса электронной почты, но и удалять их из файла-источника, создавать отдельные списки исключений. Поддержка ODBC SQL позволяет программе работать со всеми популярными СУБД (MS SQL, Oracle, MySQL, MS Access и другими) и даже с документами Microsoft Excel. Advanced Maillist Verify может удалить несуществующий адрес из базы данных, или пометить его в базе указанным способом, или добавить в таблицу колонку с результатами проверки.

ПО компании Твик Маркетинг не только позволит Вам сократить Ваш сетевой траффик, но и поддерживать целостность и актуальность списков Ваших клиентов. Программа удостоена высшей награды популярного архива TUCOWS, ZDNET, российского архива SOFTLIST и многих других. Вы можете загрузить программу с нашего сайта.


High Speed Verifier
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

High Speed Verifier (HSV) это высокоскоростная программа для проверки адресов электронной почты на существование, HSV может проверять до нескольких тысяч адресов в секунду. Программа прекрасно справляется со списками рассылки из нескольких десятков миллионов адресов; и более того - именно на списках такого объема достигается пиковая производительность программы.

HSV определяет около 20-30% несуществующих адресов в списке рассылки, при теоретически возможном определении программными методами до 60-70% несуществующих адресов. Эта цифра кажется относительно небольшой, но на практике она может составить около 10% от объема проверяемого списка. При этом HSV обеспечивает оптимальный по времени и сетевому трафику режим проверки. Более качественная проверка (позволяющая выявить остальные 40% несуществующих адресов) требует в десять раз больше времени и в пять раз больше сетевого трафика на каждый адрес, что делает качественную проверку не вполне целесообразной для списков большого объема.

Наша компания предлагает два программных продукта для проверки адресов электронной почты на существование — Advanced Maillist Verify (AMV), которая выполняет проверку в два этапа (DNS и SMTP), и High Speed Verifier (HSV), которая выполняет только первый этап проверки (DNS).

AMV предлагается как средство качественной проверки небольших (не более 50..100 тысяч адресов) списков рассылки. Advanced Maillist Verify также умеет проверять адреса в базах данных, адресных книгах популярных программ, имеет интерфейсы COM/ActiveX для интеграции в различное программное обеспечение и модули CGI/ISAPI для упрощенной интеграции в веб-сервера. Но технические принципы и заложенные в AMV интерфейсные решения не позволяют использовать программу для проверки списков большей длинны.

High Speed Verifier предлагается как решение для быстрого удаления мусора из многомиллионных списков. Ее производительность в силу число технических причин в 10..15 раз превосходит производительность AMV на небольших списках, а на списках с миллионами адресов производительность программ может уже отличаться в сотни раз. Рост производительности HSV при увеличении длинны проверяемого списка объясняется тем, что HSV кэширует в оперативной памяти результаты всех запросов к серверам DNS, и чем длиннее проверяемый список, тем выше процент попаданий в кэш.

High Speed Verifier — это первая профессиональная программа проверки больших списков адресов, созданная профессионалами для профессионалов. Мы надеемся, что использование HSV сделает Ваш бизнес более эффективным и успешным, а работа с программой окажется легкой и приятной.

Вы можете загрузить пробную версию HSV с нашего веб-севера и попробовать ее в работе.


Mailing List Wizard
No contents entries on this page
Menu
Go to previous topic
Go to home topic
This is the last topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Mailing List Wizard (MLW) поможет Вам выполнить обработку и преобразование списков рассылки. Программа умеет исключать из списков дублирующиеся адреса, исправлять неправильно написанные адреса по уникальным алгоритмам, фильтровать списки по разным критериям, объединять списки, делать исключение из списка адресов по дополнительному списку. MLW умеет обогащать список рассылки именами владельцев адресов по информации из других списков, удалять имена владельцев адресов из списков рассылки, сортировать адреса в списках рассылки и многое другое. MLW это одна программа, которая включила в себя функции сразу несколько программ по обработке списков рассылки.

Описание операций Mailing List Wizard:

·Удаление дублирующихся адресов

·Объединение двух списков

·Исключение адресов из списка

·Обогащение списка (добавление имен пользователей)

·Обеднение списка (удаление имен пользователей)

·Исправление неправильных адресов

·Фильтрация адресов по маскам, регулярным выражениям и подстрокам

·Сортировка адресов в списке рассылки

Вы можете загрузить пробную версию MLW с нашего веб-севера и попробовать ее в работе.


Значения разделенные запятыми (.CSV)

EMMA Labs web site

Navigation: »No topics above this level«

Значения разделенные запятыми (.CSV)
No contents entries on this page
Contents
Topic functions menu
Menu
This is the first topic
Go to home topic
This is the last topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Текстовый файл, разделенный запятыми (Comma Separated Values, *.csv). Реализован специально для пользователей Outlook Express. Вы можете экспортировать всю адресную книгу в текстовый файл, разделенный запятыми. Расширение этого файла должно быть CSV. В CSV-файлах используется только первый адрес электронной почты в строке. ADR использует разделитель значений заданный в региональных настройках Windows. Вы также можете переопределить этот символ в реестре ADR.

Начиная с версии 1.4, ADR поддерживает адресные книги Windows и теперь пользователи Outlook Express могут делать рассылку непосредственно по адресной книге, не прибегая к экспорту. Формат CSV также поддерживают электронные таблицы, например, Microsoft Excel.

Формат списков рассылки


Список серверов DNS

EMMA Labs web site

Navigation: »No topics above this level«

Список серверов DNS
No contents entries on this page
Contents
Topic functions menu
Menu
This is the first topic
Go to home topic
This is the last topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Время доступа к серверам DNS, используемых программой по умолчанию, у некоторых пользователей может составлять 2-3 секунды. Установка DNS Вашего провайдера может сократить это время до половины секунды. Программа пытается определить настройки DNS автоматически и показать их в “Системных настройках DNS” на закладке “DNS” в настройках программы. Также вы можете определить адреса DNS самостоятельно, запустив утилиту IPCONFIG с ключом /ALL под Windows NT или WINIPCFG утилиту под Windows 95/98. Эти утилиты входят в поставку операционной системы.

Также Вы можете использовать сервера DNS из этого списка, если Вы не можете в силу каких-либо причин получить адреса DNS Вашего провайдера или сервера провайдера работают нестабильно:

ns.worldnet.att.net                                                 AT&T-WorldNet (USA, www.worldnet.att.net)

nameserver.concentric.net                                 Concentric (USA, www.concentric.net)

arl-name-svc-1.compuserve.com                 CompuServe (USA, www.aol.com)

ns.psi.net                                                                 PSInet (USA, www.psi.net)

dns1.sympatico.ca                                                 Sympatico (Canada, www.sympatico.ca)

pns.dtag.de                                                                 T-Online (Deutschland, www.dtag.de)

dns-sol.swissonline.ch                                 SwissOnline (Switzerland, www.swissonline.ch)

main.piter.net                                                 PiterNet (Russia, www.piter.net)

Настройка DNS


Списки SQL (.SQL)

EMMA Labs web site

Navigation: »No topics above this level«

Списки SQL (.SQL)
No contents entries on this page
Contents
Topic functions menu
Menu
This is the first topic
Go to home topic
This is the last topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Эти списки создаются на лету по SQL запросу к базе данных через ODBC. Файл с SQL-запросом, который добавляется к почтовому ящику, должен иметь расширение .SQL и следующий формат:

<Источник данных ODBC>, <Пользователь>, <Пароль>, <Выражение SQL>

Если источник ODBC не требует аутентификации, то Вы должны оставить поля имени и пароля пустыми. Например:

Customers,Admin,KmiaN82,SELECT email FROM customers WHERE account>3000

FromSQL,,,SELECT name,email FROM customers WHERE email<>NULL

SQL-запрос может возвращать несколько колонок, при этом колонки одной строки будут формировать одну строчку списка рассылки. Между колонками при “склейке” добавляется пробел. Результатом запроса должен быть список с теми же ограничениями, что и простой текстовый список. Он может содержать только адреса электронной почты, но также может содержать и имена, которые будут подставлены в поле “To:” письма.

Использование SQL-списков совместно с плагином FromSQL дает возможность слияния базы данных с рассылкой. Рекомендуется посмотреть почтовый ящик Sqlmail, созданный программой во время установки. Для того, чтобы этот ящик начал работать, нужно создать источник данных ODBC с именем FromSQL. Пожалуйста, прочтите внимательно статью о плагине FromSQL перед созданием источника ODBC.

Форматы списков рассылки, О плагине FromSQL


Простые списки рассылки (.TXT, .LST)

EMMA Labs web site

Navigation: »No topics above this level«

Простые списки рассылки (.TXT, .LST)
No contents entries on this page
Contents
Topic functions menu
Menu
This is the first topic
Go to home topic
This is the last topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Обычный текстовый файл, каждая строка которого содержит один адрес электронной почты. Максимальное число адресов в списке - 1000000. Если Ваши списки больше, поделите их на части утилитой AdrSplit и добавьте к ящику несколько полученных файлов. Адрес может быть записан практически любым способом:

gorlach@massmail.ru

<gorlach@massmail.ru>

Alexander P. Gorlach <gorlach@massmail.ru>

“Alexander P. Gorlach” gorlach@massmail.ru

Alexander P. Gorlach gorlach@massmail.ru

gorlach@massmail.ru - Alexander P. Gorlach

Рекомендуемый способ записи адреса в списке рассылки:

Alexander P. Gorlach <gorlach@massmail.ru>

Ivan Ivanov <ivanov@elcomsoft.com>

ADR имеет опцию, позволяющую заменять адрес списка рассылки в поле “To:” на адрес реального получателя письма. Если Вы используете запись приведенного выше вида, то большинство почтовых программ покажут получателю письма в поле “To:” его имя, скрыв адрес электронной почты:

Alexander P. Gorlach

Ivan Ivanov

Если Ваши списки рассылки имеют особый формат - пишите, и его поддержка будет встроена в программу. Но, я думаю, любая программа имеет возможность экспорта своего формата в текстовый файл и импорта обратно, как, например, Outlook Express.

Вы также можете использовать специальный синтаксис записи адреса MAILBOX@[SMTP-SERVER]. Например, чтобы отправить письмо в ящик аlex на сервере smtp.enet.ru, напишите alex@[smtp.enet.ru]. Сервер может быть задан доменом или IP-адресом, через двоеточие может быть указан tcp-порт (по умолчанию - 25).

Форматы списков рассылки


Адресные книги Windows (.WAB)

EMMA Labs web site

Navigation: »No topics above this level«

Адресные книги Windows (.WAB)
No contents entries on this page
Contents
Topic functions menu
Menu
This is the first topic
Go to home topic
This is the last topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Адресные книги Windows хранятся в файлах с расширением WAB. Путь к адресной книге зависит от версии Micrsoft Internet Explorer. В операционных системах Windows 95, Windows 98 и Windows NT 4.0, адресные книги могут хранится в следующих папках:

\\Win95\Application Data\Microsoft\Address Book\USERNAME.WAB

\\Win98\Application Data\Microsoft\Address Book\USERNAME.WAB

\\WinNT\Profiles\USERNAME\Data\Microsoft\Address Book\USERNAME.WAB

Вы можете добавить к почтовому ящику ADR адресную книгу, как и список рассылки любого другого формата. Внимание, особенность: если Вы имеете группу контактов (addresses group, distribution list) в адресной книге (например, MyGroup), чье имя совпадает с именем ящика (т.е. ящик тоже MyGroup), к которому добавлена книга, то при рассылке по адресной книге ADR будет брать из нее только те адреса, которые входят в эту группу контактов. В противном случае, рассылка будет произведена по всей книге.

После создания списка по адресной книге, ADR удаляет из него дублирующиеся адреса. Обратите внимание, что ADR извлекает из книги адреса при каждой рассылке, т.е. этот список является динамическим, как и список создаваемый по SQL-запросу.

Форматы списков рассылки