Introduction
No contents entries on this page
Contents
Topic functions menu
Menu
This is the first topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

This program is intended for e-mail addresses and mail lists verifying. The main task is to determine which of addresses in the mail list are dead. The program is oriented, basically, on programmers which have their own mail lists to inform their users about new versions of their programs.

For example, there are about 850 emails in your mail list. About hundred of them are dead. The user can change his Internet Service Provider (ISP) and his own e-mail address. The dead addresses don’t allow to determine the correct number of subscribers, and interfere with mail system working. After sending 850 messages you loose your time receiving hundred of your messages back with remark: “beg pardon, but such address not exist”.

The program works using the same algorithm as ISP mail systems do. Mail servers addresses for specified address are extracted from DNS. The program tries to connect with found SMTP-servers and simulates sending the message. It does not come to the message sending - AMV disconnect as soon as mail server informs does this address exist or not.

AMV can find about 90% of dead addresses - some mail systems receive all messages and only then see their addresses and if the address is dead send the message back with remark about it.

The program is multi-threaded; that provides the high speed of checking and allows to regulate the network traffic and your machine loading. AMV is for network administrators and experienced users - we hope that the program is powerful, simple and convenient.

© 2009-2014 EMMA Labs


Program overview
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

If you’ve just installed AMV and never used it before, please look at Introduction chapter first. And here is more detailed information about the program, intended for advanced users.

The main program screen looks as shown in the picture below. The maximum number of addresses in the checked list is 1000000. If your list is larger, just divide it into a few parts by AMVSplit utility.

Column “Processed Emails” contains checked e-mail addresses, “Result” – the result of checking. The result can be “Exists” - e-mail address exists; “Bad syntax” - address syntax is incorrect (see Mailing list formats), “Not in DNS” - mail servers have not been found in DNS, “Not exist (SMTP)” - mail box does not exist as mail server has said, “Unknown” - it was not found, e.g. because the connection with mail server was unsuccessful. The “Comment” column just gives some additional information.

On the toolbar, there are buttons to start, to stop and to pause the checking. If you have stopped the check, you can start it again, thus all addresses with result "Unknown" will be marked as unchecked and AMV will check up them once again. If you have paused the check, you can start it again from that point (which you paused at). After the end of the check you can start it again - thus all addresses with "Unknown" result will be marked as unchecked and AMV will check up them once again. Also, there are some additional buttons on the toolbar:

log | The log viewing - the log contains description of all check stages – with technical details. You can view the log by double clicking on the address in the “Processed Emails” column.
unverify | By clicking on that button, you can mark all checked address as unchecked. As a result, the addresses are deleted from the “Processed Emails” column, and put in turn for checking. The button works only during pause and check.
check | The single address check, not a mailing list check. It is useful if you want to check a certain address once again. One of program advantages is that the check log is viewed in real time, not only when the check is completed.

Here is the algorithm of address processing. In the beginning all MX- and A- records, which correspond to indicated email address, are chosen from DNS. AMV works with one or two DNS servers given in settings. If address is not found on the first DNS server, program tries to find it on the second one. The request to each of DNS-servers is repeated two times, to exclude accidents. If SMTP-servers are found, the string like this will be written to log:

Found 4 relay(s) (univ.uniyar.ac.ru [10], nethost1.yars.free.net [20], gemini.yars.free.net [30], netserv2.free.net [50])

The priority code is given in brackets. Server with less code has more priority. The program tries to connect to the one which has the highest priority. If it is inaccessible for some reason, the program tries to connect to the next one etc. If you want to check address only on the most priority server, just check the “Verify only via the most priority SMTP server” option in SMTP settings. If you have two or more emails at one domain (e.g. a@hotmail.com and b@hotmail.com) in your mailing list, the program will retrieve addresses of SMTP servers for second email from internal DNS cache. You can turn off caching in DNS settings.

The dialogue like this takes place on the mail server:

220 ESMTP ESMTP unicorn.carrier.kiev.ua

HELO gorlach.ol.enet.ru

250 unicorn.carrier.kiev.ua Hello gorlach.ol.enet.ru [194.186.20.132], pleased to meet you

MAIL FROM: <check_email@gorlach.koenig.su>

250 <check_email@gorlach.koenig.su>... Sender ok

RCPT TO: <elbrus@carrier.kiev.ua>

550 <elbrus@carrier.kiev.ua>... User unknown

RSET

250 Reset state

QUIT

The program introduces itself (HELO) and says that it wants to send a message from address check_email@gorlach.koenig.su (MAIL FROM) to elbrus@carrier.kiev.ua (RCPT TO). In spite of SMTP-server answer, the program gives the disconnect command (QUIT) instead of message contents. No message is added to checked mailbox.

In program settings, you can specify how the program will introduce itself (the program can determinate your domain automatically or use the specified one), and which address will be used in MAIL FROM. Look at SMTP settings for details.

The program can also use a direct delivery. For example, if SMTP-server addresses alex@gorlach.com are not found in DNS, the program can try to deliver the message for address on SMTP-server gorlach.com. Usually, the direct delivery is not used, and such usage is not recommended. Read DNS settings carefully before use this option!

When you use filtering, you can save, for example, only "bad" or only "Unchecked" addresses - see Filtering section.


Program tips
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Here are some tips, which may help you to use the program more efficiently.

·Increasing the number of scanning threads speeds up the checking, but also increases the network traffic. See the “General settings” section.

·If “direct delivery” option is used, the following problem may appear: the address, which doesn’t exist in DNS, will not be labeled as “bad one”. See the “DNS settings” section.

·If non-existing or somebody else's domain is specified for HELO, there is a chance that the mail server will return the wrong result, i.e. mark the address as nonexistent one. See the “SMTP settings” section.

·Using filtering, you can control the contents of output file. For example, it may contain only "bad" addresses. See the “Filtering” section.

·If you want to verify the admin mailbox on smtp.enet.ru mail server, take advantage of special syntax admin@[smtp.enet.ru]. See "Mailing lists formats" section.


Mailing list formats
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Two mailing list formats are supported. The first is a simple text file, where each line contains one e-mail address. The maximum number of addresses in the checked list is 1000000. If your list is longer, divide it into a few parts with the AMVSplit utility. Address can be written by any way, for example:

amv@gorlach.koenig.su

<amv@gorlach.koenig.su>

Alexander P. Gorlach <amv@gorlach.koenig.su>

“Alexander P. Gorlach” <amv@gorlach.koenig.su>

“Alexander P. Gorlach” amv@gorlach.koenig.su

“Alexander P. Gorlach amv@gorlach.koenig.su”

‘Alexander P. Gorlach amv@gorlach.koenig.su’

Alexander P. Gorlach amv@gorlach.koenig.su

amv@gorlach.koenig.su - Alexander P. Gorlach

If your mailing list has some special format – just contact us, and we’ll probably support it in the future versions of AMV. Just note that most programs can export their data from their own formats to text files (and back) – for example, Outlook Express.

You also can use the special syntax of e-mail – MAILBOX@[SMTP-SERVER]. For example, to check up a mailbox alex on smtp.enet.ru server, write alex@[smtp.enet.ru].

The server can be given by the domain or IP-address, the tcp-port can be specified, too (25 by default).

The second format is CSV. It has been made specially for Outlook Express users. You can export all address book to the CSV file; load that file into AMV, save the result, clear the address book in Outlook Express and import it back from the CSV-file. It is recommended to make the backup copy of address book! In CSV-files, only first address of e-mail is checked.

Since version 2.0 AMV can verify Windows Address Books directly, without any conversion.

See also: Windows Address Book wizard, Working with ODBC sources


Command line
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Using a command line and Windows task scheduler (or another one), you can completely automate mailing lists checking.

Syntax:

AMV.EXE [keys] [“input file” [“output file” [“reverse output file” [“third output file”]]]]

All incorrect values of keys are ignored without warning messages. The available key values are:

-MINIMIZED – to start the program in minimized state;

-SAVELOG – to save log, log will placed in input file directory and with the same name as input file, but with .LOG extension;

-SAVESHORTLOG – to save “short” log, log will placed in input file directory and with the same name as input file, but with .SLOG extension if –SAVELOG key is specified and .LOG otherwise;

-EXITCOMPLETE – to close the program when mailing list is checked and saved. This key works only if the operator did not pause and did not stop the check, and if the output file was given;

-ODBCSQL – the work with ODBC SQL sources, not with mailing lists, see the details below.

The input and output files can have the same name. “Reverse” file is the same as output file but saved with inverted filtering settings. In “third” file AMV save bad, unchecked and unknown emails independently of filtering settings. If the output file is not specified, AMV does not do automatic save of results, and the –EXITCOMPLETE, -SAVELOG and -SAVESHORTLOG keys does not work.

Also, since v1.67 you can set filtering settings for each output file in command line with –FILTER key. The key must be specified after output file. If –FILTER is not specified, output files are used as it described above.

Format: -FILTER:EBUN, where

E – save “exist” emails in output file;

B – save “bad” emails in output file;

U – save “unknown” emails in output file;

N – save unchecked emails in output file.

The –ODBCSQL key shows that input and output files are the files with SQL requests to ODBC data sources, not the mailing lists. This files contain SQL expressions in the following format:

data_source_name,<username>,<password>,SQL_expression

Angled fields (<>) may be blank, for example:

MyDatasource,

Admin,

Password,

SELECT

email

FROM

customers

WHERE

email<>NULL

or

MyDatasource,,,

UPDATE customers

SET result='%result%'

WHERE email='%email%'

For details about SQL request features see the article “Working with ODBC sources” which describe the working of import and export wizards from ODBC sources. See also SqlImport.SQL and SqlExport.SQL files in the directory with Advanced Maillist Verify. When export, SQL expressions are executed according to specified filtering settings (specified by default or by –FILTER key).

Examples:

AMV.EXE -MINIMIZED -EXITCOMPLETE my.lst “verified my.lst”

AMV.EXE -MINIMIZED “product customers.lst”

AMV.EXE my.lst my.lst

AMV.EXE “c:\program files\Eserv2\mail\lists\admins.txt”

AMV.EXE –SAVELOG –SAVESHORTLOG 1.lst 1.out 1reverse.out

AMV.EXE input.lst output.lst –FILTER:EUN bad.lst –FILTER:B

AMV.EXE in.txt o1.lst –FILTER:E o2.lst –FILTER:NU o3.lst –FILTER:B

AMV.EXE –EXITCOMPLETE my.lst myout.lst –FILTER:NEU

AMV.EXE –ODBCSQL SqlImport.SQL SqlExport.SQL –FILTER:EBUN

AMV.EXE –EXITCOMPLETE –ODBCSQL –SAVELOG SqlImport.SQL SqlOut_1.SQL SqlOut_2.SQL


"File open..." dialog settings
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

These options work only at loading a file through dialogue File \ Open. At loading through the command line these options do not work.

Delete duplicated emails

Deletes lines containing duplicated e-mail addresses. The removed lines will be shown on the screen in the result column, with value "Filtered". To store the filtered emails in the output file, it is necessary to set "Save bad addresses" in dialogue "Save as…" or on a "Filter" tab in program settings.

Delete emails which contain following substrings

Deletes the addresses containing one of substrings, which are given through a comma. The search of substrings is case insensetive. The removed lines will be shown on the screen, in the result column, with value "Filtered". To stored the filtered emails in the output file, it is necessary to set "Save bad addresses" in dialogue "Save as…" or on a "Filter" tab in program settings.

Use of regular expression instead of substrings is also possible. The regular expression provides more powerful instrument for search. You can get more information on regular expressions syntax at the following addresses.

http://www.perl.com/CPAN-local/doc/manual/html/pod/perlre.html

http://www.python.org/doc/lib/re-syntax.html

http://perso.magic.fr/roumazeilles/regex.htm

http://www.boost.org/libs/regex/index.htm

You can find many other documents on this subject with search machines on request "regular expressions syntax".

Delete emails which NOT contain following substrings

It is similar to the above item but just vice verse. The address will be filtered, if it does not contain the specified substrings or don’t match to regular expression.

Remove %20 and also known bugs

This program corrects common mailing list files (with extension LST and TXT) only and does not correct CSV (Comma Separated Values) files. For example, with this option ON, the following list:

Alex <%20alex@domain.com>

Mary <mary @domain.com>

John <john@@domain.com>

will be transformed into:

Alex <alex@domain.com>

Mary <mary@domain.com>

John <john@domain.com>

This program successfully corrects about 90% of errors in e-mail lists. Testing of this program shows that no correct addresses were damaged, but some addresses were corrected not properly. The program opens a separate window for the control of results, in this window the original and corrected addresses are shown. The window is not opened, if no addresses were corrected.

As an example, you can set this option and load a file EmlBugs.LST, which is in the same catalogue as Advanced Maillist Verify.

Please, do not hesitate to send us examples of addresses, which the program has not corrected or corrected not properly. We will try to modify an algorithm to meet your demands.

See also: Mailing list formats


Working with ODBC data source

EMMA Labs web site

Navigation: Import and export wizards:

Working with ODBC data sources
No contents entries on this page
Contents
Topic functions menu
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

You can work with many databases through ODBC. You can work with Oracle, Microsoft SQL Server and even with Excel document through ODBC drivers and SQL requests.

AMV can import mailing lists from database with the help of wizard ("File" -> "Import via ODBC"). The wizard requires to set data source name (DSN), name and password for access to source and SQL-request to extract e-mails from database. Apply to your database manual for information about SQL language. The result of request is a mailing list in format supported by AMV. Each row of SQL-request result is one line of mailing list. Some examples of requests:

SELECT email FROM customers_table

SELECT

name,'<'+email+'>'

FROM

customers_table

WHERE

email<>NULL

AMV can import up to 100000 addresses from database. It's recommended to check addresses by small parts with 5000..10000 e-mails each, because AMV requeires about 2 kilobytes of RAM for each address (to keep address,log of checking, etc.).

The export of check results ("File" -> "Export via ODBC") allow to execute SQL expression for each address loaded to AMV. On first wizard page you can choose filtering of addresses to execute requests, e.g., only for successfully checked addresses. When inputing SQL-expression %email% and %result% templates are used. When executing request this templates are replaced by e-mail and text description of its check result. Since version 4.0 of AMV three new macros are available - %code%, %log%, %comment%, which will replaced, correspondingly, by numeric code of check result, email check log (multiline string) and comment to check result.

For example, the expression:

UPDATE

customers_table

SET

email_status='%result%'

WHERE

email='%email%'

will be expanded for ag@mail.com address with "Not in DNS" check result:

UPDATE

customers_table

SET

email_status='Not in DNS'

WHERE

email='ag@mail.com'

Similarly this expression will be expanded for each of addresses and executed suitable number of times.

See also: Program overview, Program support


Windows Address Book Wizards

EMMA Labs web site

Navigation: Import and export wizards:

Widows Address Book wizards
No contents entries on this page
Contents
Topic functions menu
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Windows Address Books are stored in the files with .WAB extension and used in Microsoft mail programs, for example, in Internet Mail, Internet News and Outlook Express. You can familiarize with Address Book contents and possibilities using one from above programs.

Import Windows Address Book

You can import e-mail addresses from Address Book to Advancеd Maillist Verify using the wizard called through “File” menu. You can choose default Address Book for import or any other Address Book, just specifying the file with it. See “Windows Address Book file location” article to know directories and files where Address Books are stored.

The Address Book, copied from another computer, can be opened with error or don’t opened at all. See “How to Copy an Outlook Express WAB to Another Computer” article from Microsoft Knowledge Base.

Export Windows Address Book

You can export the results of checking to Address Book using the Advancеd Maillist Verify wizard called through “File” menu. Only the results of Address Book checking can be exported, you can’t export the results of mailing list or database checking to Windows Address Book.

The export of checking results consists in the deletion emails (contacts) from Address Book. Specify, at first wizard page, the addresses you want to delete from Address Book (existent, nonexistent, unchecked or checked with “unknown” result). Pay attention, the deleted addresses can’t be restored. It is recommended to make copy of the file with Address Book. See “Windows Address Book file location” article to know the files and the directories where Address Books are stored.

After the results exporting the program can inform that it have deleted not all contacts as you specify. The reason can be in that some contacts were entered in contacts groups (distribution list) and, so, were present in general list and distribution list at the same time. When such contact is deleted from the general list, it is automatically deleted from all contacts groups where it is.

See also: TheBat Address Book wizard, Mailing list formats, Windows Address Book file location, Filtering settings


TheBat Address Book Wizards
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

The Bat! is a powerful, highly configurable, yet easy to use, email client for the casual user or the power user, the home or the office. You can download TheBat here: http://www.ritlabs.com/

By default, TheBat address books are stored in the files with .ABD extension in MAIL subdirectory of TheBat. After check results export, you must restart TheBat to load updated address book. When AMV exports results, it deletes emails from contacts according filtering settings. If contact will contain no emails then contact will be deleted too.

We recommend making backup copy of your address book before check results export.

See also: Windows Address Book wizard


Information for programmers
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Since version 2.1, AMV has COM interface. COM is the fundamental "object model" on which ActiveX Controls and OLE are built. COM allows an object to expose its functionality to other components and to host applications. It defines both how the object exposes itself and how this exposure works across processes and across networks. Now, you can use Advanced Maillist Verify power with any programming language and with any software, which supports COM.

So, you can work with AMV from Microsoft Visual C++, Borland Delphi, CBuilder, and Microsoft Visual Basic and from many other developer envelopments. You can use AMV at server side in ASP (Active Server Pages, Microsoft Technology) and ColdFusion web pages and you can work with AMV on remote computer via DCOM (Distributed COM Service). You can call local AMV copy from JavaScript and VBScript codes and so on! You can do everything!

See also: IEmailVerifier interface, IEmailVerifier interface methods, Typical program code, IAmvConfigure interface, Code samples, Redistribution of AMV modules


IEmailVerifier interface
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

IEmailVerifier is the dual-interface. So, you can use AMV through disp-interface (Visual Basic, JavaScript, ASP) or through vtbl-interface (Microsoft Visual C++, Borland Delphi). Please, see code samples for both methods illustrations.

Note, that you can create many verifier objects and implement multi-threaded verifying in your application. AMV has no built-in limitation for number of created objects. All objects will verify emails according current AMV settings. Also, you can configure AMV (e.g. DNS, proxy, SMTP settings) through COM interfaces of AMV.

Standard C++ header file for interface you can found in file: COM\AmvCpp1\AmvInterfaces.h in subdirectory of Advanced Maillist Verify.

See also: IEmailVerifier interface methods, Information for programers


IEmailVerifier interface methods
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

virtual HRESULT put_Email(/* [in] */ BSTR bstrEmail);

Set email for the check. You can set email in all known formats, e.g.:

amv@elzcomsoft.com

Alex <amv@elzcomsoft.com>

Alex “amv@elzcomsoft.com”

“Alex Gorlach” <amv@elzcomsoft.com>

The check will start automatically after successful put_Email() call. Note, that put_Email() call will be successful only when internal verifier object is in CME_CLEAR or CME_COMPLETE state (see below get_Status() description).

Possible return values are:

S_OK – email was set successfully, the check will start automatically;

S_FALSE – bad internal verifier object state (e.g., check of previous email is not completed).

virtual HRESULT put_Sleep(/* [in] */ long lMilliseconds);

Some programming languages (e.g. JavaScript) have no build-in operation for delay. lMilliseconds specifies the time, in milliseconds, for which to suspend execution (from 1 to 60000). See code sample in get_Status() description.

virtual HRESULT get_Status(/* [retval][out] */ long *status);

Return state of internal verifier object is:

CME_CLEAR (0) – object is created (and no success put_Email() call yet);

CME_READY (1) - put_Email() call was successful, checking will start automatically in some seconds;

CME_CHECKING (2) – check in progress;

CME_COMPLETE (3) – check is completed.

Possible result values are:

S_OK – status code was returned.

Typical program code is:

amv.Email = email;

if (amv.Status > 0)

{

do

{

amv.Sleep = 300;

status = amv.Status;

}

while (status != CME_COMPLETE);

}

virtual HRESULT get_Result(/* [retval][out] */ long *result);

Return numeric code of check result, is one from the following:

VER_OK (0) – email exist;

VER_BAD_DNS (2) – email domain was not found in DNS;

VER_BAD_SMTP (3) – mailbox is not existent;

VER_UNKNOWN (4) – program is unable to check email at this moment.

Possible result values are:

S_OK – result was returned;

S_FALSE – result is not available at this moment (e.g. check in progress).

virtual HRESULT get_StatusString(/* [retval][out] */ BSTR *pbstrStatus);

Return the string value of internal object status (see also get_Status() description).

virtual HRESULT get_ResultString(/* [retval][out] */ BSTR *pbstrResult);

Return the string value of check result (see “Result” column in program interface). Possible result values are:

S_OK – result string was returned;

S_FALSE – result is not available at this moment (e.g. check in progress).

virtual HRESULT get_Log(/* [retval][out] */ BSTR *pbstrLog);

Return the multi-line string with log of check. Possible result values are:

S_OK – log was returned;

S_FALSE – log is not available at this moment (e.g. check in progress).

virtual HRESULT get_Comment(/* [retval][out] */ BSTR *pbstrComment);

Return the single line with AMV comment for check (see “Comment” column in program interface). Possible result values are:

S_OK – comment was returned;

S_FALSE – comment is not available at this moment (e.g. check in progress).

virtual HRESULT get_DirtyEmail(/* [retval][out] */ BSTR *pbstrEmail);

Return the original email (like “Gorlach <alex@gorlach.koenig.su>”) received by put_Email() call. Possible result values are:

S_OK – email was returned;

S_FALSE – email is not available (e.g. put_Email() call was failed).

virtual HRESULT get_CleanEmail(/* [retval][out] */ BSTR *pbstrEmail);

Return the “clean” email (e.g. “alex@gorlach.koenig.su” instead “Gorlach <alex@gorlach.koenig.su>”) received by put_Email() call.

Possible result values are:

S_OK – email was returned;

S_FALSE – email is not available (e.g. put_Email() call was failed).

See also: Typical program code, Information for programers


Typical program code
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

var amv, status, result;

amv = new ActiveXObject('AdvancedMaillistVerify.EmailVerifier');

amv.Email = email;

if (amv.Status > 0)

{

do

{

status = amv.Status;

amv.Sleep = 300;

}

while (status != CME_COMPLETE);

result = amv.ResultString;

}

else

{

result = “Invalid syntax”;

}

See also: Code samples, Information for programers


IAmvConfigure interface
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

IAmvConfigure interface was added in version 4.1 of Advanced Maillist Verify and designed to configure AMV from other applications. IAmvConfigure is the dual-interface. So, you can use AMV through disp-interface (Visual Basic, JavaScript, ASP) or through vtbl-interface (Microsoft Visual C++, Borland Delphi). Please, see AmvCfg sample for illustration.

With IAmvConfigure interface methods you can do the same as you can do in AMV settings dialog, except some settings which are unimportant for Advanced Maillist Verify component.

IAmvConfigure methods

virtual HRESULT __stdcall Load(void);

Force component to reload settings from Windows registry.

virtual HRESULT __stdcall Save(void);

Force component to save settings to Windows registry.

virtual /* [propput] */ HRESULT __stdcall put_Timeout(/* [in] */ long lSeconds);

Set “Timeout in minutes” value.

virtual /* [propget] */ HRESULT __stdcall get_Timeout(/* [retval][out] */ long __RPC_FAR *lSeconds);

Get “Timeout in minutes” value.

virtual /* [propput] */ HRESULT __stdcall put_LogsOff(/* [in] */ VARIANT_BOOL bLog);

Set “Turn off checking logs” value.

virtual /* [propget] */ HRESULT __stdcall get_LogsOff(/* [retval][out] */ VARIANT_BOOL __RPC_FAR *bLog);

Get “Turn off checking logs” value.

virtual /* [propput] */ HRESULT __stdcall put_PrimaryDNS(/* [in] */ BSTR bstrDns);

Set “Primary DNS” value.

virtual /* [propget] */ HRESULT __stdcall get_PrimaryDNS(/* [retval][out] */ BSTR __RPC_FAR *bstrDns);

Get “Primary DNS” value.

virtual /* [propput] */ HRESULT __stdcall put_SecondaryDNS(/* [in] */ BSTR bstrDns);

Set “Secondary DNS” value.

virtual /* [propget] */ HRESULT __stdcall get_SecondaryDNS(/* [retval][out] */ BSTR __RPC_FAR *bstrDns);

Get “Secondary DNS” value.

virtual /* [propput] */ HRESULT __stdcall put_DirectDelivery(/* [in] */ VARIANT_BOOL bDirect);

Set “Direct delivering” value.

virtual /* [propget] */ HRESULT __stdcall get_DirectDelivery(/* [retval][out] */ VARIANT_BOOL __RPC_FAR *bDirect);

Get “Direct delivering” value.

virtual /* [propput] */ HRESULT __stdcall put_UpdateDNS(/* [in] */ VARIANT_BOOL bUpdate);

Set “Automatically update DNS settings” value.

virtual /* [propget] */ HRESULT __stdcall get_UpdateDNS(/* [retval][out] */ VARIANT_BOOL __RPC_FAR *bUpdate);

Get “Automatically update DNS settings” value.

virtual /* [propput] */ HRESULT __stdcall put_HeloDomain(/* [in] */ BSTR bstrDomain);

Set “Domain for HELO” value.

virtual /* [propget] */ HRESULT __stdcall get_HeloDomain(/* [retval][out] */ BSTR __RPC_FAR *bstrDomain);

Get “Domain for HELO” value.

virtual /* [propput] */ HRESULT __stdcall put_MailFrom(/* [in] */ BSTR bstrEmail);

Set “Email for MAIL FROM” value.

virtual /* [propget] */ HRESULT __stdcall get_MailFrom(/* [retval][out] */ BSTR __RPC_FAR *bstrEmail);

Get “Email for MAIL FROM” value.

virtual /* [propput] */ HRESULT __stdcall put_MostPriority(/* [in] */ VARIANT_BOOL bPriority);

Set “Verify only via the most priority SMTP server” value.

virtual /* [propget] */ HRESULT __stdcall get_MostPriority(/* [retval][out] */ VARIANT_BOOL __RPC_FAR *bPriority);

Get “Verify only via the most priority SMTP server” value.

virtual /* [propput] */ HRESULT __stdcall put_UseVrfy(/* [in] */ VARIANT_BOOL bVrfy);

Set “Execute VRFY command for exist e-mails” value.

virtual /* [propget] */ HRESULT __stdcall get_UseVrfy(/* [retval][out] */ VARIANT_BOOL __RPC_FAR *bVrfy);

Get “Execute VRFY command for exist e-mails” value.

virtual /* [propput] */ HRESULT __stdcall put_UseProxy(/* [in] */ VARIANT_BOOL bProxy);

Set “Connection through Socks5 proxy server” value.

virtual /* [propget] */ HRESULT __stdcall get_UseProxy(/* [retval][out] */ VARIANT_BOOL __RPC_FAR *bProxy);

Get “Connection through Socks5 proxy server” value.

virtual /* [propput] */ HRESULT __stdcall put_SocksServer(/* [in] */ BSTR bstrServer);

Set “Socks5 server address” value.

virtual /* [propget] */ HRESULT __stdcall get_SocksServer(/* [retval][out] */ BSTR __RPC_FAR *bstrServer);

Get “Socks5 server address” value.

virtual /* [propput] */ HRESULT __stdcall put_SocksPort(/* [in] */ long lPort);

Set “Socks5 server port” value.

virtual /* [propget] */ HRESULT __stdcall get_SocksPort(/* [retval][out] */ long __RPC_FAR *lPort);

Get “Socks5 server port” value.

virtual /* [propput] */ HRESULT __stdcall put_ProxyAuth(/* [in] */ VARIANT_BOOL bAuth);

Set “Use RFC 1929 authentication (clear-text)” value.

virtual /* [propget] */ HRESULT __stdcall get_ProxyAuth(/* [retval][out] */ VARIANT_BOOL __RPC_FAR *bAuth);

Get “Use RFC 1929 authentication (clear-text)” value.

virtual /* [propput] */ HRESULT __stdcall put_SocksLogin(/* [in] */ BSTR bstrLogin);

Set “Socks5 server login” value.

virtual /* [propget] */ HRESULT __stdcall get_SocksLogin(/* [retval][out] */ BSTR __RPC_FAR *bstrLogin);

Get “Socks5 server login” value.

virtual /* [propput] */ HRESULT __stdcall put_SocksPassword(/* [in] */ BSTR bstrPassword);

Set “Socks5 server password” value.

virtual /* [propget] */ HRESULT __stdcall get_SocksPassword(/* [retval][out] */ BSTR __RPC_FAR *bstrPassword);

Get “Socks5 server password” value.

virtual /* [propput] */ HRESULT __stdcall put_UseMapping(/* [in] */ VARIANT_BOOL bMapping);

Set “Use mapping for DNS” value.

virtual /* [propget] */ HRESULT __stdcall get_UseMapping(/* [retval][out] */ VARIANT_BOOL __RPC_FAR *bMapping);

Get “Use mapping for DNS” value.

See also:IEmailVerifier interface methods, Information for programers


Code samples
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

In COM subdirectory of AMV you can find the following samples with full source code:

AmvCpp1 - C++ console sample (vtbl implementation), compiled with Microsoft Visual C++ 6.0

AmvCpp2 - C++ console sample (disp implementation), compiled with Microsoft Visual C++ 6.0

AmvDelphi3 - Borland Delphi v3 GUI sample

AmvVB6 - Microsoft Visual Basic sample

AmvCfg - AMV configuration Visual Basic sample

AmvHtml - Client-side JavaScript samples (HTML)

AmvIIS - Server-side JavaScript sample for MS IIS (ASP)

AmvCF - Server-side script for ColdFusion web-server

See also: Redistribution of AMV modules, Information for programers


Redistribution of AMV modules
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

You can distribute AMV.EXE (main program) file with your program. Your installation program may put this file into any folder. To register COM interface, you should run the following command:

AMV.EXE –RegServer –Registration YOUR-LICENSE-NUMBER

AMV will start in the "silent" mode (i.e. without creating its own window), register COM server and type library (-RegServer key), store your license number into the registry (-Registration key) and terminate. Note, the license number is not the same as your AMV serial number, and have to be purchased separately (see the details below). If the license number is valid then program will terminate with code 1 (errorlevel), and with code 2 otherwise. Code 0 means, that no –Registration key was found in command line. To get message with result of your license number processing, add –MSG key to command line:

AMV.EXE –RegServer –Msg –Registration YOUR-LICENSE-NUMBER

When you uninstall your application, you must make the following call:

AMV.EXE -ClearRegistry

AMV will unregister COM server and remove all created keys from registry.

AMV settings are placed into the following registry section:

HKLM\Software\Elcom\Advanced Maillist Verify

Unfortunately, you can’t configure current version of AMV through COM interface. Your application must write necessary AMV settings directly to the AMV registry section.

See also: Information for programers


CGI/ISAPI modules
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Advanced Maillist Verify can be easy integrated into practically any web-server worked under Windows. There are two ways to do it:

- Through AMV COM/ActiveX interface. See "Code samples" article in "Information for programmers" part. It contains links to the examples (supplied with program) of integration into Microsoft IIS and ColdFusion server from Adobe Corporation. Unfortunately, some web-servers and its extensions don't allow to create the scripts, that will be executed on server and support COM/ActiveX objects.

- Through CGI/ISAPI modules. CGI (Common Gateway Interface) is a platform-independent interface of programs working in common with web-server. Because of its unique simplicity and some historical reasons, CGI interface is supported by all web-servers except some specialized web-servers, which don't support scripts and programs execution on server side at all. ISAPI is an alternative to CGI in Microsoft IIS web-server. The interface repeats CGI interface in many respects, but has greater efficiency and more capabilities.

CGI (AmvCgi.exe) and ISAPI (AmvIsapi.dll) modules don't differ from each other in setup and setting, so we'll call them both just modules. The modules are located in COM\AmvCGI\ and COM\AmvISAPI\ subdirectories of AMV.

The modules aren't independent programs and use "Advanced Maillist Verify Component - Email Verifier" COM-object to check address. So for their functioning you have to setup Advanced Maillist Verify and set the corresponding access right for the component using DCOMCNFG.EXE utility, if web-server works with not usual user rights. The component can be executed on any computer in network by using DCOM (Distributed COM). It also can be setting through DCOMCNFG.EXE utility.

The usual Advanced Maillist Verify user licence is not enough to use COM-component (and COM/ISAPI modules). So you have to buy the developer licence.

The setting of modules working is realized through configuration files with .INI extension. They must have the same name as script file and be located in the same directory as it (e.g., AmvCgi.EXE and AmvCgi.INI, AmvCgi1.EXE and AmvCgi1.INI). You can create a several module copies with different names in one directory, with different setting files, of course. In web-server settings, the directory with scripts must be accessible for execution, but inaccessible for reading.

The modules callings are realized with email transfer to them by POST or GET methods. The modules don't have a hard argument for address transfer and determine address from '@' sign in argument body. For example, the following GET callings will be processed correctly:

/AmvCgi.exe?my@email.com

/AmvCgi.exe?email=my@email.com

/AmvCgi.exe?test=off&my@email.com

/AmvCgi.exe?test=off&eml=my@email.com

In the next examples will be checked the first argument with '@' sign:

/AmvCgi.exe?my@email.com&my2@email.com

/AmvCgi.exe?test=@&email=my@email.com

If there is no argument contained '@' sign, then, depending on script settings, either the error message appears or the first argument of the first parameter will be chosen to check. Note, that the module processes only one parameter (email). The processing of cases, when a several parameters were transfered to module, was added only to increase the program compatibility.

The module executes email checking using Advanced Maillist Verify settings (DNS server addresses, timeouts, specific SMTP protocol settings, etc). After end of checking, the module executes one from the actions (browser redirection or HTML-page displaying) according to settings in configuration file. The principle difference between that actions consists in the method of result transfer.

In the first case (redirection), the script can code the checking results in URL, to which the redirection is realized. To specify URL you can use %EMAIL%, %RESULT%, %COMMENT% macros, which will be extended with corresponding values by script. For example:

http://www.mycompany.com/goodemail?email=%EMAIL%

In the second case (HTML-page displaying), you can use %EMAIL%, %COMMENT%, %RESULT%, %LOG% macros within the page template. They will be replaced by the real values during page displaying.

Please, see the script configurational files and page templates in COM subdirectory of AMV for details.

See also: Information for programers


Utility AmvSplit
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

The maximal number of addresses in the checked list is 1000000. If your lists are longer, divide them into parts by this utility. AmvSplit is placed in the directory with Advanced Maillist Verify.

Syntax:

AMVSPLIT.EXE lines input_file

Where lines - maximum number of lines in output files, input_file – the list you want to split. The output files are saved in the directory with the input file and have names like input_file.NNN, where NNN is the number of a part.

Examples:

AMVSPLIT.EXE 1000 my.lst

AMVSPLIT.EXE 10000 “C:\Program Files\Eserv\forward.lst”

To concatenate the parts back to one file (after check), use the COPY command in a command line. For example:

COPY my.lst.001+my.lst.002+my.lst.003 my_checked.lst

COPY my.lst.0?? my_checked.lst

See also: Utility NextStr, Utility DomainSo


Utility AmvNoDup
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

This program is designed to delete duplicated emails in mailing list. AmvNoDup is placed in the directory with Advanced Maillist Verify. Since version 4.0, you can filter duplicated emails by AMV without this utility (see “File Open…” dialog settings”).

Syntax:

AMVNODUP.EXE infile outfile

Where infile is the source mailing list file, outfile is the output file name.

Examples:

AMVNODUP.EXE customers.lst cust_clean.lst

AMVNODUP.EXE "C:\Program Files\My List.txt" mylst.txt

See also: AmvSplit utility, Utility NextStr


Utility NextStr
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

NextStr is placed in the directory with Advanced Maillist Verify. This utility is very useful for analyze AMV log files. NextStr print the strings that has specified substring in the beginning and one following string. Run program without parameters to see program help.

Syntax:

NEXTSTR.EXE “string begining” input_log_file

Example:

NEXTSTR.EXE “RCPT TO” my.log

Program output:

Line Text (first 70 characters)

------ ----------------------------------------------------------------------

64 RCPT TO: <check_email@gorlach.koenig.su>

65 250 <check_email@gorlach.koenig.su>... Recipient ok

132 RCPT TO: <nobox_8172@hotmail.com>

133 550 Requested action not taken: mailbox unavailable

200 RCPT TO: <nobox_0173@aha.ru>

201 553 <nobox_0173@aha.ru>... User unknown (remote check)

262 RCPT TO: <nobox_0173@chat.ru>

263 550 Unknown local part nobox_0173 in <nobox_0173@chat.ru>

375 RCPT TO: <aleshenka@postman.ru>

376 250 <aleshenka@postman.ru>... Recipient ok

502 RCPT TO: <zaraza@download.com>

503 550 <zaraza@download.com>... User unknown

567 RCPT TO: <dibibi@pop.convey.ru>

568 550 <dibibi@pop.convey.ru>... User unknown

629 RCPT TO: <zizitop@winfiles.com>

630 550 <zizitop@winfiles.com>... User unknown

691 RCPT TO: <uzzzi@chat.ru>

692 550 Unknown local part uzzzi in <uzzzi@chat.ru>

756 RCPT TO: <postmaster@nefto.khv.ru>

757 250 <postmaster@nefto.khv.ru>... Recipient ok

880 RCPT TO: <sisimi@real.astrakhan.su>

881 550 <sisimi@real.astrakhan.su>... User unknown

-----------------------------------------------------------------------------

Done.

See also: Uility AmvSplit, Utility DomainSo


Utility DomainSo
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

DomainSo is placed in the directory with Advanced Maillist Verify. This program is designed for sorting mailing lists by domain alphabet order. For sorting by email alphabet order use SORT utility from OS software. Run program without parameters to see program help.

Syntax:

DOMAINSO [-r] input_file output_file

Where –r is optional parameter for reverse sorting.

Examples:

DOMAINSO.EXE customers.lst cust_sorted.lst

DOMAINSO.EXE -r "C:\Program Files\My List.txt" mylst.txt

See also: Uility AmvSplit, Utility NextStr


Program setup
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

The setup of program is caused in menu “Check” by choosing of item “Settings...”. In appeared window you will see five tabs with settings: General settings, DNS settings, SMTP settings, Filtering, Proxy settings, Colors settings


General settings
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Checking email threads

The number of verifying email threads - how many addresses will be checked at the same time. By increasing the number of threads you increase the network traffic too. It is recommended to use 20...30 threads for 33.6k Internet connection.

Timeout in minutes

The maximum time of address checking in minutes, after expiration of which the address checking is terminated with the “Timeout” comment. Set this value to zero to disable it.

Check several email from one domain in one TCP connection

There is an opportunity to check a several addresses (from 2 till 99) at one domain during the one connection to SMTP server by a several RCPT TO commands. The usage of this setting may result in the speed-up of the checking great list of addresses in a several times. It's recommended to check 10..20 addresses at one connection. Increase the timeout when you use the larger value of this setting. The checking logs will look like if the addresses was checked separatly. A number in "InChk" field of status.bar can be greater than a number of email checking threads when this option is turned on because a several addresses can be checked in one thread (or in one TCP connection).

Create BAK files when overwrite

To save copies when you overwrite mailing lists.

Beep when complete

To generate a beep on the system speaker, when program completes mailing list checking.

Only CR for separate emails

To use only CR (0x0A) for separating the addresses (lines) when you save the mailing list. By default - CRLF (0x0D, 0x0A).

Only two columns in short log

When you save the short log, all three columns of window are written into the output file (by default). Check this column to disable the “Comment” column writing.

Show banner advertisement

Only registered users can turn off banner advertisement.

Turn off checking logs

The log of letter checking can take about 1 kilobyte. The logs can take up to 100 megabytes of RAM during the checking a great list of 100000 addresses. In this case you can turn off the logs for memory saving.

Auto pause if no dial-up connection established

When dial-up connection dropped, AMV has pause the checking and run it again when connection will be established.

See also: Program setup


DNS settings
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Primary DNS

It can be given by both domain and by IP-address. AMV works with DNS-servers only via UDP protocol. The access time to DNS-servers, which the program uses by default, is 2-3 seconds for some users. Apply to your Internet provider for its DNS-server address, if you want to shorten this period till half a second. Windows can get this information automatically sometimes. And most of providers use this feature to guard user from superfluous settings. AMV tries to determine DNS settings by itself and show them in “Windows DNS Settings”. You can also determine DNS-servers addresses independently using IPCONFIG utility with key /ALL under Windows NT, or using WINIPCFG utility under Windows 95 or Windows 98. That are utilities of operation system. Also you can take DNS addresses from DNS servers list.

Secondary DNS

Can be empty. It is used only if the primary DNS-server has not answered to the request positively.

Direct delivering

For example, direct delivery to server gorlach.koenig.su for address alex@gorlach.koenig.su . Even if the direct delivery is set, it is used only when DNS-servers have not returned the addresses of mail servers. Using this option IS NOT RECOMMENDED – you can get incorrect results. You may use it only in research purposes.

Don’t use internal DNS cache

If you have two or more emails from one domain (e.g. a@hotmail.com and b@hotmail.com) in your mailing list, then the program will retrieve addresses of SMTP servers for second email from internal DNS cache. The cache is reset at each “Run Check”. Your also can turn off caching by checking this option.

Windows DNS Settings

Information in this window is updated every second automatically. Program tries to determine DNS settings of Windows by itself and show them in this window. If you have dial-up connection then establish the connection at first in order to AMV can determine DNS settings. You can also determine DNS-servers addresses independently using IPCONFIG utility with key /ALL under Windows NT, or using WINIPCFG utility under Windows 95 or Windows 98. They are utilities of operation system.

Automatically update DNS settings

Automatically replace primary and secondary servers by system DNS, if they are found. Settings check and update happen every second. DNS settings not updated when program settings window is opened.

See also: DNS servers list, Program setup


SMTP settings
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Domain for “HELO”

Your domain for introducing to SMTP-servers. It is recommended to use your real domain. If the domain is not specified, the program tries to determine your domain itself. If it cannot be done for some reason, the domain localhost is used. The use of somebody else's domain or localhost alias is allowed but not recommended - the servers with high security level can refuse to work with you.

If you’re connected to the Internet through Socks5 proxy server, you have to set the proxy server domain manually here – the program can not determine the proxy domain itself.

Email for “MAIL FROM”

Email address used in “MAIL FROM” request to mail server. It is recommended to use your real address. Otherwise, servers with high security level can refuse the request.

Verify only via the most priority SMTP server

This setting instructs the program to check the addresses only on the most priority server and, if this server is down, don't try other servers (with lower priority).

Execute VRFY command for exist e-mails

VRFY command of SMTP protocol [RFC 821] apply to get real name or organization name of e-mail address owner. Unfortunately, only about 10% of mail servers support this command. Turn on VRFY command, check the list and save checking log (not “short” log). You can analyze servers answers by NextStr utility. This feature is experimental.

Execute RSET at end of SMTP session

Without this command some SMTP servers may send blank message to recipient. We do not recommend to turn off this setting.

See also: Program setup


Filtering
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

To control the contents of output file. For example, you can tune the program to save only “bad” addresses in list. You can save the file, change these settings and save the file under another name - to receive two lists as a result, the first one with “good” and the second one with “bad” addresses. Your can manage filtering both from “Filtering” in program settings and “Save As…” dialog.

Save checked “Exist” emails

To save the addresses which were checked and identified as existent ones.

Save checked “Bad” emails

To save the addresses which were checked and identified as non-existent ones.

Save emails in “Unknown” state

To save the addresses, whose checking has not been completed.

Save unchecked emails

To save the addresses, which have not been checked yet. It is useful when you stop or pause the checking.

See also: Program setup


Proxy settings
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Connection through Socks5 proxy server

Proxy server is a special program which allows LAN users to work with Internet (when only one machine has the “real” IP address). Please contact your network administrator if you’re not sure how you’re connected, and how to set appropriate options here. Such popular program as ICQ works in LAN using Socks5 protocol. You must indicate proxy-server domain in SMTP settings if you use proxy-server.

Address

Proxy-server address. May be either domain or IP-address. Examples: proxy.isp.com, 10.1.1.1.

Port

Usually, it is 1080. Don’t confuse Socks5 proxy with http and ftp proxies, which are on 3128 and 3121 ports by default. The program doesn’t work through http or ftp proxies.

Use RFC 1929 authentication (clear-text)

The server requires authentication, i.e. requires user login and password. In most Socks5 realizations, the login and password are transferred as a plain text, as described in RFC 1929 document.

Login

The name (login) of Socks5 proxy server user.

Password

The password for Socks5 proxy server user.

Use mapping for DNS

Use port mapping to work with DNS using UDP protocol. Some proxy-server realizations, for example WinGate 3.0, work incorrectly using UDP protocol, and in that case it is necessary to use such mapping. For example, if your proxy-server has an address 10.1.1.1, then map 53 UDP-port of the first DNS, e.g. ns.ml.org, to 53 local port, and the port of the second DNS – to 54 local port. In DNS setting, indicate these addresses as 10.1.1.1 and 10.1.1.1:54 (port 53 is used by default).

See also: Program setup


Emails Colors

EMMA Labs web site

Navigation: Program settings:

Colors
No contents entries on this page
Contents
Topic functions menu
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

You can set different colors in list for emails with different check results.

See also: Program setup


How to register

EMMA Labs web site

Navigation: Registration:

Registration
No contents entries on this page
Contents
Topic functions menu
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

You can register your copy of AMV via registration service using any major credit card. You can register on-line, using fax, toll-free phone, by check or wire transfer. Money orders are also accepted.

On the Internet, go to our Web page at: http://www.mailutilities.com/purchase/ and follow the link "Purchase AMV".

You can also use the wire transfer to register AMV. Please contact EMMA Labs. for more details.

On payment approval, we'll send you the registration key, which will remove the nag screen in AMV and enable some additional features. Your registration will be valid for all future versions of AMV.

See also: Program support


Unregistered copy limitations

EMMA Labs web site

Navigation: Registration:

Unregistred copy limitations
No contents entries on this page
Contents
Topic functions menu
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

The unregistered version of AMV is almost fully functional. However, it has following limitations:

- on start, the program displays the nag screen;

- you can save no more than first 100 processed emails;

- exporting of results via ODBC into database is disabled;

- exporting of TheBat check results is disabled;

- exporting of Windows Address Book check results is disabled.

Also, we can provide only limited support (and with low priority) to unregistered users.

When you’ll register, you’ll get the registration key (serial number) which will remove the nag screen and allow you to saving program results. Your registration key will work for all major future versions of AMV (or we may provide you with the new key, if the keys will be changed for some reason).

If you're using AMV COM interface but haven't purchased the developer license yet, AMV will show nag screens sometimes (when you call methods of AMV COM object).

See also: Program registration, Program support


Web Server
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

On the web-site you can find the complete list of our software products and the latest news, download trial versions of the products, and register your software.

· Advanced Email Extractor

· Mailing List Wizard

· Advanced Direct Remailer

· High Speed Verifier

Most of our products are being updated once a month on the average. Don't forget to visit our site, we are always glad to see you! Should you have any questions or suggestions, please, contact the technical support service.


Program support
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Before you contact us, please do the following:

·Be sure that you’re doing everything right. We all make mistakes sometimes... Be attentive.

·Look at the Help file: it may already contain an answer to your question. A lot of people ask us something like "how do I…", though the complete information is there (in the document you’re reading now).

·Visit AMV home page in the Internet at http://www.emmalabs.com/amv/. It’s a good chance that you’ll find the newer version of AMV there; we’re trying to update the program once a month or even more frequently – when our staff is not on vacations, of course. Also, if the serious bug has been found in the program, but the new version is not ready yet, we make the hot fix for it.

But if you still have a problem with AMV and noting else helps, please contact technical support staff at:

http://www.emmalabs.com/support/

Please inform us about the following:

·Advanced Maillist Verify version (from About dialog)

·Advanced Maillist Verify registration code or user ID (if you're a registered user) – this will help us to process your request faster

·where did you get Advanced Maillist Verify (http or ftp site)

·Windows version (including service packs and other fixes installed), US or international, OEM or not

·computer information: CPU type and speed, amount of memory installed

·description of your problem (as much information as possible to retrieve the problem)

·any additional information, which may help: DNS and SMTP settings, etc.

We’ll try to help you as fast as possible, usually in one or two business days.

If you have any comments or suggestions for the next releases, please feel free to post them to us.


Advanced Email Extractor
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Advanced Email Extractor 3 (EmEx 3) is designed to extract e-mail addresses from web-pages on the Internet (using HTTP and HTTPS protocols) and from HTML and text files on local disks. EmEx 3 supports operation through a proxy-server and works very fast, as it is able of loading several pages simultaneously, and requires very few resources.

EmEx 3 is intended to collect information (e-mail addresses, phone numbers, ICQ/MSN/Skupe UINs and many others) from public sources in Internet.

The most common issues, which appeared in our other smart solution - Advanced Email Extractor (AEE), were solved in EmEx 3. Also, we took into account the newest technologies of email addresses protection from extracting and collection.

The software interface is more simple and handy and program's features are almost unlimited.

More 300 search engines over whole world can process your queries now. We constantly track the actuality of script databases for processing of search engines results, so you don't need to update the software if a search engine changes the format of data. You will get the updated settings with every run of EmEx 3.

Take a look to a short list of EmEx 3 features:

·Data search in different sources including search engines

·Support of more than 300 search engines (including Yahoo, Google, MSN)

·Simplified HTTP authorization on such websites as web forums or paid services

·Search limitations: by country, domain, document code page

·Customizable list of exceptions

·Black and white lists

·List of ignored domains

·Filter by keywords with support of logical expressions

·Anti-flood filter to regulate load on scanned websites (anti-hammer);

·Scheduler

·Dynamic replacement of document's content

·Masking by User-Agent

·Filters by MIME-types of the scanned document

·Mode of multi thread scanning which enables to process up to 50 documents at once

·Limitation of loading speed

·Daily updated script schemes for information recognition

·Proxy support

·Daily updated lists of proxy servers

·An ability to form non standard search templates without updating the application

·and much more!

EmEx 3 works under Vista/Windows 7/8 with Microsoft Internet Explorer 8.0 or higher installed. It will never go out-of-date - it will become better and better, it's capabilities will expand with every new release of Internet Explorer.

You can download program free from our site.


Advanced Direct Remailer
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Advanced Direct Remailer (ADR) is a powerful remailer and mass mailer which send your message straight out to the recipient's mail server (without your ISP's SMTP server). ADR realizes multi-threaded direct delivery, and so works several times quicker than usual email client. The program has its own internal SMTP server, and can be easily intergated into any email client (Outlook, Outlook Express, Edudora etc), any other mail server or mass mailer (e.g. Eserv, GroupMail etc.).

Support for simple mailing lists (.TXT, .LST, .CSV with personification), Windows address books (.WAB) and mailing lists which are formed by database SQL-request on fly, user's programs for message processing (plugins), merging mailing lists with databases from Excel document to powerful Microsoft SQL Server or Oracle, determine up to 90% of "dead" e-mails in address list befor sending, detailed and handy logs for each sent email, open API for programmers and samples with source code, comfortable Monitor and easy control of messages flow.

The program supports Socks5 proxy protocol, so you can use it within a Local Area Network (LAN), too. ADR ensures faster, safer, and more easy-to-control mail sending, and thus it helps to save your time and money!


High Speed Verifier
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

High Speed Verifier (HSV) is a high-speed software designed to check e-mail address for existence. HSV is capable of checking thousands of addresses per second. It can easily deal with mailing lists containing tens millions of addresses; moreover, it is with this list size that the program's highest performance can be achieved.

HSV detects about 20-30% of invalid addresses in a mailing list, though theoretically it is possible to detect up to 60-70% using a software product. This figure seems relatively small, but actually it might make 10% of a list. Besides, HSV provides for optimal checking mode in terms of time and data traffic. More thorough checking (with which the rest 40% of invalid addresses could be detected) takes 10 times longer and requires 5 times greater traffic for each address, hence it's not that advisable with huge lists.

We are pleased to offer you two software products designed to check e-mail addresses for existence — Advanced Maillist Verify (AMV), which does the two-phase checking (DNS and SMTP) and detect all possible dead emails, and High Speed Verifier (HSV), which only performs the first phase (DNS).

AMV is helpful when you need to thoroughly check relatively small mailing lists (containing no more than 50..100 thousand addresses). Advanced Maillist Verify is also capable of checking addresses in databases, address books of popular applications, it has COM/ActiveX interfaces for integration into various software systems and CGI/ISAPI modules for simpler integration into wed-servers. However, technical principles underlying AMV interface solutions don't allow using it for longer lists.

High Speed Verifier is offered as a solution for quick removal of garbage from lists with millions of addresses. For purely technical reasons, its operating rate is 10..15 times greater than that of AMV with relatively small lists, and with lists containing millions of addresses the difference in operating rate might be up to thousands of times. Growth of the HSV operating rate with longer lists is ensured by the fact that HSV stores the results of all queries to DNS servers in RAM cache, so, with longer lists the rate of cache hits is greater.

HSV is the first professional software designed to check huge mailing lists, it is created by professionals for professionals. We hope with HSV your business will be more effective and successful, and you will enjoy using our product.

You can download program free from our site.


Mailing List Wizard
No contents entries on this page
Go to previous topic
Go to home topic
This is the last topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Mailing List Wizard (MLW) is designed to help you with processing and converting your mailing lists. It is able of excluding duplicated addresses, correcting misspelled addresses using unique algorithms, filtering lists by varied criteria, merging lists, and making exclusions from address lists using an additional list. MLW can supplement mailing lists with address owner names using information from other lists, delete address owner names from mailing lists, sort emails in mailing lists, and also many other things. MLW is a single software product that combines functions of several programs for mailing list processing.

The program works in a wizard mode: it will prompt you step by step to choose action type; to choose a file the action is to be taken upon (source file); to choose a file the results to be saved into (destination file); to choose action settings and to specify additional files to be involved in the action.

When an operation is being performed, the results are stored in a temporary file on disk, and they are moved to the destination file only after the action is successfully completed. This allows interrupting an action in any phase without a risk of losing data any changes to files involved in the action are made only upon its completion. The temporary file is created in the same directory where the destination file is to be stored. Therefore, you need to have enough of free space on your disk so the temporary file could be saved.

During an action, the program is displaying a real-time log showing the action progress. For example, when exclusion of duplicated addresses is being performed, all the duplicated addresses found will be written to the log along with line numbers. Besides, the log contains statistic information such as number of lines processed, action execution time, etc. When processing large mailing lists, the number of entries in the log might exceed 100000, and refreshing the log on the screen might take system resources comparable to resources needed for the list processing itself. Therefore only first 60 K of the log are displayed real-time (about 1500 lines).

The whole log is stored in a temporary file in the MLW directory. After the action is completed, you can save the log from temporary file to any other file, open and view it with a text editor. You can also choose the option "Statistics only in this window" if you want only important information and statistics to be shown real-time (total about 5-20 lines during an action).

You can download program free from our site.


DNS servers list

EMMA Labs web site

Navigation: »No topics above this level«

DNS servers list
No contents entries on this page
Contents
Topic functions menu
Menu
This is the first topic
Go to home topic
This is the last topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

The access time to DNS-servers, which the program uses by default, is 2-3 seconds for some users. Apply to your Internet provider for its DNS-server address, if you want to shorten this period till half a second. Program tries to determine DNS settings by itself and show them in "Windows DNS Settings" at "DNS" tab in general settings. You can also determine DNS-servers addresses independently using IPCONFIG utility with key /ALL

Also you can use DNS servers from this list if you can't get your provider DNS address for some reason or your provider server works unstably.

ns.worldnet.att.net AT&T-WorldNet (USA, www.worldnet.att.net)

nameserver.concentric.net Concentric (USA, www.concentric.net)

arl-name-svc-1.compuserve.com CompuServe (USA, www.aol.com)

ns.psi.net PSInet (USA, www.psi.net)

dns1.sympatico.ca Sympatico (Canada, www.sympatico.ca)

pns.dtag.de T-Online (Deutschland, www.dtag.de)

dns-sol.swissonline.ch SwissOnline (Switzerland, www.swissonline.ch)

main.piter.net PiterNet (Russia, www.piter.net)

See also: DNS settings


Windows Address Book file location

EMMA Labs web site

Navigation: »No topics above this level«

Windows Address Book file location
No contents entries on this page
Contents
Topic functions menu
Menu
This is the first topic
Go to home topic
This is the last topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Windows Address Book is in file with .WAB extension. This file can be placed in different directories depending on operating system version and mail program.

Internet Mail and News

The Windows Address Book used by Internet Mail and News is located in the Windows folder. The Address Book file is named <user name>.wab, where <user name> is the name with which you log on to Windows 95. If you do not have a logon name for Windows 95, the default name for the file is UserMPS.wab.

For some systems with installed Internet Explorer 3.02, Address Book name may be <username>.wab.ie3 instead of <username>.wab.

Outlook Express

The Windows Address Book used by Outlook Express is located in the <Windows>\Application Data\Microsoft\Address Book folder, where <Windows> is the folder in which Windows 95/98 is installed.

In Windows NT and in Windows 95/98 with user profiles enabled, the Windows Address Book is located in the <Windows>\Profiles\<Username>\Application Data\Microsoft\Address Book folder, where <Windows> is the folder in which Windows is installed, and <Username> is the name you use to log on to Windows.

Other configurations

You can find the file with Address Book by yourself. For that use the window for file search (“Start” / “Search” / “For Files and Folders …”) and specify the search mask:

*.WAB

Probably, the file with Address Book will have the same name as the user name and it is placed in one from the Windows subdirectories.

See also: Windows Address Book wizard