Введение
No contents entries on this page
Contents
Topic functions menu
Menu
This is the first topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Эта программа предназначена для проверки адресов электронной почты и списков рассылки. Основная задача - определить, на какие адреса в списке рассылки слать почту уже бесполезно. Программа ориентирована, в основном, на программистов, которые имеют собственные списки рассылки для оповещения своих пользователей о выходе новых версий программ.

Так, у меня в списке рассылки около 850 человек. Из них около сотни - “мертвые души”. Человек подписался, сменил провайдера и подписался снова. “Мертвые души” не только не дают возможности объективно определить число подписчиков, но и существенно мешают нормальному функционированию почтовой системы. Послав 850 писем, я еще трачу время на то, чтобы получить сто своих писем обратно с припиской “извините, но такого адреса нет”.

Программа работает по тому же алгоритму, что и почтовые системы провайдеров. Из DNS извлекаются адреса почтовых серверов для указанного адреса. Программа пытается соединиться с найденными SMTP-серверами и имитирует посылку письма. До самой отправки письма дело не доходит - как только почтовый сервер сообщает, что такого адреса нет, или, наоборот, есть, AMV раскланивается.

AMV позволяет отловить порядка 90% “мертвых душ” - некоторые почтовые системы устроены так, что принимают все, что им дашь. И лишь затем разбираются с тем, что им дали и, если такого адреса нет, шлют письмо с выражением соболезнований.

Программа многопоточна, что обеспечивает очень высокую скорость проверки и позволяет регулировать нагрузку на Сеть и на Вашу машину. Работать с AMV может и опытный администратор, и грамотный пользователь - надеемся, что создали мощную, простую и удобную для Вас программу.

См. также: Подробное описание программы, Настройка программы

© 2009-2014 EMMA Labs


Описание программы
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Общие слова были сказаны во “Введении”. Здесь приводится более подробная информация о программе. Часть сведений рассчитана на профессиональных пользователей.

Работающая программа имеет вид показанный на рисунке. Максимальное число адресов в проверяемом списке - 100000. Если Ваши списки больше, поделите их на части при помощи утилиты AmvSplit.

Колонка “Обработанные адреса” - адреса электронной почты, прошедшие проверку. “Результат” - результат проверки, может принимать следующие значения: “Существует” - адрес электронной почты существует, “Плохой синтаксис” - синтаксис адреса неверен (см. “Формат списков рассылки»), “Нет в DNS” - почтовые сервера не найдены в DNS, “Не сущ. (SMTP)” - почтовый ящик не существует, согласно заверению почтового сервера, “Неизвестно” - не удалось выяснить, например, потому, что не удалось соединиться с почтовым сервером. Колонка “Комментарий” содержит описание причины, заставившее программу принять то или иное решение.

На панель управления вынесены кнопки запускающая, останавливающая и приостанавливающая проверку. Остановив проверку, Вы можете снова запустить ее, при этом все адреса с результатом “Неизвестно” будут помечены как непроверенные и AMV проверит их еще раз. Приостановив проверку, Вы можете запустить ее с того же места, откуда прервали. После завершения проверки Вы можете запустить ее снова - при этом все адреса с результатом “Неизвестно” будут помечены как непроверенные и AMV проверит их еще раз. Также на панели есть кнопки, требующие особого пояснения.

log | Просмотр журнала - в нем отображены все стадии проверки письма со всеми доступными техническими деталями. Просмотр журнала также вызывается двойным щелчком по адресу в колонке “Обработанные адреса”.
unverify | Нажатие этой кнопки отмечает проверенный адрес как непроверенный, в результате чего он удаляется из колонки “Обработанные адреса” и становится в очередь на проверку.
check | Проверка одиночного адреса, а не списка рассылки. Также полезна, если Вы хотите еще раз “перепроверить” какой-нибудь адрес. Удобно еще и то, что журнал проверки просматривается в реальном времени, а не только тогда, когда проверка закончена.

Алгоритм обработки адреса такой. Вначале из DNS выбираются все MX- и A- записи, соответствующие указанному адресу электронной почты. AMV работает с одним или с двумя DNS серверами, задаваемыми в настройках. Если на первом DNS сервере адрес не найден, то программа пробует узнать его на втором. Каждому DNS-серверу запрос повторяется два раза, чтобы исключить случайности. Если SMTP-серверы найдены, то в журнал попадает строка вида:

Found 4 relay(s) (univ.uniyar.ac.ru [10], nethost1.yars.free.net [20], gemini.yars.free.net [30], netserv2.free.net [50])

В квадратных скобках указан код приоритета. Наиболее приоритетен сервер с меньшим кодом. Программа пытается связаться с наиболее приоритетным из найденных почтовых серверов. Если этот сервер по каким-то причинам оказывается недоступен, программа обращается к следующему серверу и т.д. Если Вы хотите, чтобы адрес проверялся только на самом приоритетном сервере, то пометьте в настройках SMTP пункт “Verify only via the most priority SMTP server”. Если в списке есть два адреса с одного домена (например, a@hotmail.com и b@hotmail.com), то второй раз программа не станет обращаться к DNS - адреса почтовых серверов будет выбраны из внутреннего кэша программы, который может быть отключен в настройках DNS.

На почтовом сервере происходит диалог такого вида:

220 ESMTP ESMTP unicorn.carrier.kiev.ua

HELO gorlach.ol.enet.ru

250 unicorn.carrier.kiev.ua Hello gorlach.ol.enet.ru [194.186.20.132], pleased to meet you

MAIL FROM: <check_email@gorlach.koenig.su>

250 <check_email@gorlach.koenig.su>... Sender ok

RCPT TO: <elbrus@carrier.kiev.ua>

550 <elbrus@carrier.kiev.ua>... User unknown

RSET

250 Reset state

QUIT

Программа представляется (HELO) и говорит что хочет написать письмо с адреса check_email@gorlach.koenig.su (MAIL FROM) на адрес elbrus@carrier.kiev.ua (RCPT TO). Независимо от того, что скажет SMTP-сервер, программа вместо тела письма дает команду разрыва связи QUIT. Никакого письма в проверяемый ящик не попадает.

В настройках Вы можете указать как представляться программе - программа может вычислять Ваш домен автоматически или пользоваться указанным, и какой адрес использовать в MAIL FROM. Более подробно см. в разделе “Настройка SMTP”.

Также программа может использовать прямую доставку. Например, для адреса alex@gorlach.com пытаться доставить письмо на SMTP-сервер gorlach.com, если в DNS не найдены адреса SMTP-серверов. Прямая доставка в жизни не используется и применение ее не рекомендуется. Обязательно прочтите “Настройка DNS” перед использованием этой опции!

Используя фильтрацию, Вы можете сохранить, например, только “плохие” адреса или же только непроверенные - см. более подробно в разделе “Фильтрация”.

См. также: Советы по работе с программой


Советы по работе с программой
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Несколько советов, которые помогут использовать Вам программу более эффективно.

·Увеличение числа сканирующих потоков ускорит проверку, но увеличит нагрузку на Сеть. Рекомендуется использовать 20..30 потоков для соединения с Интернет на 33.6k. См. раздел “Общие настройки”.

·Включение прямой доставки может привести к тому, что адреса, которых нет в DNS, не будут помечены как “плохие”. См. раздел “Настройки DNS”.

·Указание несуществующего или чужого домена для HELO чревато тем, что некоторые спамобоязненные сервера не допустят Вас к проверке ящика и программа пометит адрес как несуществующий. См. раздел “Настройки SMTP”.

·Применение фильтрации позволяет управлять содержимым выходного файла. Например, он будет содержать только “плохие” адреса. См. раздел “Фильтрация”.

·Если Вы хотите проверить ящик admin на почтовом сервере smtp.enet.ru, воспользуйтесь специальным синтаксисом admin@[smtp.enet.ru] . См. раздел “Форматы списков рассылки”.

См. также: Описание программы


Форматы списков рассылки
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Поддерживаются два формата список рассылки. Первый - обычный текстовый файл, каждая строка которого содержит один адрес электронной почты. Максимальное число адресов в проверяемом списке - 100000. Если Ваши списки больше, поделите их на части при помощи утилиты AMVSplit. Адрес может быть записан практически любым способом:

amv@gorlach.koenig.su

<amv@gorlach.koenig.su>

Alexander P. Gorlach <amv@gorlach.koenig.su>

“Alexander P. Gorlach” <amv@gorlach.koenig.su>

“Alexander P. Gorlach” amv@gorlach.koenig.su

Alexander P. Gorlach amv@gorlach.koenig.su

amv@gorlach.koenig.su - Alexander P. Gorlach

Если Ваши списки рассылки имеют особый формат - пишите, и его поддержка будет встроена в программу. Но, я думаю, любая программа имеет возможность экспорта своего формата в текстовый файл и импорта обратно, как, например, Outlook Express.

Вы также можете использовать специальный синтаксис записи адреса MAILBOX@[SMTP-SERVER]. Например, чтобы проверить ящик аlex на сервере smtp.enet.ru, напишите alex@[smtp.enet.ru]. Сервер может быть задан доменом или IP-адресом, через двоеточие может быть указан tcp-порт (по умолчанию - 25).

Второй формат - текстовый файл, разделенный запятыми (*.csv). Сделан специально для пользователей Outlook Express. Вы можете экспортировать всю адресную книгу в текстовый файл, разделенный запятыми. Расширение этого файла должно быть CSV. После чего загрузить файл в AMV, сохранить результат, очистить адресную книгу в Outlook Express и импортировать ее обратно из CSV-файла. Рекомендуется сделать резервную копию списка ! В CSV-файлах проверяется только первый адрес электронной почты.

Начиная с версии 2.0, AMV может работать с адресными книгами напрямую, безо всяких дополнительных преобразований формата.

См. также: Импорт/экспорт из адресных кних Windows, Работа с источниками данных ODBC


Командная строка
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Используя командную строку и планировщик заданий Windows (или любой другой), Вы можете полностью автоматизировать проверку списков рассылки.

Синтаксис: AMV.EXE [ключ] [ “входной файл” [“выходной файл” [“реверсивный выходной файл” [“третий выходной файл”]]]]

Ключей может быть несколько, они должны быть перечислены перед именами файлов. Все неверные значения ключей игнорируются AMV, сообщений с предупреждениями не выводится. Допустимые значения:

-MINIMIZED – запустить программу в “свернутом” виде;

-SAVELOG – сохранить журнал, журнал будет помещен в каталог с входным файлом и будет иметь имя входного файла и расширение .LOG;

-SAVESHORTLOG – сохранить “короткий” журнал, журнал будет помещен в каталог с входным файлом и будет иметь имя входного, и расширение .SLOG если задан также ключ –SAVELOG и расширение .LOG в противном случае;

-EXITCOMPLETE – завершить работу программы после проверки списка и сохранения его. Этот ключ срабатывает, только если оператор не приостанавливал и не останавливал проверку и если был задан выходной файл;

-ODBCSQL – работа с источником данных ODBC SQL, а не со списками рассылки, см. детали ниже.

Выходной файл может совпадать с входным файлом. “Реверсивный” выходной файл сохраняется с инвертированными настройками фильтрации . В “третьем файле” AMV сохраняет плохие, не проверенные адреса и те, что проверить не удалось, независимо от настроек фильтрации. Если выходной файл не указан, AMV не сохраняет результаты работы автоматически, и ключи –EXITCOMPLETE, -SAVELOG и –SAVESHORTLOG не работают.

Начиная с версии 1.67 вы можете устанавливать индивидуальные настройки фильтров для каждого выходного файла из командной строки при помощи ключа –FILTER. Ключ должен быть указан после имени выходного файла. Если –FILTER не указан, ты выходные файлы сохраняются как это было описано выше.

Формат: -FILTER:EBUN, где

E – сохранять “существующие” адреса в выходной файл;

B – сохранять “плохие” адреса в выходной файл;

U – сохранять адреса, которые не удалось проверить в выходной файл;

N – сохранять непроверенные адреса в выходной файл.

Ключ –ODBCSQL показывает что входной и выходной файлы это запросы SQL к источнику данных ODBC, ф не списки рассылки. Эти файлы содержат выражения SQL в следующем формате:

имя_источника_данных,<имя_пользователя>,<пароль>,выражение_SQL

Заключенные в скобки поля (<>) могут быть пустыми, например:

MyDatasource,

Admin,

Password,

SELECT

email

FROM

customers

WHERE

email<>NULL

или

MyDatasource,,,

UPDATE customers

SET result='%result%'

WHERE email='%email%'

Более подробно особенности запросов SQL рассматриваются в статье “Работа с источниками данных ODBC”, которая описывает работу мастеров импорта/экспорта из источников данных ODBC. Также посмотрите файлы SqlImport.SQL и SqlExport.SQL в каталоге с Advanced Maillist Verify. При экспорте, выражения SQL выполняются согласно указанным настройкам фильтрации (по умолчанию или ключом –FILTER).

Примеры:

AMV.EXE -MINIMIZED -EXITCOMPLETE my.lst “verified my.lst”

AMV.EXE -MINIMIZED “product customers.lst”

AMV.EXE my.lst my.lst

AMV.EXE “c:\program files\Eserv2\mail\lists\admins.txt”

AMV.EXE –SAVELOG –SAVESHORTLOG 1.lst 1.out 1reverse.out

AMV.EXE input.lst output.lst –FILTER:EUN bad.lst –FILTER:B

AMV.EXE in.txt o1.lst –FILTER:E o2.lst –FILTER:NU o3.lst –FILTER:B

AMV.EXE –EXITCOMPLETE my.lst myout.lst –FILTER:NEU

AMV.EXE –ODBCSQL SqlImport.SQL SqlExport.SQL –FILTER:EBUN

AMV.EXE –EXITCOMPLETE –ODBCSQL –SAVELOG SqlImport.SQL SqlOut_1.SQL SqlOut_2.SQL


Настройки диалога “Открыть список…”
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Эти настройки действуют только при загрузке файла через диалог Файл \ Открыть. При загрузке через командную строку настройки этого диалога не действуют.

Удалять дублирующиеся адреса

Удаляет строки, содержащие дублирующиеся адреса электронной почты. Удаленные строки будут сразу показаны на экране, со значением “Отфильтрован” в колонке результата. Чтобы записать удаленные строки в выходной файл, нужно включить настройку “Сохранять плохие адреса” в диалоге “Сохранить как…” или на закладке “Фильтр”.

Удалять адреса, содержащие подстроки

Удаляет адреса, содержащие одну из указанных подстрок, заданных через запятую. Поиск подстрок идет без учета регистра. Удаленные строки будут сразу показаны на экране, со значением “Отфильтрован” в колонке результата. Чтобы записать удаленные строки в выходной файл, нужно включить настройку “Сохранять плохие адреса” в диалоге “Сохранить как…” или на закладке “Фильтр”.

Также возможно использование регулярного выражения вместо подстроки. Регулярное выражение обеспечивает более мощные шаблоны для поиска строки символов. Познакомиться с синтаксисом регулярных выражений можно по следующим адресам.

На русском языке:

http://www.citforum.ru/internet/php/regexp.shtml

http://www.citforum.ru/internet/perl_tut/re.shtml

http://allo.usaaa.ru/wdh/js05.htm

http://www.kgtei.kts.ru/~lib/gnulib/on-line-python/lib_py/lib152/re-syntax.html

На английском языке:

http://www.perl.com/CPAN-local/doc/manual/html/pod/perlre.html

http://www.python.org/doc/lib/re-syntax.html

http://perso.magic.fr/roumazeilles/regex.htm

http://www.boost.org/libs/regex/index.htm

Вы также можете найти много других документов на эту тему по запросу “синтаксис регулярных выражений” (regular expressions syntax) на поисковых машинах.

Удалять адреса, НЕ содержащие подстроки

Полностью аналогичен предыдущему пункту с точностью до наоборот. Адрес будет удален, если не содержит ни одной из указанных строк или не соответствует регулярному выражению.

Удалять %20 и другие ошибки в адресах

Программа исправляет ошибки только в обычных списках рассылки (файлах с расширением LST и TXT) и не исправляет ошибки в файлах CSV (Comma Separated Values). Например, с включением этой опции программа приведет следующий список:

Alex <%20alex@domain.com>

Mary <mary @domain.com>

John <john@@domain.com>

к нормальному виду:

Alex <alex@domain.com>

Mary <mary@domain.com>

John <john@domain.com>

Программа удачно исправляет около 90% ошибок, встречающихся в списках рассылки. Во время тестирования программа не повредила ни одного правильного адреса в списке, но некоторые адреса были исправлены неверно. Для контроля результатов исправлений программа при загрузке списка выводит отдельное окно, где показаны оригинальные и исправленные адреса. Окно не появляется, если во время загрузки ни одного адреса исправлено не было.

Для демонстрации исправления ошибок, включите эту опцию и загрузите файл EmlBugs.LST, находящийся в одном каталоге с Advanced Maillist Verify.

Пожалуйста, не стесняйтесь присылать нам примеры адресов, которые программа не смогла исправить или исправила неверно. Мы постараемся внести дополнения в алгоритм работы программы.

См. также: Форматы списков рассылки


Работа с источниками данных ODBC
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Со многими базами данных можно работать через ODBC. Oracle, Microsoft SQL Server и даже с документом Excel можно работать с как с базой данных через драйвера ODBC и запросов SQL.

AMV может импортировать списки рассылки из базы данных при помощи мастера, запускаемого через меню "Файл" -> "Импорт через ODBC". Мастеру нужно указать имя источника данных (DSN, data source name), пользовательское имя и пароль для доступа к источнику и SQL-запрос, по которому из базы данных будут извлечены адреса электронной почты.

За сведениями о языке SQL рекомендуется обратиться к руководству по своей базе данных. В результате запроса должен быть получен список рассылки в формате поддерживаемом AMV. Каждая строка ответа на SQL-запрос эквивалентна строке в списке рассылки. Примеры запросов:

SELECT email FROM customers_table

SELECT

name,'<'+email+'>'

FROM

customers_table

WHERE

email<>NULL

Из базы данных будет импортировано не более 100000 адресов. Рекомендуется проверять адреса более мелкими порциями по 5000..10000 адресов, так как AMV требуется порядка двух килобайт оперативной памяти для каждого адреса (для хранения самого адреса, журнала проверки адреса и т.п.) и для проверки большого списка нужен значительный объем оперативной памяти.

Экспорт результатов проверки, запускаемый через "Файл" -> "Экспорт через ODBC" позволяет выполнить для каждого адреса из загруженного в AMV выражение на SQL. Вы можете указать на первой странице мастера фильтрацию адресов чтобы, например, выполнить запросы только для успешно проверенных адресов. При вводе SQL-выражения используются шаблоны %email% и %result%, при выполнении запроса вместо них в выражение подставляется адрес электронной почты и текстовое описание результата его проверки. В версии AMV 4.0 добавлены еще три макроса - %code%, %log%, %comment%, которые заменяются соответственно на числовой код результата проверки, журнал проверки адреса (содержит несколько строк текста) и комментарий.

Например, выражение:

UPDATE

customers_table

SET

email_status='%result%'

WHERE

email='%email%'

будет для адреса ag@mail.ru, проверенного с результатом "Нет в DNS" расширено в выражение:

UPDATE

customers_table

SET

email_status='Нет в DNS'

WHERE

email='ag@mail.ru'

Аналогично оно будет расширено и для всех остальных адресов и это SQL-выражение будет выполнено соответствующее число раз.

См. также: Описание программы, Техническая поддержка


Мастер адресных книг Windows
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Адресные книги Windows хранятся в файлах с расширением .WAB и используются в почтовых программах Microsoft, например, в Internet Mail, Internet News и Outlook Express. Вы можете ознакомиться с содержимым и возможностями адресной книги при помощи одной из вышеперечисленных программ.

Импорт адресной книги Windows

Импортировать список адресов электронной почты из адресной книги в Advanced Maillist Verify можно при помощи мастера, вызываемого через меню “Файл”. Вы можете выбрать для импорта адресную книгу, используемую в системе по умолчанию или любую другую адресную книгу, указав файл, в котором она хранится. В каких файлах и каталогах хранятся адресные книги, описано статье “Расположение адресной книги Windows”.

Адресные книги, скопированные с другого компьютера, могут открываться с ошибкой или не открываться вообще. Смотрите статью “How to Copy an Outlook Express WAB to Another Computer” из Microsoft Knowledge Base с рекомендациями по переносу адресных книг с другого компьютера.

Экспорт адресной книги Windows

Экспортировать результаты проверки обратно в адресную книгу в Advanced Maillist Verify можно при помощи мастера, вызываемого через меню “Файл”. Экспорту подлежат только результаты проверки адресной книги, экспортировать результаты проверки списка рассылки или базы данных в адресную книгу Windows нельзя.

Экспорт результатов проверки заключается в удалении адресов (контактов, contacts) из адресной книги. На первой странице мастера вы указываете, какие адреса (не существующие, существующие, не проверенные или те, которые проверить не удалось) должны быть удалены из адресной книги. Обратите внимание на то, что удаленные адреса невозможно будет восстановить. Рекомендуется сделать копию файла с адресной книгой. В каких файлах и каталогах хранятся адресные книги, описано статье “Расположение адресной книги Windows”.

После экспортирования результатов программа может выдать сообщение, что были удалены не все адреса из тех, которые нужно было удалить. Это может объясняться тем, что некоторые адреса (контакты, contacts) входили в состав групп (contacts groups, distribution list) и присутствовали одновременно и в общем списке контактов и в списке группы. При удалении такого контакта из общего списка он автоматически удалялся и изо всех групп (contacts groups) в которые он входил.

См. также: Мастер адресных книг TheBat, Форматы списков рассылки, Расположение адресной книги Windows, Фильтрация


Мастер адресных книг TheBat
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

По умолчанию, адресные книги TheBat хранятся в файлах с расширением .ABD в подкаталоге MAIL программы. Загрузить почтовую программу TheBat можно с веб-сервера: http://www.ritlabs.com/

После экспорта результатов проверки необходимо перезапустить TheBat, чтобы он загрузил обновленную адресную книгу. При экспорте результатов проверки, AMV удаляет адреса электронной почты из адресной книги в соответствии с настройкой фильтров. Если контакт адресной книги после удаления адреса не будет содержать ни одного адреса электронной почты, то контакт также будет удален.

Рекомендуется делать резервные копии адресных книг перед экспортом результатов проверки.

См. также: Мастер адресных книг Windows


Мастер адресных книг Eudora

EMMA Labs web site

Navigation: Информация для программистов:

Информация для программистов
No contents entries on this page
Contents
Topic functions menu
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Начиная с версии 2.1, AMV имеет COM интерфейс. COM это объектная модель на которой построены управляющие элементы ActiveX и OLE. COM позволяет объектам предоставлять их функциональность другим компонентам и приложениям. COM определяет связь объектов, взаимодействие объектов между процессами и сетями. Теперь Вы можете использовать возможности Advanced Maillist Verify в любом языке программирования и в любом программном обеспечении поддерживающем COM.

Теперь Вы можете использовать AMV из Microsoft Visual C++, Borland Delphi, CBuilder и Microsoft Visual Basic и из множества других средств разработки. Вы можете использовать AMV на своих веб-страницах ASP (Active Server Pages, Microsoft Technology) и ColdFusion – AMV будет проверять правильность ввода данных пользователем. Вы можете работать с AMV установленным на другом компьютере через DCOM (Distributed COM Service). И вы можете взаимодействовать с локальной копией AMV из VBScript и JavaScript. Вы можете все!

См. также: Интерфейс EmailVerifier, Методы интерфейса EmailVerifier, Типичный код программы, Интерфейс IAmvConfigure, Примеры и исходные тексты, Распространение модулей AMV


Интерфейс IEmailVerifier
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

IEmailVerifier - это дуальный интерфейс (dual-interface). Так, вы можете использовать AMV через disp-интерфейс (Visual Basic, JavaScript, ASP) или через vtbl-интерфейс (Microsoft Visual C++, Borland Delphi). С программой поставляются исходный код примеров, использующих оба метода.

Вы можете создавать множество объектов и реализовывать многопоточную проверку в Вашем приложении. AMV не имеет встроенных ограничений на число созданных объектов. Все объекты будут проверять адреса в соответствии с текущими настройками AMV. Также Вы не можете настраивать AMV (например, адреса DNS и т.д.) через COM интерфейсы объекта.

Стандартный заголовок C++ для интерфейса Вы можете найти в файле: COM\AmvCpp1\AmvInterfaces.h в подкаталоге Advanced Maillist Verify.

См. также: Методы интерфейса IEmailVerifier, Информация для программистов


Методы интерфейса IEmailVerifier
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

virtual HRESULT __stdcall put_Email(/* [in] */ BSTR bstrEmail);

Задать адрес для проверки. Вы можете задавать адрес в любом известном формате, e.g.:

amv@elxcomsoft.com

Alex <amv@elxcomsoft.com>

Alex “amv@elxcomsoft.com”

“Alex Gorlach” <amv@elxcomsoft.com>

Проверка будет запущена автоматически после успешного вызова put_Email(). Обратите внимание, что вызов put_Email() будет успешен только если внутренний объект в состоянии CME_CLEAR или CME_COMPLETE (см. ниже описание get_Status()).

Возможные возвращаемые значения:

S_OK – адрес был задан успешно, проверка будет автоматически запущена;

S_FALSE – неверное состояние внутреннего объекта (например, проверка прошлого адреса еще не закончена).

virtual HRESULT __stdcall put_Sleep(/* [in] */ long lMilliseconds);

Некоторые языки программирования (например, JavaScript) встроенной операции задержки. lMilliseconds задает время, в миллисекундах (от 1 до 60000), на которое взывающий этот метод поток приостановит свое выполнение. Смотрите пример кода в описании get_Status().

virtual HRESULT __stdcall get_Status(/* [retval][out] */ long __RPC_FAR *status);

Возвращает состояние внутреннего объекта:

CME_CLEAR (0) – объект создан (и не было успешных вызовов put_Email());

CME_READY (1) - put_Email() была вызвана успешно, проверка будет сейчас запущена;

CME_CHECKING (2) – идет проверка адреса;

CME_COMPLETE (3) – проверка завершена.

Возможные коды возврата:

S_OK – состояние было возвращено.

Типичный код программы таков:

amv.Email = email;

if (amv.Status > 0)

{

do

{

amv.Sleep = 300;

status = amv.Status;

}

while (status != CME_COMPLETE);

}

virtual HRESULT __stdcall get_Result(/* [retval][out] */ long __RPC_FAR *result);

Возвращает числовой код результата проверки, одно из следующих значений:

VER_OK (0) - адрес существует;

VER_BAD_DNS (2) – домен адреса не был найден в DNS;

VER_BAD_SMTP (3) – почтовый ящик не существует;

VER_UNKNOWN (4) – программа не смогла проверить адрес.

Возможные коды возврата:

S_OK – результат был возвращен;

S_FALSE – результат еще недоступен (например, еще идет проверка).

virtual HRESULT __stdcall get_StatusString(/* [retval][out] */ BSTR __RPC_FAR *pbstrStatus);

Возвращает строковое описание состояния объекта (см. также описание get_Status()).

Возможные коды возврата:

S_OK – результат был возвращен.

virtual HRESULT __stdcall get_ResultString(/* [retval][out] */ BSTR __RPC_FAR *pbstrResult);

Возвращает строковое описание результата проверки (см. колонку “Результат” в интерфейсе программы). Врзможные коды возврата:

S_OK – строка была возвращена;

S_FALSE – результат еще не доступен (например, еще идет проверка).

virtual HRESULT __stdcall get_Log(/* [retval][out] */ BSTR __RPC_FAR *pbstrLog);

Вернуть многострочный журнал проверки адреса. Возможные коды возврата:

S_OK – журнал был возращен;

S_FALSE – журнал не доступен в данный момент (например, еще идет проверка).

virtual HRESULT __stdcall get_Comment(/* [retval][out] */ BSTR __RPC_FAR *pbstrComment);

Возвращает однострочный комментарий AMV к проверке этого адреса (см. колонку “Комментарий” в интерфейсе программы). Возможные коды возврата:

S_OK – комментарий был возвращен;

S_FALSE – комментарий не доступен на данный момент (например, проверка еще идет).

virtual HRESULT __stdcall get_DirtyEmail(/* [retval][out] */ BSTR __RPC_FAR *pbstrEmail);

Возвращает проверяемый адрес электронной почты (вида “Gorlach <alex@gorlach.koenig.su>») полученный put_Email(). Возможные коды возврата:

S_OK – адрес был возвращен;

S_FALSE – адрес не доступен (например, вызов put_Email() завершился неудачно).

virtual HRESULT __stdcall get_CleanEmail(/* [retval][out] */ BSTR __RPC_FAR *pbstrEmail);

Возвращает “очищенный” адрес (например “alex@gorlach.koenig.su” вместо “Gorlach <alex@gorlach.koenig.su>») полученный put_Email(). Возможные коды возврата:

S_OK – адрес был возвращен;

S_FALSE – адрес недоступен (например, вызов put_Email() завершился неудачно).

См. также: Типичный код программы, Информация для программистов


Типичный код программы
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

var amv, status, result;

amv = new ActiveXObject('AdvancedMaillistVerify.EmailVerifier');

amv.Email = email;

if (amv.Status > 0)

{

do

{

status = amv.Status;

amv.Sleep = 300;

}

while (status != CME_COMPLETE);

result = amv.ResultString;

}

else

{

result = “Invalid syntax”;

}

См. также: Примеры и исходные тексты, Информация для программистов


Интерфейс IAmvConfigure
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Интерфейс IAmvConfigure был добавлен в версии 4.1 Advanced Maillist Verify и предназначен для конфигурирования AMV из других приложений. IAmvConfigure это дуальный интерфейс (dual-interface). Так, Вы можете использовать AMV через disp-интерфейс (Visual Basic, JavaScript, ASP) или через vtbl-интерфейс (Microsoft Visual C++, Borland Delphi). Смотрите пример AmvCfg в качестве иллюстрации.

При помощи методов интерфейса IAmvConfigure Вы можете делать тоже, что и через диалог настроек AMV, за исключением некоторых настроек, незначимых при конфигурировании компонента Advanced Maillist Verify.

Методы интерфейса IAmvConfigure

virtual HRESULT __stdcall Load(void);

Заставляет компонент загрузить настройки из реестра Windows.

virtual HRESULT __stdcall Save(void);

Заставляет компонент сохранить настройки в реестр Windows.

virtual /* [propput] */ HRESULT __stdcall put_Timeout(/* [in] */ long lSeconds);

Устанавливает значение “Таймаут в минутах”.

virtual /* [propget] */ HRESULT __stdcall get_Timeout(/* [retval][out] */ long __RPC_FAR *lSeconds);

Получает значение “Таймаут в минутах”.

virtual /* [propput] */ HRESULT __stdcall put_LogsOff(/* [in] */ VARIANT_BOOL bLog);

Устанавливает значение “Отключить ведение журналов проверки”.

virtual /* [propget] */ HRESULT __stdcall get_LogsOff(/* [retval][out] */ VARIANT_BOOL __RPC_FAR *bLog);

Получает значение “Отключить ведение журналов проверки”.

virtual /* [propput] */ HRESULT __stdcall put_PrimaryDNS(/* [in] */ BSTR bstrDns);

Устанавливает значение “Первый DNS”.

virtual /* [propget] */ HRESULT __stdcall get_PrimaryDNS(/* [retval][out] */ BSTR __RPC_FAR *bstrDns);

Получает значение “Первый DNS”.

virtual /* [propput] */ HRESULT __stdcall put_SecondaryDNS(/* [in] */ BSTR bstrDns);

Устанавливает значение “Второй DNS”.

virtual /* [propget] */ HRESULT __stdcall get_SecondaryDNS(/* [retval][out] */ BSTR __RPC_FAR *bstrDns);

Получает значение “Второй DNS”.

virtual /* [propput] */ HRESULT __stdcall put_DirectDelivery(/* [in] */ VARIANT_BOOL bDirect);

Устанавливает значение “Прямая проверка”.

virtual /* [propget] */ HRESULT __stdcall get_DirectDelivery(/* [retval][out] */ VARIANT_BOOL __RPC_FAR *bDirect);

Получает значение “Прямая проверка”.

virtual /* [propput] */ HRESULT __stdcall put_UpdateDNS(/* [in] */ VARIANT_BOOL bUpdate);

Устанавливает значение “Автоматически обновлять настройки DNS”.

virtual /* [propget] */ HRESULT __stdcall get_UpdateDNS(/* [retval][out] */ VARIANT_BOOL __RPC_FAR *bUpdate);

Получает значение “Автоматически обновлять настройки DNS”.

virtual /* [propput] */ HRESULT __stdcall put_HeloDomain(/* [in] */ BSTR bstrDomain);

Устанавливает значение “Домен для HELO”.

virtual /* [propget] */ HRESULT __stdcall get_HeloDomain(/* [retval][out] */ BSTR __RPC_FAR *bstrDomain);

Получает значение “Домен для HELO”.

virtual /* [propput] */ HRESULT __stdcall put_MailFrom(/* [in] */ BSTR bstrEmail);

Устанавливает значение “Адрес в MAIL FROM”.

virtual /* [propget] */ HRESULT __stdcall get_MailFrom(/* [retval][out] */ BSTR __RPC_FAR *bstrEmail);

Получает значение “Адрес в MAIL FROM”.

virtual /* [propput] */ HRESULT __stdcall put_MostPriority(/* [in] */ VARIANT_BOOL bPriority);

Устанавливает значение “Проверять на приоритетнейшем SMTP-сервере”.

virtual /* [propget] */ HRESULT __stdcall get_MostPriority(/* [retval][out] */ VARIANT_BOOL __RPC_FAR *bPriority);

Получает значение “Проверять на приоритетнейшем SMTP-сервере”.

virtual /* [propput] */ HRESULT __stdcall put_UseVrfy(/* [in] */ VARIANT_BOOL bVrfy);

Устанавливает значение “Выполнять команду VRFY для существующих адресов”.

virtual /* [propget] */ HRESULT __stdcall get_UseVrfy(/* [retval][out] */ VARIANT_BOOL __RPC_FAR *bVrfy);

Получает значение “Выполнять команду VRFY для существующих адресов”.

virtual /* [propput] */ HRESULT __stdcall put_UseProxy(/* [in] */ VARIANT_BOOL bProxy);

Устанавливает значение “Подключаться через Socks5 прокси-сервер”.

virtual /* [propget] */ HRESULT __stdcall get_UseProxy(/* [retval][out] */ VARIANT_BOOL __RPC_FAR *bProxy);

Получает значение “Подключаться через Socks5 прокси-сервер”.

virtual /* [propput] */ HRESULT __stdcall put_SocksServer(/* [in] */ BSTR bstrServer);

Устанавливает значение “Адрес сервера Socks5”.

virtual /* [propget] */ HRESULT __stdcall get_SocksServer(/* [retval][out] */ BSTR __RPC_FAR *bstrServer);

Получает значение “Адрес сервера Socks5”.

virtual /* [propput] */ HRESULT __stdcall put_SocksPort(/* [in] */ long lPort);

Устанавливает значение “Порт сервера Socks5”.

virtual /* [propget] */ HRESULT __stdcall get_SocksPort(/* [retval][out] */ long __RPC_FAR *lPort);

Получает значение “Порт сервера Socks5”.

virtual /* [propput] */ HRESULT __stdcall put_ProxyAuth(/* [in] */ VARIANT_BOOL bAuth);

Устанавливает значение “Использовать аутентификацию RFC 1929”.

virtual /* [propget] */ HRESULT __stdcall get_ProxyAuth(/* [retval][out] */ VARIANT_BOOL __RPC_FAR *bAuth);

Получает значение “Использовать аутентификацию RFC 1929”.

virtual /* [propput] */ HRESULT __stdcall put_SocksLogin(/* [in] */ BSTR bstrLogin);

Устанавливает значение “Логин к серверу Socks5”.

virtual /* [propget] */ HRESULT __stdcall get_SocksLogin(/* [retval][out] */ BSTR __RPC_FAR *bstrLogin);

Получает значение “Логин к серверу Socks5”.

virtual /* [propput] */ HRESULT __stdcall put_SocksPassword(/* [in] */ BSTR bstrPassword);

Устанавливает значение “Пароль к серверу Socks5”.

virtual /* [propget] */ HRESULT __stdcall get_SocksPassword(/* [retval][out] */ BSTR __RPC_FAR *bstrPassword);

Получает значение “Пароль к серверу Socks5”.

virtual /* [propput] */ HRESULT __stdcall put_UseMapping(/* [in] */ VARIANT_BOOL bMapping);

Устанавливает значение “Маппинг для DNS”.

virtual /* [propget] */ HRESULT __stdcall get_UseMapping(/* [retval][out] */ VARIANT_BOOL __RPC_FAR *bMapping);

Получает значение “Маппинг для DNS”.

См. также: Методы интерфейса IEmailVerifier, Информация для программистов


Примеры и исходные тексты
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

В подкаталоге COM каталога с AMV Вы можете найти следующие примеры с полным исходным текстом:

AmvCpp1 - C++ консольный пример (через vtbl), компилировалось Microsoft Visual C++ 6.0

AmvCpp2 - C++ консольный пример (через disp), компилировалось Microsoft Visual C++ 6.0

AmvDelphi3 – пример для Borland Delphi v3, GUI

AmvVB6 - пример для Microsoft Visual Basic

AmvCfg - пример конфигурирования AMV для Visual Basic

AmvHtml - пример скрипта JavaScript на стороне клиента (HTML)

AmvIIS - пример серверного скрипта JavaScript для MS IIS (ASP)

AmvCF - пример серверного скрипта для веб-сервера с ColdFusion

См. также: Распространение модулей AMV, Информация для программистов


Распространение модулей AMV
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Вы можете распространять файл AMV.EXE (компонент) со своей программой. Ваша программа установки должна записать этот файл в любой каталог. Чтобы зарегистрировать интерфейс COM, Вы должны запустить следующую команду:

AMV.EXE –RegServer –Registration YOUR-LICENSE-NUMBER

AMV запустится в "скрытом" режиме (т.е. без создания окна), зарегистрирует сервер COM и библиотеку типа (ключ -RegServer), сохранит номер Вашей лицензии в реестре (ключ -Registration) и завершится. Обратите внимание, что номер лицензии – это не серийный номер к AMV и приобретается отдельно (см. ниже). Если номер лицензии верный, то код возврата (errorlevel) будет 1, в противном случае 2. Код 0 означает, что ключ –Registration не был найден в командной строке. Если Вы хотите, чтобы программа выдала окно с сообщением, что регистрация прошла успешно или неуспешно, то добавьте ключ –MSG к командной строке:

AMV.EXE –RegServer –Msg –Registration YOUR-LICENSE-NUMBER

Когда Вы удаляете свое приложение, Вы должны сделать следующий вызов:

AMV.EXE –ClearRegistry

и AMV разрегистрирует сервер COM и удалит все свои записи из реестра. После чего Вы можете удалить AMV.EXE.

Настройки AMV хранятся в следующем разделе реестра:

HKLM\Software\Elcom\Advanced Maillist Verify

К сожалению, Вы не можете конфигурировать текущую версию AMV через интерфейс COM. Ваше приложение должно записывать настройки AMV непосредственно в реестр.

Обратите внимание, что лицензия (позволяющая создавать собственные приложения используя COM-интерфейс AMV и, при определенных типах лицензии, распространять их) должна быть приобретена отдельно. Пожалуйста, посетите наш сайт чтобы ознакомиться с лицензией и ценами.

См. также: Информация для программистов


Модули CGI/ISAPI
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Advanced Maillist Verify может быть легко интегрирована в практически любой веб-сервер работающий под ОС Windows. Это может быть сделано двумя способами:

- Через COM/ActiveX интерфейс AMV. Смотрите статью "Примеры и исходные тексты" в разделе "Информация для программистов", в ней содержатся ссылки на поставляемые с программой примеры интеграции в сервера Microsoft IIS и ColdFusion от Allaire Corporation. К сожалению, далеко не все вебсервера и их расширения позволяют создавать скрипты выполняющиеся на сервере и поддерживающие COM/ActiveX объекты.

- Через модули CGI/ISAPI. CGI (Common Gateway Interface) является платформонезависимым интерфейсом выполнения программ совместно с вебсервером. В силу своей исключительной простоты и исторических причин, интерфейс CGI поддерживается всеми вебсерверами, за исключением немногих специализированных вебсерверов, которые вообще не поддерживают выполнение на стороне сервера скриптов и программ. ISAPI является альтернативой CGI в вебсервере Microsoft IIS. Интерфейс во многом повторяет интерфейс CGI, но обладает большей производительностью и несколько большими возможности.

Модули CGI (AmvCgi.exe) и ISAPI (AmvIsapi.dll) не отличаются друг от друга в плане установки и настройки, поэтому в дальнейшем мы будем называть их просто модули. Модули находятся в подкаталогах COM\AmvCGI\ и COM\AmvISAPI\ каталога с AMV.

Модули не являются самостоятельными программами и используют COM-объект "Advanced Maillist Verify Component - Email Verifier" для выполнения проверки адреса. Поэтому для их функционирования должен быть установлен Advanced Maillist Verify и для компонента должны быть установлены соответствующие права доступа при помощи утилиты DCOMCNFG.EXE, если вебсервер работает не с правами обычного пользователя. При помощи DCOM (Distributed COM), компонент может выполняться на любом компьютере в сети, это также настраивается при помощи утилиты DCOMCNFG.EXE.

Для использования COM-компонента (и, соответственно, модулей COM/ISAPI) недостаточно обычной пользовательской лицензии на Advanced Maillist Verify. Вы должны приобрести лицензию разработчика.

Настройка работы модулей осуществляется через конфигурационные файлы с расширением .INI, которые должны иметь то же имя, что и файл скрипта и находится с ним в одном каталоге (например, AmvCgi.EXE и AmvCgi.INI, AmvCgi1.EXE и AmvCgi1.INI). Вы можете создать несколько копий модулей с разными именами в одном каталоге с, соответственно, разными файлами настроек. В настройках вебсервера каталог со скриптами должен быть доступен для выполнения и недоступен для чтения.

Вызовы модулей осуществляются с передачей им адреса электронной почты методом POST или GET. Модули не имеют строго заданного аргумента для передачи адреса и определяют адрес по знаку '@' в теле аргумента. Например, правильно будут обработаны следующие вызовы GET:

/AmvCgi.exe?my@email.com

/AmvCgi.exe?email=my@email.com

/AmvCgi.exe?test=off&my@email.com

/AmvCgi.exe?test=off&eml=my@email.com

В следующих случаях будет проверен первый аргумент, где встречается символ '@':

/AmvCgi.exe?my@email.com&my2@email.com

/AmvCgi.exe?test=@&email=my@email.com

Если ни один из аргументов не содержит символа '@', то, в зависимости от настроек скрипта, будет либо выдано сообщение об ошибке, либо для проверки будет взят первый аргумент первого параметра. Обратите внимание, что модуль обрабатывает только один параметр (адрес электронной почты) и обработка ситуаций, когда модулю передано несколько параметров добавлена исключительно для большей совместимости.

Модуль выполняет проверку адреса электронной почты используя настройки Advanced Maillist Verify (адреса серверов DNS, таймауты, специфичные настройки протокола SMTP и т.д.). После окончания проверки, модуль выполняет одно из действий (перенаправление браузера или выдача HTML-страницы) согласно настройкам в файле конфигурации. Принципиальная разница между этими действиями заключается способе передачи результата.

В первом случае (перенаправление, redirect) скрипт может кодировать результаты проверки в URL, на который осуществляется перенаправление. При задании URL можно использовать макросы %EMAIL%, %RESULT%, %COMMENT%, которые будут расширены скриптом соответствующими значениями. Например:

http://www.mycompany.com/goodemail?email=%EMAIL%

Во втором случае (выдача HTML-страницы), Вы можете использовать макросы %EMAIL%, %COMMENT%, %RESULT%, %LOG% в теле шаблона страницы, и которые будут заменены на реальные значения при ее выводе.

Пожалуйста, посмотрите конфигурационные файлы скриптов и шаблоны страниц в подкаталоге COM программы для более подробной информации.

См. также: Информация для программистов


Утилита AmvSplit
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Максимальное число адресов в проверяемом списке - 1000000. Если Ваши списки больше, поделите их на части при помощи этой утилиты. Она находится в каталоге, в который Вы установили Advanced Maillist Verify.

Синтаксис:

AMVSPLIT.EXE число_строк входной_файл

Где число_строк - максимальное число строк в выходных файлах, входной_файл - разделяемый список рассылки. Выходные файлы записываются в каталог входного файла и имеют имена вида входной_файл.NNN, где NNN - номер части.

Примеры:

AMVSPLIT.EXE 1000 my.lst

AMVSPLIT.EXE 10000 “C:\Program Files\Eserv\forward.lst”

Объединить части в один файл после проверки можно при помощи команды COPY в командной строке. Например:

COPY my.lst.001+my.lst.002+my.lst.003 my_checked.lst

COPY my.lst.0?? my_checked.lst

См. также: Утилита NextStr, Утилита DomainSo


Утилита NextStr
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Утилита находится в каталоге, в который Вы установили Advanced Maillist Verify. Утилита предназначена для анализа журналов работы программы. Программа печатает все строки, начинающиеся с указанной подстроки и следующую за ней строку. Для получения справки по ключам запуска программы запустите ее без ключей.

Синтаксис:

NEXTSTR.EXE “начало строки” входной файл

Пример:

NEXTSTR.EXE “RCPT TO” my.log

Распечатка на экране:

Line Text (first 70 characters)

------ ----------------------------------------------------------------------

64 RCPT TO: <check_email@gorlach.koenig.su>

65 250 <check_email@gorlach.koenig.su>... Recipient ok

132 RCPT TO: <nobox_8172@hotmail.com>

133 550 Requested action not taken: mailbox unavailable

200 RCPT TO: <nobox_0173@aha.ru>

201 553 <nobox_0173@aha.ru>... User unknown (remote check)

262 RCPT TO: <nobox_0173@chat.ru>

263 550 Unknown local part nobox_0173 in <nobox_0173@chat.ru>

375 RCPT TO: <aleshenka@postman.ru>

376 250 <aleshenka@postman.ru>... Recipient ok

502 RCPT TO: <zaraza@download.com>

503 550 <zaraza@download.com>... User unknown

567 RCPT TO: <dibibi@pop.convey.ru>

568 550 <dibibi@pop.convey.ru>... User unknown

629 RCPT TO: <zizitop@winfiles.com>

630 550 <zizitop@winfiles.com>... User unknown

691 RCPT TO: <uzzzi@chat.ru>

692 550 Unknown local part uzzzi in <uzzzi@chat.ru>

756 RCPT TO: <postmaster@nefto.khv.ru>

757 250 <postmaster@nefto.khv.ru>... Recipient ok

880 RCPT TO: <sisimi@real.astrakhan.su>

881 550 <sisimi@real.astrakhan.su>... User unknown

-----------------------------------------------------------------------------

Done.

См. также: Утилита AmvSplit, Утилита DomainSo


Утилита DomainSo
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Утилита находится в каталоге, в который Вы установили Advanced Maillist Verify. Утилита предназначена для сортировки списков рассылки по домену в алфавитном порядке. Для сортировки в алфавитном порядке по всему адресу Вы можете воспользоваться утилитой SORT из операционной системы.

Синтаксис:

DOMAINSO [-r] входной_файл выходной_файл

Где “-r” – необязательный параметр, включающий сортировку в обратном направлении.

Примеры:

DOMAINSO.EXE customers.lst cust_sorted.lst

DOMAINSO.EXE -r "C:\Program Files\My List.txt" mylst.txt

См. также: Утилита AmvSplit, Утилита AmvNoDup


Утилита AmvNoDup
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Эта программа предназначена для удаления дублирующихся адресов из списков рассылки. AmvNoDup находится в каталоге с Advanced Maillist Verify. Вы также можете удалять дублирующиеся адреса установив соответствующие настройки в диалоге AMV “Открыть файл…”.

Синтаксис:

AMVNODUP.EXE infile outfile

Где infile это исходный список рассылки, outfile это имя выходного файла.

Примеры:

AMVNODUP.EXE customers.lst cust_clean.lst

AMVNODUP.EXE "C:\Program Files\My List.txt" mylst.txt

См. также: Утилита AmvSplit, Утилита NextStr


Настройка программы
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Настройка программы вызывается в меню “Check” выбором пункта “Settings...”. В появившемся окне Вы увидите пять закладок с настройками:

Общие настройки, DNS - Настройка DNS, SMTP - Настройка SMTP, Фильтр содержимого выходного файла, Прокси - Настройка подключения через прокси-сервер, Цвета - Настройка раскраски списка адресов


Общие настройки
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Число потоков проверки

Число проверяющих потоков - сколько адресов будет проверятся одновременно. Увеличивая число потоков, Вы увеличиваете сетевой трафик и нагрузку на машину. Рекомендуется 20..30 потоков для подключения к Интернет со скоростью 33.6k.

Таймаут в минутах

Максимальное время проверки адреса в минутах, после истечения которого проверка адреса прекращается с комментарием “Timeout”. Значение 0 отключает проверку таймаута.

Проверять несколько адресов из одного домена в одном соединении

Включает проверку нескольких адресов (от 2 до 99) из одного домена в течении одного подключения к SMTP серверу. При соединении выдается несколько команд RCPT TO, но журнал проверки адреса компонуется так, будто он единственный проверялся при соединении. Эта опция позволяет в несколько десятков раз повысить скорость проверки. Рекомендуется проверять 10..20 адресов в одном соединении, так как некоторые почтовые сервера имеют строгие ограничения на число получателей одного письма. Не забудьте увеличить значение таймаута, если будете использовать эту настройку. Число в поле “Пров” статусной строки теперь будет выше, чем число установленных потоков проверки, так как теперь несколько адресов проверяется в одном потоке.

Создавать BAK файлы при перезаписи

Сохранять копии файлов списков рассылки при перезаписи.

Гудок при окончании проверки

Издать на спикер короткий звуковой сигнал при завершении проверки списка.

Только CR для разделения при сохранении

При сохранении списка рассылки использовать только CR (0x0A) для разделения адресов-строк. По умолчанию - CRLF (0x0D,0x0A).

Только две колонки в коротком журнале

При сохранении короткого журнала работы (“Файл” -> “Сохранить журнал” -> “Сохранить короткий лог») по умолчанию в файл записываются все три столбца окна результатов. Эта опция позволяет исключить третий столбец “Комментарий”.

Отключить ведение журналов проверки

Журнал проверки адреса занимает около килобайта памяти. Журналы могут потребовать 100 мегабайт, если Вы проверяете список из 100000 адресов. В этом случае Вы можете отключить ведение журналов для экономии памяти.

Включать паузу если нет dial-up соединений

При разрыве связи AMV остановит проверку и запустит ее когда связь будет восстановлена.

См. также: Настройка программы


Настройка DNS
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Первый DNS

Основной DNS-сервер. Может быть задан как доменом, так и IP-адресом. Advanced Maillist Verify работает с DNS-серверами только по протоколу UDP. У некоторых пользователей время доступа к DNS-серверам, которые по умолчанию используются программой, составляет 2-3 секунды. Вы можете сократить это время до половины секунды, обратившись к своему провайдеру услуг Интернет за адресом его DNS сервера, если он не предоставил вам эту информацию при заключении договора. Windows при определенных условиях может получать адрес DNS-сервера автоматически, и многие провайдеры используют это, чтобы не заставлять пользователя делать лишние настройки. AMV пытается определить настройки DNS и показывает их в окне “Системные настройки DNS”. Вы также можете самостоятельно определить адреса DNS-серверов, запустив утилиту IPCONFIG с ключом /ALL, если Вы работаете под Windows XP и старше. Эти утилиты входят в состав операционной системы.

Второй DNS

Дополнительный DNS-сервер, может быть не указан. Может быть задан как доменом, так и IP-адресом. Используется, только если основной DNS-сервер не ответил положительно на запрос.

Прямая проверка

Прямая проверка или доставка. Например, для адреса alex@gorlach.koenig.su на сервер gorlach.koenig.su . Если даже прямая доставка включена, то она используется только в том случае, если DNS-серверы не вернули адресов почтовых серверов. Использование прямой доставки НЕ РЕКОМЕНДУЕТСЯ. Ее использование приведет к некорректным результатам - пользоваться ей можно только в исследовательских целях.

Не использовать внутренний кэш DNS

Если в списке есть два адреса с одного домена (например, a@hotmail.com и b@hotmail.com), то второй раз программа не станет обращаться к DNS - адреса почтовых серверов будет выбраны из внутреннего кэша программы. Отметкой этой опции Вы можете отключить кэш.

Системные настройки DNS

Информация в этом окне обновляется каждую секунду. Программа пытается определить настройки DNS Windows самостоятельно и отобразить их в этом окне. Если Вы подключаетесь к Интернет через диал-ап соединение, то Вы должны подключиться к Интернет, чтобы программа смогла определить настройки. Вы также можете самостоятельно определить адреса DNS-серверов, запустив утилиту IPCONFIG с ключом /ALL, если Вы работаете под Windows NT, или утилиту WINIPCFG, если вы работаете под Windows 95 или Windows 98. Эти утилиты входят в состав операционной системы.

Автоматически обновлять настройки DNS

Автоматически заменять первичный и вторичный сервера системными DNS, если они обнаружены. Проверка и обновление настроек происходит примерно раз в секунду. При открытом окне настройки программы автоматического обновления не происходит.

См. также: Настройка программы


Настройка SMTP
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Домен для “HELO”

Ваш домен, используемый для представления SMTP-серверам. Рекомендуется использовать свой настоящий домен. Если домен не указан, программа постарается сама определить Ваш домен, если определить домен не удастся, будет использован домен localhost. Использование чужого домена или псевдонима localhost возможно, но не рекомендуется - серверы с высоким уровнем безопасности могут отказаться с Вами работать.

Если Вы настроили программу для работы через прокси-сервер Socks5, то здесь следует указать домен прокси-сервера – программа не сможет сама его определить.

Адрес в “MAIL FROM”

Адрес электронной почты, используемый в запросе “MAIL FROM” к почтовому серверу. Рекомендуется использовать настоящий адрес. В противном случае, серверы с высоким уровнем безопасности могут отказаться с Вами работать.

Проверять на приоритетнейшем SMTP-сервере

По умолчанию, если недоступен сервер с наивысшем приоритетом, то программа пытается проверить адрес на остальных серверах, найденных в DNS для этого адреса. Эта настройка заставляет программу проверять адрес только на сервере с наивысшим приоритетом и не пробовать другие сервера, если он недоступен.

Выполнять команду VRFY для существующих адресов

Команда VRFY протокола SMTP [RFC 821] применяется для получения реальных имен или названия организации, владеющей адресом электронной почты. К сожалению, только около 10% почтовых серверов поддерживают эту команду. Включите выполнение VRFY, проверьте список и сохраните журнал проверки (не “короткий” журнал, а полный). Вы можете проанализировать ответы серверов утилитой NextStr. Эта опция является экспериментальной.

Выполнять команду RSET в конце сессии

Без этой команды некоторые сервера SMTP могут отправлять пустое письмо на проверяемый адрес. Отключать выполнение этой команды не рекомендуется.

См. также: Настройка программы


Фильтр
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Управление содержимым выходного файла. Например, Вы можете настроить, чтобы программа сохраняла только плохие адреса в список. Вы можете сохранить файл, изменить эти настройки и сохранить файл под другим именем - чтобы получить в результате два списка, один с “хорошими”, а второй - с “плохими” адресами. Фильтрацией можно управлять как из настроек программы, так и из диалога “Сохранить как…” программы.

Сохранять существующие адреса

Сохранять в выходной файл адреса прошедшие проверку и определенные как существующие.

Сохранять несуществующие адреса

Сохранять в выходной файл адреса прошедшие проверку и определенные как несуществующие.

Адреса с неизвестным результатом

Сохранять в выходной файл адреса, чью проверку не удалось завершить.

Сохранять непроверенные адреса

Сохранять адреса, которые еще не были проверены. Это полезно, когда Вы останавливаете или приостанавливаете проверку.

См. также: Настройка программы


Настройка прокси
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Подключаться через Socks5 прокси-сервер

Прокси сервер - это специальная программа, позволяющая пользователям локальной сети работать с Интернет. Обратитесь, пожалуйста, к администратору Вашей локальной сети, если у Вас возникают проблемы с настройкой программы. По протоколу Socks5 работает в локальной сети такая популярная программа, как ICQ. Если Вы используете прокси-сервер, то строго рекомендуется указать домен прокси сервера в настройках SMTP.

Адрес

Адрес прокси сервера. Может быть как доменом, так и IP-адресом. Примеры: proxy.isp.com, 10.1.1.1.

Порт

Порт сервера. Обычно, это порт 1080. Очень многие путают Socks5-proxy с http-proxy и ftp-proxy и указывают, соответственно, номер порта 3128 или 3121. Через http-proxy или ftp-proxy программа работать не будет.

Использовать аутентификацию RFC 1929

Сервер требует авторизацию – предъявить имя и пароль пользователя. Большинство реализаций прокси-серверов Socks5 поддерживают простейшую реализацию, в которой имя и пароль передаются открытым текстом, как описано в документе RFC 1929.

Логин

Имя или логин пользователя прокси-сервера Socks5.

Пароль

Пароль пользователя прокси-сервера Socks5.

Маппинг для DNS

Использовать маппинг (отображение) портов для работы с DNS по протоколу UDP. Некоторые реализации прокси-серверов, например, WinGate 3.0 некорректно работают по протоколу UDP, и использовать маппинг в таком случае необходимо. Если Ваш прокси сервер имеет адрес 10.1.1.1, то отобразите UDP-порт 53 первого DNS, например ns.ml.org, на локальный порт 53, а порт второго DNS – на локальный порт 54. И в настройках DNS укажите эти адреса – 10.1.1.1 и 10.1.1.1:54 (порт 53 используется по умолчанию).

См. также: Настройка программы


Цвета
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Настройки данной группы позволяют отображать разными цветами адреса электронной почты с разным результатом проверки.

См. также: Настройка программы


Регистрация
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Регистрация программы платная После регистрации программы Вам будет выслан ключ, который снимет с программы все ограничения. Ключ будет работать и со всеми будущими минорными версиями Advanced Maillist Verify.

Наша компания принимает все виды оплаты от физических и юридических лиц, предоставляя покупателям необходимые для отчетности финансовые документы. Перейти на страницу регистрации программы можно по прямой ссылке http://www.massmail.ru/purchase/

Преобретая программу легально, Вы стимулируете автора развивать и совершенствовать программу, которая нужна Вам, помогаете создавать в России цивилизованный рынок программного обеспечения.


Ограничения незарегистрированной копии
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Незарегистрированная русская версия AMV полностью функциональна, за исключением следующего:

·Вы не можете экспортировать результаты работы

·Вы не можете сохранить более 100 проверенных адресов

Также мы обеспечиваем ограниченную поддержку незарегистрированных пользователей, и с более низким приоритетом, чем зарегистрированных.

После регистрации программы Вы получите регистрационный код, который уберет ограничения. Регистрационный код будет работать со всеми будущими версиями AMV (если система регистрации по каким-либо причинам поменяется, Вам будет выслан новый код).

Если Вы используете COM-интерфейс AMV, но не приобрели лицензию разработчика, то AMV будет время от времени при вызове методов COM-объекта просить Вас ее приобрести.

См. также: Регистрация программы, Техническая поддержка


Сайт в Интернет
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

На веб-сайте вы можете узнать последние новости, подписаться на список рассылки о программе и скачать последнюю версию программы. Помимо Advanced Maillist Verify, на нашем сайте Вы найдете еще несколько полезных программ:

Advanced Email Extractor

Advanced Direct Remailer

High Speed Verify

Mailing List Wizard

и другие.

Не забывайте заходить на наш сайт, мы всегда рады видеть вас! Пожалуйста, обращайтесь в службу технической поддержки, если у вас возникли вопросы, предложения или пожелания.


Техническая поддержка
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Мы обещаем ответить на ваше письмо, если Вы будете придерживаться следующих правил, когда обращетесь в службу технической поддержки:

·Если Ваш вопрос касается некорректной работы программного обеспечения, то не забудьте сообщить версию операционной системы, пакета обновления и установленного Microsoft Internet Explorer.

·Пожалуйста, сообщите все дополнительные детали, какие сочтете нужными, чтобы разработчики могли в точности воспроизвести вашу ситуацию.

·Ознакомьтесь со списком в Интернет, возможно, что необходимое уже добавлено или исправлено в более новой версии.

·Уважайте чужое время. Мы знаем, где скачать самый лучший мейлер и знаем, почему ваша звонилка не ловит сигнал "занято". Но мы Вам этого не скажем.

·Если Вы зарегистрированный пользователь, то сообщите в письме Вашу регистрационную информацию. Это позволит нам обработать Ваш запрос быстрее.

Связаться со службой технической поддержки можно через web сайт. Также рекомендуем посетить наш сайт в Интернет, на котором можно найти дополнительную информацию о программе.


Advanced Email Extractor
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

EmEx 3 предназначен для сбора информации (e-mail адресов, номеров телефонов, номеров ICQ/MSN/Skype и многого другого) из публичных источников, размещенных в сети Интернет.

При создании EmEx были решены наиболее частые задачи, с которыми сталкивались пользователи нашего популярного продукта Advanced Email Extractor (AEE), а так же учтены новейшие технологии защиты e-mail адресов от подобного сбора.

Интерфейс пользователя стал проще и удобнее, а возможности программы - практически неограниченны.

Более 300 поисковых машин по всему миру могут обрабатывать ваши запросы. Мы постоянно отслеживаем актуальность баз данных скриптов для обработки результатов ответов от поисковых машин, поэтому вам не придется обновлять программу если поисковая машина изменила формат возвращаемых данных. При каждом запуске EmEx 3 вы получите обновленные настройки для поиска.

Посмотрите на краткий перечень возможностей EmEx 3 и убедитесь сами:

·Поиск как с заданного источника, так и по поисковым машинам

·Одновременный поиск по более чем 300 поисковым машинам мира

·Поддержка авторизации по HTTP или через веб форму

·Ограничение поиска по стране, доменной зоне или кодовой странице документа

·Гибко настраиваемый фильтр исключений

·"Черный" и "Белый" списки

·Список игнорируемых доменов

·Фильтр ключевых слов, поддерживающий логические выражения

·Фильтр ограничения активности запросов к сканируемым сайтам (анти-хаммер)

·Работа по расписанию

·Динамическая замена содержимого документа

·Маскировка по User-Agent

·Фильтрация по MIME типам

·Многопоточное сканирование, позволяющее обрабатывать до 50 ссылок одновременно

·Ограничение скорости загрузки

·Постоянно обновляемые скрипты для распознавания собираемой информации

·Использование прокси серверов

·Обновляемые списки прокси серверов1

·Возможность создания собственных схем для сбора информации2

·И многое другое!.

Вы можете загрузить пробную версию EmEx 3 с нашего веб-севера и попробовать ее в работе.


Advanced Direct Remailer
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Advanced Direct Remailer (ADR) - это недорогое и универсальное решение для среднего и малого бизнеса, легко интегрирующееся в имеющиеся системы и позволющее строить на своей базе системы обработки и доставки исходящей почты.

Встроенный почтовый сервер SMTP обеспечивает широкую совместимость с офисным ПО и позволяет использовать программу всем сотрудникам организации независимо от платформы рабочих станций. Возможность прямой доставки исходящей почты на сервера получателей позволяет обойтись без сервера SMTP провайдера, удобно контролировать ее доставку, доставлять почту более оперативно, и экономить траффик, определяя большинство несуществующих почтовых адресов электронной почты уже на начальной стадии отправки письма. Возможность гибкой настройки зачастую позволяет доставить почту даже тогда, когда ее невозможно отправить через сервер провайдера. Поддержка протокола Socks5 позволяет использовать программу в сетях самых сложнейших конфигураций.

Развитая и открытая система пользовательских программ обработки сообщений позволит Вам создавать решения любой сложности - от простых систем сбора статистики до сложных контент-фильтров. Программа поддерживает списки рассылки всех популярных форматов, а возможность использования ODBC SQL позволяет выполнять рассылку по адресам из любой популярной базы данных (MS SQL, Oracle, MySQL, MS Access и даже MS Excel и другие) и рассылать персонифицированную информацию их базы данных по письму-шаблону. Программа может работать как сервис Mirosoft Windows NT/2000, и настроив ее один раз Вы можете забыть о ней.

Вы можете загрузить пробную версию ADR с нашего веб-севера и попробовать ее в работе.


High Speed Verifier
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

High Speed Verifier (HSV) это высокоскоростная программа для проверки адресов электронной почты на существование, HSV может проверять до нескольких тысяч адресов в секунду. Программа прекрасно справляется со списками рассылки из нескольких десятков миллионов адресов; и более того - именно на списках такого объема достигается пиковая производительность программы.

HSV определяет около 20-30% несуществующих адресов в списке рассылки, при теоретически возможном определении программными методами до 60-70% несуществующих адресов. Эта цифра кажется относительно небольшой, но на практике она может составить около 10% от объема проверяемого списка. При этом HSV обеспечивает оптимальный по времени и сетевому трафику режим проверки. Более качественная проверка (позволяющая выявить остальные 40% несуществующих адресов) требует в десять раз больше времени и в пять раз больше сетевого трафика на каждый адрес, что делает качественную проверку не вполне целесообразной для списков большого объема.

Наша компания предлагает два программных продукта для проверки адресов электронной почты на существование — Advanced Maillist Verify (AMV), которая выполняет проверку в два этапа (DNS и SMTP), и High Speed Verifier (HSV), которая выполняет только первый этап проверки (DNS).

AMV предлагается как средство качественной проверки небольших (не более 50..100 тысяч адресов) списков рассылки. Advanced Maillist Verify также умеет проверять адреса в базах данных, адресных книгах популярных программ, имеет интерфейсы COM/ActiveX для интеграции в различное программное обеспечение и модули CGI/ISAPI для упрощенной интеграции в веб-сервера. Но технические принципы и заложенные в AMV интерфейсные решения не позволяют использовать программу для проверки списков большей длинны.

High Speed Verifier предлагается как решение для быстрого удаления мусора из многомиллионных списков. Ее производительность в силу число технических причин в 10..15 раз превосходит производительность AMV на небольших списках, а на списках с миллионами адресов производительность программ может уже отличаться в сотни раз. Рост производительности HSV при увеличении длинны проверяемого списка объясняется тем, что HSV кэширует в оперативной памяти результаты всех запросов к серверам DNS, и чем длиннее проверяемый список, тем выше процент попаданий в кэш.

High Speed Verifier — это первая профессиональная программа проверки больших списков адресов, созданная профессионалами для профессионалов. Мы надеемся, что использование HSV сделает Ваш бизнес более эффективным и успешным, а работа с программой окажется легкой и приятной.

Вы можете загрузить пробную версию HSV с нашего веб-севера и попробовать ее в работе.


Mailing List Wizard
No contents entries on this page
Menu
Go to previous topic
Go to home topic
This is the last topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Mailing List Wizard (MLW) поможет Вам выполнить обработку и преобразование списков рассылки. Программа умеет исключать из списков дублирующиеся адреса, исправлять неправильно написанные адреса по уникальным алгоритмам, фильтровать списки по разным критериям, объединять списки, делать исключение из списка адресов по дополнительному списку. MLW умеет обогащать список рассылки именами владельцев адресов по информации из других списков, удалять имена владельцев адресов из списков рассылки, сортировать адреса в списках рассылки и многое другое. MLW это одна программа, которая включила в себя функции сразу несколько программ по обработке списков рассылки.

Описание операций Mailing List Wizard:

·Удаление дублирующихся адресов

·Объединение двух списков

·Исключение адресов из списка

·Обогащение списка (добавление имен пользователей)

·Обеднение списка (удаление имен пользователей)

·Исправление неправильных адресов

·Фильтрация адресов по маскам, регулярным выражениям и подстрокам

·Сортировка адресов в списке рассылки

Вы можете загрузить пробную версию MLW с нашего веб-севера и попробовать ее в работе.


Расположение адресной книги Windows

EMMA Labs web site

Navigation: »No topics above this level«

Расположение адресной книги Windows
No contents entries on this page
Contents
Topic functions menu
Menu
This is the first topic
Go to home topic
This is the last topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Адресная книга Windows хранится в файле с расширением .WAB. В зависимости от версии операционной системы и почтовой программы, этот файл может находится в разных каталогах.

Internet Mail and News

Адресная книга используемая Internet Mail and News находится в каталоге Windows. Файл адресной книги имеет имя <имя пользователя>.wab, где <имя пользователя> это имя под которым Вы вошли в Windows 95. Если Вы не вводите имя пользователя при входе в Windows, то файл имеет имя UserMPS.wab.

В системах с установленным Internet Explorer 3.02, имя адресной книги может быть <имя пользователя>.wab.ie3 вместо <имя пользователя>.wab.

Outlook Express

Адресная книга используемая Outlook Express находится в каталоге <Windows>\Application Data\Microsoft\Address Book, где <Windows> это каталог установки Windows 95/98.

В Windows NT и Windows 95/98 с включенными профилями пользователей, адресная книга находится в каталоге <Windows>\Profiles\<Username>\Application Data\Microsoft\Address Book, где <Windows> это каталог установки Windows, и <Username> это имя для входа в Windows.

Other configurations

Вы можете найти файл с адресной книгой самостоятельно. Для этого окно поиска файлов (”Пуск” / “Поиск” / “Файлы и папки …») и задайте для поиска маску:

*.WAB

Файл с адресной книгой предположительно будет иметь имя, совпадающее с именем пользователя и находится в одном из подкаталогов Windows.

См. также: Мастер адресных книг Windows