Introduction
No contents entries on this page
Contents
Topic functions menu
Menu
This is the first topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

High Speed Verifier (HSV) is a high-speed software designed to check e-mail address for existence. HSV is capable of checking thousands of addresses per second. It can easily deal with mailing lists containing tens millions of addresses; moreover, it is with this list size that the program's highest performance can be achieved.

HSV detects about 20-30% of invalid addresses in a mailing list, though theoretically it is possible to detect up to 60-70% using a software product. This figure seems relatively small, but actually it might make 10% of a list. Besides, HSV provides for optimal checking mode in terms of time and data traffic. More thorough checking (with which the rest 40% of invalid addresses could be detected) takes 10 times longer and requires 5 times greater traffic for each address, hence it's not that advisable with big-size lists.

HSV is the first professional software designed to check big-size mailing lists, it is created by professionals for professionals. We hope with High Speed Verifier your business will be more effective and successful, and you will enjoy using our product.

© 2016 EMMA Labs All rights reserved.


Introduction to E-mail Technologies
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

The process of message delivery by a mail server consists of the two phases. First, it detects address of the mail server that receives messages for the recipient (further on referred to as Recipient's Server, RS). Then, it connects to that server using the SMTP protocol and transmits the message to it.

Mail domain (mail.com for the address alex@mail.com; "alex" here is a mailbox in the mail.com domain) name normally is different from name of the mail server that receives messages for that address. At the moment when this text was being written, messages for alex@mail.com were received by the servers mail-com.mr.outblaze.com and mail-com-bk.mr.outblaze.com. While computers with addresses mail.com and www.mail.com received no messages for no addresses. So, mail domain cannot be directly related to the mail server address, rather often messages are received by a computer with absolutely different name.

To find out RS address, a query is sent to the DNS service, which stores (besides other things) information about mail server that receives messages for each domain.

DNS is a distributed database. For example, DNS server ns1.outblaze.com stores all the information about mail.com, but it knows nothing about other domains, e.g. about hotmail.com. The server ns1.hotmal.com stores information about domain hotmail.com, but it knows nothing about other domains. There is a server responsible for all .com domains, it keeps information about the servers that store domain information in the .com zone.

Your ISP's DNS has no information about mail.com or hotmail.com. Therefore, when it receives a query about the name mail.com, it inquires the server responsible for the .com zone about address of the server that contains domain information for mail.com (it is ns1.outblaze.com), connects to that server and returns the answer to you. This way of query execution is referred to as recursive.

We are not going to enlarge upon DNS technology here (it is well described in numerous public sources). The fact important for us is that a query to the DNS service might come through several DNS servers scattered over the globe before you get the answer. And, after all, it's domain owner who is responsible for storage of information about it.

There is a common practice of caching DNS queries. Normally, DNS server remembers the recursive query results for a couple of days in order to reduce the DNS server loading to ensure faster query execution (the information about maximum possible number of days for the result caching is contained into answer to a query). This means that when DNS record suddenly changes, it might take several days before caches of other DNS servers on the Internet are updated and their users get the up-to-date information.


Address Verification Technologies
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

To check whether an e-mail address exists or not, it is necessary to perform the same two phases as a mail server does to deliver a message to a recipient (see the previous section). First, we need to find out address of the server that receives messages for the recipient. Then, we have to connect to the mail server and ask it if it can receive a message for the user with that particular address.

Unfortunately, this method allows detecting no more than about 2/3 of invalid addresses. The problem is that some mail servers receive all messages for their mail domains, but if a mailbox doesn't exist, a server notifies the sender via e-mail that the message is undeliverable.

Current statistics show that about 30% of detectable 2/3 of dead addresses can be detected in the first phase, and 70% can be detected in the second phase. On the average, the second stage takes 10 times longer and involves 5 times greater network traffic compared to the first phase. In fact, the two-stage checking requires as much time and traffic as sending of a small message to the address being checked.

Consider the both phases in more details. In the first phase, checking software analyses e-mail address syntax, identifies mail domain and inquires DNS server about mail server address for that domain. For interaction with DNS server UDP protocol is used, this protocol is faster than TCP, because it is not oriented to establishing connection between servers. Normally, DNS server inquiring time doesn't exceed 1..2 seconds. During that time, one packet with the query is sent (about 60 bytes including the packet heading) and one packet with the answer is received (it's size doesn't exceed 512 bytes; normally it's no more than 200..300 bytes). Obviously, in this phase all addresses with wrong syntax and address with non-existent domains are screened.

In the second phase connection is established with a mail server using the SMTP protocol (based on TCP). TCP is oriented to establishing connection, therefore the servers involved in the process first send service packets to establish connection. Once the connection is established, the servers exchange greetings (see the first three lines in the log below); then, the sender's address is submitted, and the receiving server confirms its readiness to receive a message from that address; after that, message recipient's address is submitted:

< 220 ns.watson.ibm.com ESMTP Sendmail AIX4.3/8.9.3/8.9.0; Thu, 22 Aug 2002 20:44:07 +0500

> HELO cisco.my.net

< 250 ns.watson.ibm.com Hello cisco.my.net [12.44.72.94], pleased to meet you

> MAIL FROM:<verify@testmail.com>

< 250 <verify@testmail.com>... Sender is valid.

> RCPT TO:<noshuchaddress@ibm.com>

< 550 <noshuchaddress@ibm.com>... User unknown

> RSET

< 250 Resetting the state.

> QUIT

In this instance, the receiving server answered that user with the address noshuchaddress@ibm.com was unknown to it and refused to receive the message. After that, the serves exchanged commands to terminate the connection.

While checking the address, the servers sent to each other 10 messages with total size about 500 bytes; but to send all those messages, they had to exchange over 20 packets, so the total traffic was about 2K. Of note, most of the action time was spent on waiting for reply from the other server.

High Speed Verifier is offered as a solution for quick removal of garbage from lists with millions of addresses. For purely technical reasons, its operating rate is 10..15 times greater than that of AMV with relatively small lists, and with lists containing millions of addresses the difference in operating rate might be up to thousands of times. Growth of the HSV operating rate with longer lists is ensured by the fact that HSV stores the results of all queries to DNS servers in RAM cache, so, with longer lists the rate of cache hits is greater.


Technical Description of HSV Operation

EMMA Labs website

Navigation: Working with program:

Technical Description of Operation
No contents entries on this page
Contents
Topic functions menu
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Overview of technical principles underlying HSV operation is given in the previous section. This section describes HSV operation algorithms. Knowing these algorithms, one can get more from the product.

Based on the checking results, HSV sorts all the addresses into four groups – existing addresses, addresses which checking failed (unchecked), non-existing addresses, and addresses with wrong syntax. Please note that incorrect and non-existing address cannot be saved in different files on end of the verifing process — they are always saved in the same file — the file with non-existing addresses.

To check an e-mail address, High Speed Verifier performs the following operations. First, it analyses address syntax and identifies the mail domain. In the domain name, the first-level domain is identified (e.g., .com for mail.com) and checked using the first-level zone list (the file zones.txt in the program folder). If analysis of address syntax fails, or its first-level domain is not found in the list, the address is deemed invalid.

After that, HSV inquires DNS server about domain mail server address. If the list of servers that receive mail for the domain under consideration is obtained, the address is deemed valid. If no such address is found in DNS or there are no mail servers that receive mail for it, the address is deemed invalid. If DNS server failed to return any reply (as you know from the first section, queries are normally executed recursively, and a situation when DNS servers responsible for the domain queried about are physically inaccessible is quite probable), the address is considered unchecked.

High Speed Verifier keeps domain checking results in its inner cache, so if another address from the same domain is found in a mailing list, it will take the result immediately from the inner cache instead of querying a DNS server again. The cache size is limited only by the RAM size on a machine. To store one domain checking result, 40 bytes in RAM is required. So, to store results of checking a million of different domains, 40 Mb is needed. Time of search in the cache practically doesn't depend on its size.

Checking of a list with million addresses from one domain by HSV takes 2..4 minutes on a modern machine. So, the difference in checking time of a list with 50000 addresses from unique domains and a list with million addresses from 50000 unique domains will not exceed 2..4 minutes, and in fact it might be just a few seconds (because of multithreaded operation of the program).

That's why High Speed Verifier operating rate is higher with longer lists. HSV might spend a couple of hours on checking the first million addresses from a list, and ten minutes on checking each next million addresses from the same list.

High Speed Verifier operating rate greatly depends on quality of the list of DNS servers it works with. When checking an address, HSV sends query to a DNS server, and if there is no reply in 30 seconds, it sends a query once again. If there is no reply after three attempts, the check stops with the "Timeout" error. HSV makes five attempts to check an address if its checking fails. DNS server for each next attempt is chosen from a list in a random way. If all the five attempts failed, the address is marked as unchecked.

The more DNS servers there are in the list HSV works with, the smaller is the probability that failure of one or two DNS servers would influence operating rate of the program.

High Speed Verifier works in a multithread mode, you can set the thread number from 1 to 600. One thread is used to check one address. So, if 600 threads are used, 600 domains are checked simultaneously, and HSV sends up to 15000 queries to DNS servers per minute, with peak traffic up to 700 kbps. Loading one DNS server so heavily looks very much like a hackers' attack aimed at disrupting its operation. Therefore DNS server software system might block you until the reason is checked by system administrator. It is also possible that DNS server will accept a limited number of queries from your address per second, and ignore the rest packets to reserve some free resources for processing queries from other users. In that instance, HSV operating rate will sharply drop down, addresses will be checked several times, because previous checking attempts were terminated on timeout.

So, if your network connection is capable of maintaining operation of over 50 threads, you need to have a list of DNS servers with one server for each 10 threads. Then you can be sure that servers won't fail due to overload.


Are Dead Addresses Really Dead?
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

What is a dead address? First, it is an address with wrong syntax. Such address is always dead. Second, it is an address from an unbought domain or a domain that was not paid in a due time. Such an address might become "live" again if somebody buys a domain. Third, it is an address from a domain that has been bought but hasn't been registered in DNS, or no mail server addresses are registered for it in DNS. Some domains were bought only because of their names, their only function is to send visitors to main site of a company; normally, no e-mail address is needed for a domain of that kind. Such addresses may come alive at any moment once domain owner's plans change. With some domains, DNS addresses refer to other machines which are not DNS servers any more or are off due to some technical or managerial problems. But tomorrow the error will be corrected, DNS server caches will be updated and the addresses will come back to life in some three days.

Both domain life and life of an e-mail address in that domain are rather relative. Some addresses die irreparably, some will become alive again in a day, some will come back to life in a month. Somebody will buy a dead domain in a year, and the address webmaster@ will become valid again.

We have done the following test. We checked a list of addresses, and then rechecked the list of invalid addresses. This new check revealed 0.65% of existing addresses. Check of the remaining list of invalid addresses revealed 0.3% of existing addresses again. We repeated the check again and again, and with every new check the number of existing addresses found was several times smaller — down to hundredths of a percent. In total, repeated checks revealed that about 1.1% of the addresses in the list of invalid addresses actually existed. We run the checks continuously for two days.

The list of revived addresses was checked by HSV and only 30% of the addresses existed, 70% were found invalid again. When remaining revived addresses were checked again a day later, only 33% proved actually existing. So, finally, as little as 9% of the revived address list remained. It made 0.1% of the initial list of invalid address list.

It is possible to assume that about 1% of invalid addresses found are unstable, "half-dead". And 90% of unstable addresses remain unstable for at least several days.

Our investigation delivered a simple explanation of why most of unstable addresses behave so. Software of many DNS is configured so that when replying to a recursive query is impossible (see the section "Introduction to E-mail Technologies") they return the result "Server not found". Actually, another reply code would be more adequate – then, High Speed Verifier could repeat the query through another server. Some DNS servers do so, and HSV makes five attempts at checking an address through different DNS servers. Finally, one of the attempts succeeds, or the address is marked as unchecked.

So, if a DNS server is connected to the web through an overloaded, unstable channel, e-mail addresses on the domain it is responsible for are unstable, too.

As we've already noted, dead address is a relative definition, the situation might change over time. If you are going to use a mailing list with millions of addresses, it would be advisable to exclude all the addresses marked by HSV as unchecked or invalid. Because messages to 99% of such addresses will be never delivered; and 1% of the messages will be delivered after hours of attempts.

But don't discard the list of invalid address — if you have a million of dead addresses, you have a chance to retrieve about ten thousand of revived addresses from it in a week.


Diagnostics and Optimization
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Summarizing the previous articles of the help system, it is possible to develop several rules, keeping to which would help a user to ensure optimal operation rate of the program:

1.Try to check as long lists as possible, lists with millions of addresses are optimal.

2.Also don't forget, please, that the more addresses from the same domain there are in a list, the quicker it will be checked. Check of million addresses from one domain takes 2..4 minutes

3.Never use DNS servers that didn't pass testing.

4.Avoid using DNS servers that failed to pass all 7 of 7 tests, as well as slow DNS servers.

5.Never use less than five DNS servers, with great number of threads use at least one servers for every ten threads. Failure to keep to these rules might result in breakdown of computer networks.

6.Greater thread number not always ensures higher operating rate. Some operation systems are unable of managing great number of threads effectively; the channel width required for great number of threads might exceed actually available width, so further increase of thread number would result in lower operating rate.

7.Remember that DNS server lists needs to be checked and updated on a regular basis.

The following symptoms might show that High Speed Verifier doesn't work optimally:

1.The number of DNS errors occurred while checking a list is greater or equal to a half number of domains processed.

2.CPU and Internet channel usage rate is low.

3.Checking speed is much smaller than you could expect with your Internet connection speed. Assuming that check of one domain (not one email address!) requires 300..400 bytes of network traffic, you can calculate maximum possible number of domains checked per second. For example, with 33.6 kbps connection it would be about 10..15 domains. Please note that with non-uniform address list, readings of the address checking speed indicator might be misleading.

Diagnostics should consist of the following steps:

1.Check the DNS server list once again. Probably, some of the servers have become slow or don't work any more.

2.Make sure that size of the DNS server list meets recommendations of this article. Remember that adding new fast servers to the list would never have negative effect on HSV operating rate.

3.Open the Internet-channel and CPU usage monitor (see your operation system manual). Slowly change the number of threads until you achieve the best relation between the checking speed displayed by HSV and load of the Internet channel and CPU. Besides the checking speed indicator, also note how quickly the number of checked domains is changing, because readings of the speed indicator might be misleading with non-uniform lists.

4.Note changes in readings of the DNS error counter, and adjust the number of threads if the readings go beyond the optimal range.


DNS Servers Test Window
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

In this page of the Wizard you are to create a list of DNS servers and to check them. You can proceed to the next page of the master only provided you have a list of checked DNS servers.

High Speed Verifier imports the list of DNS servers from your machine settings on the first launch, but the list with one…three servers might prove to small for most tasks (see the article "Technical Description of Operation"). We recommend that you have at least five DNS servers or at least one server for each ten checking threads (see the "Mailing List Verifing Window").

Editing the Server List.

To add a DNS server into the list, click "Add New Server". Alternatively, you can hit the INSERT key, provided the insertion point is in the server list (to ensure that, you can click on the list first).

To add several servers at once, hit SHIFT+INSERT (the insertion point must be in the list), and server addresses from the clipboard will be added to the list. When copying data from the clipboard, each line is assumed to contain one server address, spaces around server names are ignored.

To remove a server from the list, highlight it and hit DELETE or BACKSPACE.

The above commands are also accessible via a context menu. To open the menu, right-click the mouse.

Downloading the Server List from Our Site.

To download the DNS server list from our site, HTTP protocol is used. When downloading the list, HSV uses Microsoft Internet Explorer settings. If some problems occur with the list downloading, first of all you are to check Microsoft Internet Explorer settings and to make sure that you can view Internet pages with that browser. It is also recommended that you read the article "Operation via a Proxy Server", if you use Internet connection via a proxy server.

High Speed Verifier downloads a list of 100 servers in one session. The servers are selected in a random way from the big list on our server. There is one more limitation: downloading more than 100 servers in one day is not allowed.

Checking the DNS Servers.

Server checking is a very important action. If your list is only half-checked, the master will let you proceed to the next page, but HSV operation quality and speed are at risk.

Usage of unchecked servers or of unreliable servers (servers that failed to pass some of HSV tests) might result in both great slow-down of HSV operation, and (potentially, in very rare occasions) to its erratic performance. For technical reasoning, see the article "Technical Description of Operation". Therefore we strongly recommend that you be very careful about selection and testing of DNS servers.

Of note, the server list needs to be rechecked and updated after every few days. You can set up automatic execution of that operation via the HSV command prompt.

So, the master would probably suggest deleting all bad servers. We strongly recommend that you accept the suggestion, because usage of servers that failed to pass the tests (or passed only some of the tests) is likely to result in considerable slow-down of HSV operation or to erratic results. Bad servers can only be used for testing purposes.

The master may also suggest removing all slow / unreliable servers. A server that has passed 11 tests of 12 is considered unreliable. If a server passes less than 11 tests, it is considered bad. Usage of unreliable servers would potentially yield erratic results, and usage of slow servers might result in considerable slow-down of the program operation.

In the command prompt operation mode, the key –suggest means automatic acceptance of the master's suggestions, which results in removal of all bad, slow, and unreliable servers (as recommended by the master), if there are any in the list.


Source and Destination Files Window
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

High Speed Verifier supports standard text files with one e-mail address in each line. Any conventional address syntax is acceptable:

John Smith <jsm@mail.com>

"John Smith" jsm@mail.com

jsm@mail.com

"John Smith" <jsm@mail.com>

Other file formats are not supported, excluding CSV (Comma Separated Values) file format. Many programs, including Microsoft Excel, Microsoft Outlook and Advanced Email Extractor are support data export to CSV format.

While checking a list, High Speed Verifier sorts the addresses into three groups – unchecked addresses, existing addresses, and invalid addresses (see "Technical Description of Operation"). So, you can choose three different output files the result would be saved to.

If two output files have the same name (e.g., the file for verified addresses and the file for unchecked addresses), one file will be created and addresses from the both groups will be saved into it (verified addresses and unchecked addresses in our example). If names of all the three output files are the same, HSV will create a single file, exact copy of the source file, so, in fact you will get nothing but a copy of the source file on a disc and an opportunity to watch the checking process.

When the results are being saved on disc, they are placed to a temporary file first. That's why name of any output file may be similar to name of the source file: the results will be placed in a temporary file first, and upon completion of the check, the source file will be replaced with the temporary file. For this reason you can also safely terminate HSV operation in the second phase of checking process (the result saving phase) — the results will be lost, but there is absolutely no risk that the source file will be damaged.

Please note that unregistered copy of HSV only saves addresses that proved valid. Saving of unchecked and invalid addresses is only possible with a registered copy. That's why unregistered copy displays warning on the last page of the master when output file name and source file name are the same — there is a risk that you lose some addresses if the source file contains more than 5000 entries.


Mailing List Verifing Window
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Address checking involves three steps:

·processing of the source file

·saving of the results into the output files

·release of the resources allotted to the program on the first step

Step 1/3: source file processing.

Progress of the process is displayed by indicators in the Statistics window:

·Total lines loaded — the number of lines loaded from the source file. Some of those lines are already processed, others are under processing — DNS servers are queried about addresses from those lines.

·Valid emails — number of addresses that were checked and found valid.

·Unverified emails — the number of addresses that proved impossible to check (see "Technical Description of Operation").

·Bad emails — addresses that were checked and found invalid.

·Incorrect lines — number of lines with wrong address syntax. When saving the results, HSV saves those addresses in the file with invalid addresses.

·Processed domains — number of unique mail domains processed. A list might contain many addresses from same domains, therefore this indicator normally shows a number smaller than the total number of valid, invalid, and unchecked addresses.

·Domains in process — number of domains being inquired about from DNS servers at the moment. This number can be changed by the thread number control slider (see below).

·DNS errors — number of errors occurred when querying DNS. It is supposed that a DNS server must answer whether there are servers receiving mail for particular domain or not (see "Address Verification Technologies"). However, DNS often is unable of giving the reply because a server that stores information for the domain queried about is inaccessible, so it returns an error message. Moreover, HSV makes several attempts at checking such address via different DNS servers from the list, so one "unstable" address increases the number of errors by more than one. Errors may also occur due to overload of your Internet-connection (e.g. because of exceeded thread number). It is considered normal if the error counter shows a number three to four times smaller than the number of processed domains. Otherwise, see "Diagnostics and Optimization".

·Elapsed time — time elapsed from start of the current checking session, in the format HH:MM:SS.

·Speed (emails/sec) — shows average speed of address checking in the past 30 seconds. When the source file checking is about to be completed, readings of this indicator usually drop down to less than 10 or even to less than 1. This happens because some domains which first check failed remain in the task list, and HSV attempts at checking those domain through other servers. Checking of the last domains sometimes takes 1..3 minutes.

Under the Statistics window, there is a slider that controls the number of simultaneous queries to DNS servers (or the number of threads). You can set the tread number from 1 to 600. If 600 threads are used, 600 domains are checked simultaneously, and HSV sends up to 15000 queries to DNS servers per minutes, with the peak network traffic up to 700 kbps.

Depending on the result of you DNS server list testing, High Speed Verify calculates approximate width of the network channel required for each thread and shows it above the slider.

If you are going to run HSV with more than 50 threads, you ought to thoroughly read the article "Technical Description of Operation". Inconsiderate increase of the thread number might result not in greater operation rate of the program but in greater number of errors and significant reduction of the operation rate. In some networks, if the list of DNS-servers is small, great number of threads might result in rejection of queries from other users by DNS servers, which would cause failure or even collapse of the network. Also please read the article "Diagnostics and Optimization".

Step 2/3: Saving of the Results.

On this step, HSV saves the check results on a disc. The data to be saved are first stored in a temporary file. That's why name of any output file may be similar to name of the source file: the results will be placed in a temporary file first, and upon completion of the check, the source file will be replaced with the temporary file. For this reason you can also safely terminate HSV operation on the second step of checking process (the result saving step) – the results will be lost, but there absolutely no risk that the source file will be damaged. For more details see the article "Source and destination files window".

Step 3/3: Cleanup.

The third step, release of the allotted system resources, is a required action, which cannot be interrupted or cancelled. This step will be performed even if the first or the second step was terminated. On this step, HSV frees memory allotted to store intermediate results.


Running HSV from the Command Prompt

EMMA Labs website

Navigation: Advanced options:

Running High Speed Verifier from the Command Prompt
No contents entries on this page
Contents
Topic functions menu
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Command prompt syntax:

HSV.EXE source valid [[unverified [bad]] [-download] [-test] [-suggest] [-exit]

Where:

source | Source file name. Required.
valid | Name of the file valid addresses to be saved in (see. "Source and destination files window"). Required.
unverified | Name of the file addresses which check failed to be saved in. Optional.
bad | Name of the file bad addresses to be saved in. Optional.
-download | This key requires from the master to download DNS server list from HSV web-site. See "DNS Servers Test Window". Abbreviated syntax: -D. Optional. If download fails, the master will stop working.
-test | This key requires from the master to test the DNS server list. See "DNS Servers Test Window". Abbreviated syntax: -T. Optional. If no good servers were found during the test, the master will stop working.
-suggest | This key requires from the master to accept its suggestions automatically. See "DNS Servers Test Window". Abbreviated syntax: -S. Optional.
-exit | Quit the master upon SUCCESSFUL completion of a task. Abbreviated syntax: –E.Optional.

You can run High Speed Verifier from the command prompt to check a file. In this instance, the first two parameters ("source" and "valid") are required, and the rest parameters are optional.

The keys -download, -test, -suggest, -exit may come in any order, but they must come after the file names. The keys and their abbreviations may be typed in any case.

HSV.EXE –download –test –suggest –exit

Examples of right commands:

HSV.EXE “C:\My Documents\mlist.txt” c:\work\exist.txt c:\work\unv.txt c:\work\bad.txt

HSV.EXR maillist.txt ..\valid.txt –download –test –suggest

HSV.EXR maillist.txt ..\valid.txt –d –t –s –e

HSV.EXR maillist.txt ..\valid.txt –e -t

Examples of wrong command prompt syntax:

HSV.EXE “C:\My Documents\mlist.txt”

HSV.EXR –download –test maillist.txt ..\valid.txt

HSV.EXR maillist.txt –d –t –s –e

You can also run High Speed Verifier from the command prompt with the only purpose to update or check the server list. In this instance, no names of files to be processed need to be entered, but the command prompt must contain at least one of the following keys: –download, -test, -suggest, and the –exit may be used only provided there is one of the required keys in the command prompt.

Also you can create the task with the following command prompt in the Windows Scheduler to have the list updated according to your desired schedule:

Examples of right command prompt syntax in this mode:

HSV.EXE –download –test –suggest -exit

HSV.EXR -D -T -suggest


Operation via a Proxy Server
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Proxy server is necessary if your machine has no direct connection to the Internet. High Speed Verifier works with DNS servers using the UDP protocol, but the list of DNS servers is downloaded from our site using the HTTP protocol.

When downloading the list of DNS servers, HSV is using Microsoft Internet Explorer settings. If you can view web pages with Microsoft Internet Explorer, HSV is unlikely to have any problems with downloading the server list from our site. There is only one instance when a problem is possible: if your proxy requires authorization (username and password should be provided). Then, request from your system administrator to alter the authorization procedure so that you don't have to enter the username and password manually.

Unfortunately, configuring the program for work with DNS servers is a more difficult task. Software like Socks Capture cannot ensure correct operation of HSV. The only possible way to configure HSV is to do DNS server port mapping on the ports of your proxy.

Assume your proxy address is 192.168.1.1. And you have a list of several DNS servers:

NS1.SOMESITE.COM

NS2.SOMESITE.COM

NS3.SOMESITE.COM

Your system administrator should map:

UDP 53 port of the server NS1.SOMESITE.COM to port 53 of the proxy

UDP 53 port of the server NS2.SOMESITE.COM to port 54 of the proxy

UDP 53 port of the server NS3.SOMESITE.COM to port 55 of the proxy

Then you have to enter the following server list in High Speed Verifier (please note that the default port is 53 – standard for DNS):

192.168.1.1

192.168.1.1:54

192.168.1.1:55

Please note that in this instance you will have to transfer DNS servers downloaded from our site from HSV to the proxy settings, and to enter addresses of the ports mapped on the proxy server in HSV.


Registration
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

You can register your copy of High Speed Verifier via RegNow registration service using any major credit card. Volume discounts are available. You can register on-line, using fax, toll-free phone, by check or wire transfer. Money orders are also accepted.

On the Internet, go to our Web page and follow the link "Purchase High Speed Verifier".

On payment approval, we'll send you the registration key, which will remove all limitations. Your registration will be valid for all future versions of High Speed Verifier.


Unregistered copy limitations
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

The unregistered version of High Speed Verifier is almost fully functional. However, it has one limitation — it saves only first 5000 of the checked addresses. Also, we can provide only limited support (and with low priority) to unregistered users.

When you'll register, you'll get the registration key (serial number) which will remove the limitation. Your registration key will work for all future versions of High Speed Verifier (or we may provide you with the new key, if the keys will be changed for some reason).


Advanced Email Extractor
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Advanced Email Extractor 3 (EmEx 3) is designed to extract e-mail addresses from web-pages on the Internet (using HTTP and HTTPS protocols) and from HTML and text files on local disks. EmEx 3 supports operation through a proxy-server and works very fast, as it is able of loading several pages simultaneously, and requires very few resources. It is possible to launch EmEx 3 in fully automatic mode through the command prompt.

EmEx 3 is intended to collect information (e-mail addresses, phone numbers, ICQ/MSN/Skupe UINs and many others) from public sources in Internet.

The most common issues, which appeared in our other smart solution - Advanced Email Extractor (AEE), were solved in EmEx 3. Also, we took into account the newest technologies of email addresses protection from extracting and collection.

The software interface is more simple and handy and program's features are almost unlimited.

More 300 search engines over whole world can process your queries now. We constantly track the actuality of script databases for processing of search engines results, so you don't need to update the software if a search engine changes the format of data. You will get the updated settings with every run of EmEx 3.

Take a look to a short list of EmEx 3 features:

·Data search in different sources including search engines

·Support of more than 300 search engines (including Yahoo, Google, MSN)

·Simplified HTTP authorization on such websites as web forums or paid services

·Search limitations: by country, domain, document code page

·Customizable list of exceptions

·Black and white lists

·List of ignored domains

·Filter by keywords with support of logical expressions

·Anti-flood filter to regulate load on scanned websites (anti-hammer);

·Scheduler

·Dynamic replacement of document's content

·Masking by User-Agent

·Filters by MIME-types of the scanned document

·Mode of multi thread scanning which enables to process up to 50 documents at once

·Limitation of loading speed

·Daily updated script schemes for information recognition

·Proxy support

·Daily updated lists of proxy servers

·An ability to form non standard search templates without updating the application

·and much more!

EmEx 3 works under XP/Vista/Windows 7/Windows 8 with Microsoft Internet Explorer 7.0 or higher installed. It will never go out-of-date - it will become better and better, it's capabilities will expand with every new release of Internet Explorer.

You can download program free from our site.


Mailing List Wizard
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Mailing List Wizard (MLW) is designed to help you with processing and converting your mailing lists. It is able of excluding duplicated addresses, correcting misspelled addresses using unique algorithms, filtering lists by varied criteria, merging lists, and making exclusions from address lists using an additional list. MLW can supplement mailing lists with address owner names using information from other lists, delete address owner names from mailing lists, sort emails in mailing lists, and also many other things. MLW is a single software product that combines functions of several programs for mailing list processing.

The program works in a wizard mode: it will prompt you step by step to choose action type; to choose a file the action is to be taken upon (source file); to choose a file the results to be saved into (destination file); to choose action settings and to specify additional files to be involved in the action.

When an operation is being performed, the results are stored in a temporary file on disk, and they are moved to the destination file only after the action is successfully completed. This allows interrupting an action in any phase without a risk of losing data any changes to files involved in the action are made only upon its completion. The temporary file is created in the same directory where the destination file is to be stored. Therefore, you need to have enough of free space on your disk so the temporary file could be saved.

During an action, the program is displaying a real-time log showing the action progress. For example, when exclusion of duplicated addresses is being performed, all the duplicated addresses found will be written to the log along with line numbers. Besides, the log contains statistic information such as number of lines processed, action execution time, etc. When processing large mailing lists, the number of entries in the log might exceed 100000, and refreshing the log on the screen might take system resources comparable to resources needed for the list processing itself. Therefore only first 60 K of the log are displayed real-time (about 1500 lines).

The whole log is stored in a temporary file in the MLW directory. After the action is completed, you can save the log from temporary file to any other file, open and view it with a text editor.

You can download program free from our site.


Web Server
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

On the web-site you can find the complete list of our software products and the latest news, download trial versions of the products, and register your software.

·Mailing List Wizard home

·Emex 3 home

·High Speed Verifier home

·What's new on our server

Most of our products are being updated once a month on the average. Don't forget to visit our site, we are always glad to see you! Should you have any questions or suggestions, please, contact the technical support service.


Technical support
No contents entries on this page
Go to previous topic
Go to home topic
This is the last topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Our technical support service is always glad to help you and to answer any your questions. Please, keep to the following rules when contacting the technical support service:

·If your question concerns incorrect operation of the software, do not forget to provide the version number of your operating system and service/upgrade pack.

·Please, include any additional details you see appropriate so that the developers could reconstruct your exact situation in the lab.

·If you are a registered the user, specify your serial number or number of the order. It will help us to process your inquiry faster.

You can contact the technical support service via web - http://www.emmalabs.com/support/. We also recommend visiting our web-site where you can find additional information on the about our products.