Введение
No contents entries on this page
Contents
Topic functions menu
Menu
This is the first topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Mailing List Wizard (MLW) поможет Вам выполнить обработку и преобразование списков рассылки. Программа умеет исключать из списков дублирующиеся адреса, исправлять неправильно написанные адреса по уникальным алгоритмам, фильтровать списки по разным критериям, объединять и разделять списки, делать исключение из списка адресов по дополнительному списку. MLW умеет обогащать список рассылки именами владельцев адресов по информации из других списков, удалять имена владельцев адресов из списков рассылки, сортировать адреса в списках рассылки и многое другое. MLW это одна программа, которая включила в себя функции сразу несколько программ по обработке списков рассылки.

Программа построена в виде мастера (wizard), который последовательно предлагает Вам выбрать вам тип выполняемой операции; выбрать файл над которым будет выполняться операция (исходный файл); выбрать файл, в который будут помещены результаты (файл-приемник); задать настройки для операции и указать дополнительные файлы, которые будут вовлечены в операцию.

При выполнении операции результаты записываются во временный файл на диске, и лишь после успешного завершения операции данные из временного файла перемещаются в файл-приемник. Это дает возможность на любом этапе выполнения операции прервать ее, не опасаясь возможной потери данных - изменения вовлеченных в операцию файлов происходят только после ее завершения. Временный файл для выполнения операции создается в том же каталоге, что и файл-приемник. Поэтому на диске, соответственно, должно быть достаточно свободного места для сохранения временного файла.

Во время выполнения операции программа показывает в реальном времени журнал, в котором отражается ход выполнения операции. Например, при выполнении операции по исключению дублирующихся адресов, в журнал будут занесены все найденные дублирующиеся адреса вместе с номерами строк. Также в журнал сохраняется статистическая информация, такая как число обработанных строк, время выполнения операции и т.п. При обработке больших списков рассылки в журнал могут быть добавлены сотни тысяч записей, и обновление журнала на экране может потребовать затрат ресурсов, сравнимых с затратами на саму обработку списка. Поэтому в реальном времени показываются только первые 60 кб журнала (около 1500 строк).

Полностью журнал записывается во временный файл, создаваемый в каталоге с программой. После завершения выполнения операции журнал можно сохранить из временного файла в любой другой файл, открыть его текстовым редактором и просмотреть. Вы также можете пометить "Показывать только статистику", чтобы в реальном времени отображалась только важная информация и статистика (всего около 5-20 строк за время выполнения операции).

MLW поддерживает единственный формат списков рассылки, когда в каждой строке файла записан один адрес. Адрес может быть записан следующими способами:

"John Smith" <jsmith@email.com>

John Smith <jsmith@email.com>

<jsmith@email.com>

jsmith@email.com

John Smith jsmith@email.com

Следующие варианты записи адресов будут считаться неправильными:

<jsmith@email.com> John Smith

jsmith@email.com, John Smith

<jsmith@email.com> "John Smith"

John Smith, jsmith@email.com or jsmith@hotmail.com

"John and Jane" jsmith@email.com, janesmith@email.com

Адреса, записанные одним из вышеуказанных способов, могут быть приведены к нормальному виду при помощи операции коррекции синтаксиса.

© 2016 EMMA Labs All rights reserved.


Выбор операции
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

За один раз мастер выполняет одну операцию. Если вам нужно выполнить несколько операций (например, объединить два списка и удалить из них дубликаты), то после выполнения первой операции объединения списков необходимо вернуться назад на эту страницу и выбрать следующую операцию — операцию удаления дубликатов.

Описание операций:

·Удаление дублирующихся адресов

·Разделение списка

·Объединение двух списков

·Исключение адресов из списка

·Обогащение списка

·Обеднение списка

·Исправление неправильных адресов

·Фильтрация адресов

·Сортировка адресов в списке рассылки


Выбор исходного файла
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Выберите файл, над которым будет выполняться операция. Некоторые операции (например, объединения двух файлов) требуют два исходных файла; в этом случае выбор второго исходного файла будет предоставлен на следующих страницах мастера.

При выполнении операции результаты записываются во временный файл на диске, и лишь после успешного завершения операции данные из временного файла перемещаются в файл-приемник. Это дает возможность на любом этапе выполнения операции прервать ее, не опасаясь возможной потери данных - изменения вовлеченных в операцию файлов происходят только после ее успешного завершения. Временный файл для выполнения операции создается в том же каталоге, что и файл-приемник.

Исходный файл может совпадать с файлом-приемником. Обратите внимание, что незарегистрированная версия программы обрабатывает только первые 1000 строк исходного файла. И если исходный файл совпадает с файлом-приемником, то в незарегистрированной версии это может привести к усечению файла, если он длиннее 1000 строк.


Выбор файла-приемника
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

В файл приемник будут сохранены результаты после успешного выполнения операции. При выполнении операции результаты записываются во временный файл на диске, и лишь после успешного завершения операции данные из временного файла перемещаются в файл-приемник. Это дает возможность на любом этапе выполнения операции прервать ее, не опасаясь возможной потери данных — изменения вовлеченных в операцию файлов происходят только после ее успешного завершения. Временный файл для выполнения операции создается в том же каталоге, что и файл-приемник.

Исходный файл может совпадать с файлом-приемником. Обратите внимание, что незарегистрированная версия программы обрабатывает только первые 1000 строк исходного файла. И если исходный файл совпадает с файлом-приемником, то в незарегистрированной версии это может привести к усечению файла, если он длиннее 1000 строк.


Выбор файла исключений
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Этот файл используется в операции "Исключение адресов из списка", в ходе которой из исходного файла удаляются все адреса, которые присутствуют в файле исключений.

См. также описание операции.


Выбор файла-донора
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Файл-донор используется в операции "Обогащение списка". Во время операции адреса электронной почты из исходного списка обогащаются именами владельцев адресов из файла-донора. Во время операции из исходного списка удаляются все неправильные и дублирующиеся адреса, поэтому рекомендуется выполнить вначале над исходным списком операцию коррекции синтаксиса.

См. подробное описание настроек в описании операции.


Настройки коррекции синтаксиса
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Эти настройки используются в операции коррекции синтаксиса. См. подробное описание настроек в описании операции.


Добавление файла
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Выбор файла для добавления к исходному файлу в оперции "Объединение списков". Это очень простая операция, по сути являющаяся построчным копированием двух файлов в один. При этом адреса в списках не проверяются на предмет ошибок, но вы можете автоматически исключить пустые или слишком короткие строки (менее шести символов), которые не могут содержать корректного адреса.


Настройки фильтров
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Эти настройки используются для фильтрации адресов в списке. См. описание этих настроек в описании операции.


Настройки сортировки
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Эти настройки используются при сортировке адресов в списке рассылки. См. подробное описание настроек в описании операции.


Настройки разделения
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Эти настройки используются при разделении списка. См. подробное описание настроек в описании операции.


Запуск операции
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

При выполнении операции результаты записываются во временный файл на диске, и лишь после успешного завершения операции данные из временного файла перемещаются в файл-приемник. Это дает возможность на любом этапе выполнения операции прервать ее, не опасаясь возможной потери данных — изменения вовлеченных в операцию файлов происходят только после ее успешного завершения. Временный файл для выполнения операции создается в том же каталоге, что и файл-приемник.

После выполнения операции работа мастера будет завершена. Если Вы хотите выполнить еще одну операцию, пометьте опцию "Вернуться на первую страницу...", чтобы мастер после завершения операции перешел на страницу выбора операции.


Удаление дублирующихся адресов
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

В ходе операции из списка рассылки удаляются дублирующиеся адреса и неверные адреса. Список удаляемых адресов помещается в журнал в следующем формате:

DUP 6744: <mbdil@prodigy.net>

INV 6955: "E-mail the

DUP 7126: custcare@investors.com

DUP 7229: copyright@yahoo-inc.com

DUP 7241: "Send comments" <letters@forbes.net>

Вначале идет трехбуквенный код (DUP - дублирующийся адрес; INV - неверный адрес), затем номер строки с адресом, а затем сам адрес после двоеточия.

Дублирующимися адресами считаются те, у которых совпадает сам адрес электронной почты. Например, адреса:

John Smith <jsmith@email.com>

JSM <jsmith@email.com>

являются дублирующимися.

MLW не пытается исправить синтаксис адресов во время этой операции, поэтому перед ее выполнением рекомендуется выполнить вначале операцию исправления адресов с неправильным синтаксисом.


Разделение списка
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

При помощи этой опрации Вы можете разделить исходный файл на несколько. Обратите внимание, что в процессе разделения плохие адреса не будут записаны в выходные файлы и, возможно, предварительно стоит выполнить операцию исправления адресов. Обратите внимание, что выходные файлы всегда именуются отлично от исходного файла, и исходный файл не может быть поврежден или перезаписан при выполнении операции. Поддерживаются следующие режимы разделения:

По размеру.

При этом Вы можете задать максимальный размер выходных файлов. Если, например, исходный файл 110 Кб, и указан размер выходного файла в 50 Кб, то на выходе получится три файла — первые два по 50 Кб и один размером 10 Кб. Адреса переписываются в выходные файлы в том порядке, в каком они идут в исходном файле.

По числу адресов

Если указано, что выходной файл должен содержать не более 1000 адресов, а в исходном списке 3500 адресов, то на выходе будет четыре файла — в первых трех по 1000, и в последнем 500 адресов. Адреса переписываются в выходные файлы в том порядке, в каком они идут в исходном файле.

При изменении домена первого уровня

Перед обработкой файла, очевидно, нужно выполнить операцию сортировки адресов в списке по домену первого уровня. Пусть у Вас есть гигантский список, и Вы хотите сохранить из него в отдельные файлы все адреса с доменов .COM, .NET и .ORG. Тогда, вначале Вам нужно отсортировать исходный список, потом сделать операцию разделения по домену первого уровня (при этом на каждый домен первого уровня будет создан отдельный файл с адресами, их может быть около сотни — .IT, .JP, .ES и т.п.), и затем исключить из исходного файла содержимое тех файлов, что содержат адреса .COM, .NET и .ORG (в зависимости от выбраной схемы именования, они могут называться, например, mylist.txt.COM, mylist.txt.NET, mylist.txt.ORG). После чего стереть все файлы, кроме исходого и mylist.txt.COM, mylist.txt.NET, mylist.txt.ORG. Итого, требуемая задача может быть выполнена при помощи трех операций MLW.

При изменении домена второго уровня

Аналогично предыдущему пункту. Однако следует учесть, что и изменение домена первого уровня учитывается. Например, адреса с доменов mysite.com и mysite.org будут записаны в разные выходные файлы.

При изменении имени ящика

Аналогично, исходный список должен быть вначале отсортирован по имени почтового ящика. При этом изменения в домене не учитываются, адреса webmaster@microsoft.com и webmaster@mailutilities.com попадут в один выходной файл.

Также программе нужно задать механизм именования выходных файлов. Возможны следующие варианты:

Добавлять порядковый номер

Каждому выходному файлу будет присваиваться последовательный номер, начиная с единицы. Например, исходный список называется mylist.txt и программа генерирует три выходных файла, тогда они будут называться mylist.txt.001, mylist.txt.002 и mylist.txt.003.

По домену первого уровня первого адреса

Например, мы делим по изменению домена первого уровня следующий файл:

jsmith@email.com

jane@email.com

andrian@email.net

andrian@email.org

Тогда будут сформированы три выходных файла: mylist.txt.com, mylist.txt.net и mylist.txt.org. Теперь предположим, что мы пытаемся поделить не отсортированный файл по домену первого уровня:

jsmith@email.com

andrian@email.net

jane@email.com

andrian@email.org

MLW сформирует файлы mylist.txt.com и mylist.txt.net. После чего программа дойдет до адреса jane@email.com, при этом домен первого уровня поменяется (с .net на .com) и программа начнет новый файл, поименует его согласно настройке как mylist.txt.com. При этом первый сформированный файл с этим именем будет перезаписан без предупреждения.

По домену второго уровня первого адреса

Аналогично предыдущему пункту. Теоретически, этот режим именования должен использоваться только при разделении файла по домену второго уровня. Однако MLW позволяет использовать его при любом варианте разделения файла. Именно по этому в названии этого режима присутствует приписка "...первого адреса", так как адреса сохраняемые в файл могут быть с абсолютно разных доменов, не смотря на выбранную схему именования выходных файлов.

По имени почтового ящика первого адреса

Полностью аналогично двум предыдущим схемам именования выходных файлов.


Объединение двух списков
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Эта примитивная операция является, по сути, построчным копированием двух файлов в один. Синтаксис адресов не проверяется, но можно автоматически исключить при копировании все пустые или слишком короткие строки (менее 6 символов), которые не могут содержать адреса электронной почты по определению.


Исключение адресов из списка
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

В ходе этой операции из исходного файла исключаются все адреса, которые присутствуют в файле с исключениями (exclude file). Файл исключений также можно называть стоп-листом. Формат записи адреса в исходном файле и файле исключений может различаться. Например, пусть в исходном файле присутствуют строки:

John Smith <jsmith@email.com>

jane@email.com

А в файле исключений такие строки:

jsmith@email.com

"Jane Morgan" <jane@email.com>

Несмотря на то, что формат адресов не совпадает, оба адреса будут исключены из исходного файла (точнее, они не будут сохранены в файл-приемник). Список удаляемых адресов помещается в журнал в следующем формате:

INV 1049605: "WHAT?" <WHAT>

DUP 1051097: mp3help@sandh.com

DUP 1051098: "Kristoff Batizy" <kristoff.batizy@nau.edu>

DUP 1051099: pr@netdragons.com

DUP 1051100: "to Postmaster" <postmaster@dngmail.com>

Loading the exclude file 'D:\exclude-list.txt'

EXC 10: jpiracy@adobe.com

EXC 17: debbib@bsa.org

EXC 18: roni.singleton@dittus.com

Вначале идет трехбуквенный код (DUP - дублирующийся адрес; INV - неверный адрес; EXC - исключен, так как присутствует в файле исключений), затем номер строки с адресом, а затем сам адрес после двоеточия.

MLW не пытается исправить синтаксис адресов во время этой операции, поэтому перед ее выполнением рекомендуется выполнить вначале операцию исправления адресов с неправильным синтаксисом.


Обогащение списка
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

В операции принимают участие два файла: исходный файл (обогащаемый), и файл с именами пользователей. Суть операции в добавлении к адресам электронной почты в исходном файле имен пользователей из второго файла. Например, исходный файл содержит строки:

"JS" <jsmith@email.com>

jane@email.com

"Mr. Andrian" <andrian@email.com>

А файл с именами содержит:

"John Smith" <jsmith@email.com>

"Jane Loran" <jane@email.com>

andrian@email.com

После выполнения операции обогащения результат может выглядеть так:

"John Smith" <jsmith@email.com>

"Jane Loran" <jane@email.com>

"Mr. Andrian" <andrian@email.com>

Можно выбрать один из трех режимов выполнения операции: 1) обогащать только те адреса, которые вообще не имеют имен (jane@email.com в нашем примере); 2) обогащать адреса, выбирая из двух возможных имен более длинное (в нашем примере, таким образом обогатятся "JS" <jsmith@email.com> и jane@email.com); 3) заменять все имена, которые возможно. В третьем режиме замена не произойдет только в том случае, если адрес в файле с именами вообще не содержит имени (в нашем примере адрес "Mr. Andrian" <andrian@email.com> не будет заменен на andrian@email.com ни в одном из трех режимов).

Во время операции также будут исключены все некорректные и дублирующиеся адреса, поэтому перед ее выполнением рекомендуется выполнить вначале операцию исправления адресов с неправильным синтаксисом.


Обеднение списка адресов
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Во время этой операции из исходного списка удаляются все имена, и файл-приемник будет содержать только адреса электронной почты. При этом адреса с неверным синтаксисом записываются в файл-приемник в неизмененном виде. Рекомендуется выполнить операцию коррекции синтаксиса адресов перед выполнением этой операции.

Например, исходный файл содержит строки:

"JS" <jsmith@email.com>

jane@email.com

bzzzzz......

"Anna" <anna@@@email.com>

"Mr. Andrian" <andrian@email.com>

Результатом обработки будет:

jsmith@email.com

jane@email.com

bzzzzz......

"Anna" <anna@@@email.com>

andrian@email.com

В данном примере третья и четвертая строки небыли обработаны, а были сохранены в файл приемник в неизмененном виде.


Исправление неправильных адресов
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Данная операция исправляет в файле-источнике неправильные адреса электронной почты, используя уникальные алгоритмы. Пример выполнения операции:

SRC 11: jpiracy@adobe.comjB

NEW 11: jpiracy@adobe.com

SRC 467: "Greg A. Saville" <gregsa@teleport.com">

NEW 467: "Greg A. Saville" <gregsa@teleport.com>

SRC 724: "martyb" <martyb@ultraint.com%20(train%20to%20trane)>

NEW 724: "martyb" <martyb@ultraint.com>

SRC 733: "MAXOMENOS" <maxomenos@SPAM=DEATH.hushmail.com>

NEW 733: "MAXOMENOS" <maxomenos@hushmail.com>

SRC 743: tycho@penny-arcade.com,gabriel@penny-arcade.com

NEW 743: tycho@penny-arcade.com

SRC 772: krodim@hotmail.comt

NEW 772: krodim@hotmail.com

SRC 1263: "info@spinnaker.co.jp" <//info@spinnaker.co.jp>

NEW 1263: "info@spinnaker.co.jp" <info@spinnaker.co.jp>

SRC 2267: "Laurent Clevy" <lclevy@club-internet.fr@subject=[ADF_FAQ]>

NEW 2267: "Laurent Clevy" <lclevy@club-internet.fr>

SRC 2480: "guylhem@metalab.unc.edu" <guylhem@LDP_NO_SPAM.metalab.unc.edu>

NEW 2480: "guylhem@metalab.unc.edu" <guylhem@metalab.unc.edu>

SRC 3955: "abuse@ihateclowns.com" <abuse@ihateclowns.com,rodneyb@ihateclowns.com>

NEW 3955: "abuse@ihateclowns.com" <rodneyb@ihateclowns.com>

SRC 4083: abuse@bfp.net)

NEW 4083: abuse@bfp.net

SRC 4229: (djackson@aol.net)

NEW 4229: djackson@aol.net

SRC 11832: "Daniel Stenberg" <daniel_at_haxx.se>

NEW 11832: "Daniel Stenberg" <daniel@haxx.se>

SRC 13550: "lena@lenagames.com" <Lena%20Games>

NEW 13550: "Lena Games" <lena@lenagames.com>

SRC 19699: mailto:kurtcpa@bright.net

NEW 19699: kurtcpa@bright.net

SRC 19846: "JAMM <bo.begole@sun.com>" <JAMM%20<bo.begole@sun.com>>

NEW 19846: "JAMM <bo.begole@sun.com>" <bo.begole@sun.com>

Мы добились 100% исправления ошибок в реальных тестовых списках адресов, которые у нас были. Но предполагаем, что программа восстанавливает около 95% адресов из тех, которые теоретически можно восстановить. В целях предохранения от спама, адреса часто записывают экзотическими способами, например, (my)*(email)!(com). Интеллект нашей программы пока что уступает фантазии человека.

Вы можете попробовать восстановить адреса из файла EmlBugs.LST (этот файл расположен в установочном каталоге с MLW) для демонстрации возможностей MLW по восстановлению адресов.

В ходе выполнения этой операции не может пострадать корректный адрес, MLW пытается исправить только некорректные адреса. Список исправляемых адресов помещается в журнал в приведенном выше формате. Вначале идет трехбуквенный код (SRC- исходный адрес; NEW - адрес после исправления; INV - неверный адрес, который не удалось восстановить), затем номер строки с адресом, а затем сам адрес после двоеточия.

Мастер также предложит Вам также следующие опции:

Удалить ?subject= из адресов

Формально, задание темы письма вместе с адресом почты является вполне допустимым, но в большинстве списков адресов это излишне.

Добавить ящик к почтовому домену без ящика

Часть адресов в списке может быть принципиально не подлежащей восстановлению, например:

NetSoap <netsoap.com>

Jane Smith <http://www.jsmith.com>

mycorp.net

Sergio <mailto:sergio.com>

Программа не может угадать почтовый ящик, если он вообще не присутствует в адресе. Если не включать данную опцию, то все такие адреса будут отнесены к неверным. Если же опция включена и задан ящик, например "info", то адреса будут восстановлены следующим образом:

NetSoap <info@netsoap.com>

Jane Smith <info@jsmith.com>

info@mycorp.net

Sergio <info@sergio.com>

Удалить произвольную строку

MLW будет пытаться удалить заданную подстроку из всех адресов в списке - корректных и некорректных (до процедуры восстановления). Строка чувствительна к регистру (при заданной подстроке "REMOVEIT", подстрока "RemoveIt" удалена не будет). Подстрока ищется по всей строке с адресом, включая имя владельца адреса, если оно есть.

Исправлять адрес по списку известных доменов

Если эта опция включена, MLW будет пытаться восстановить адреса без домена первого уровня типа mike@hotmail, jane@aol в mike@hotmail.com и jane@aol.com. Вы можете отредактировать список известных доменов, добавив в него сколько доменов, сколько нужно.

Удалять известные подстроки 'REMOVEIT'

Эта опция может испортить правильные адреса. Адреса типа mikeREMOVEIT@hotmail.com и jane@NOSPAMaol.com синтаксически корректные и могут существовать на самом деле. Если эта опция включена, то MLW попробует восстановить такие адреса в mike@hotmail.com и jane@aol.com.

Проверять адреса по списку доменов первого уровня

Это простейшая процедура проверки, она сравнивает домен первого уровня (например, '.com' для jane@somesite.domain.com) со всеми доменами из списка. Эта процедура полезна для удаления 'антиспамерских шуток', типа hahaha@dont.spam, someone@invalid.address и т.п.

Удалять адреса, которые не удалось исправить

Если опция не включена, то адрес, который не удалось восстановить (или который был восстановлен неуспешно), будет записан в файл-приемник в оригинальном виде.


Фильтрация адресов
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Данная операция фильтрует адреса из файла-источника несколькими способами. Вы можете отфильтровать адреса, которые:

·содержат или не содержат указанной подстроки. Через запятую может быть перечислено несколько подстрок, например:

info@, support@, postmaster@

·совпадают или не совпадают с указанной маской. Можно использовать метасимволы "*" и "?". "*" означает "любая подстрока" (включая пустую), а "?" - один любой символ; например a*@b??.com совпадает с a@bcc.com, acc@bcc.com, и не совпадает с a@bc.com. Масок также может быть задано несколько через запятую:

info@*, support@*, *master@*

·совпадают или не совпадают с заданным регулярным выражением. Регулярные выражения во многом похожи на маски, но представляют гораздо более мощный механизм поиска. Вы можете ознакомиться с их синтаксисом на одном из следующих ресурсов:

http://www.perl.com/CPAN-local/doc/manual/html/pod/perlre.html

http://www.python.org/doc/lib/re-syntax.html

http://perso.magic.fr/roumazeilles/regex.htm

http://www.boost.org/libs/regex/index.htm

Регулярное выражение может быть задано только одно для поиска совпадения и одно для поиска несовпадения.

В зависимости от того, включена ли опция "Применять фильтр ко всему адресу, включая имя владельца", поиск совпадений (во всех трех методах) будет выполняться либо только по адресу электронной почты (jsmith@email.com), либо по всей строке с адресом, включая имя ("Jane Smith" <jsmith@email.com>).

Независимо от включения названной выше опции, фильтры применяются только к корректным адресам в списке. Поэтому перед выполнением операции рекомендуется выполнить вначале операцию исправления адресов с неправильным синтаксисом. Некорректные адреса будут либо сохранены в неизменном виде, либо не сохранены, в зависимости от того, включена ли опция "Удалять невернуые адреса".

Еще можно включить опцию "Проверять адреса по списку доменов первого уровня." Это простейшая процедура проверки, она сравнивает домен первого уровня (например, '.com' для jane@somesite.domain.com) со всеми доменами из списка. Эта процедура полезна для удаления 'антиспамерских шуток', типа hahaha@dont.spam, someone@invalid.address и т.п.

Также для данной операции можно включить опцию "Удалять адреса, содержащие более 5 цифр в имени почтового ящика". Если она включена, то следующие адреса будут удалены из списка:

23823-98103@compuserve.com 192.15.210.5@abuse.com mx0228443@email.com

А данные адреса не попадут под действие этого фильтра:

as123@eml345.com

abc@x123456.com

"Jane 1977-05-06" <jsmith@email.com>


Сортировка адресов в списке
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Эта операция сортирует адреса в исходном файле в алфавитном порядке или по адресу/домену. Обратите внимание, что неправильные адреса будут удалены из списка, и поэтому мы рекомендуем выполнить вначале операцию коррекции синтаксиса.

Предлагаемые критерии сортировки в примерах:

Сортировка по всей строке.

Max <aaa@bbb.com>

All <bbb@aaa.com>

jim <aaa@aaa.com>

ccc@911.ccc.com

ccc@911.ccc.ar

aaa@911.ccc.uk

> > > >

aaa@911.ccc.uk

All <bbb@aaa.com>

ccc@911.ccc.ar

ccc@911.ccc.com

jim <aaa@aaa.com>

Max <aaa@bbb.com>

Сортировка только по адресу электронной почты.

Max <aaa@bbb.com>

All <bbb@aaa.com>

jim <aaa@aaa.com>

ccc@911.ccc.com

ccc@911.ccc.ar

aaa@911.ccc.uk

> > > >

aaa@911.ccc.uk

jim <aaa@aaa.com>

Max <aaa@bbb.com>

All <bbb@aaa.com>

ccc@911.ccc.ar

ccc@911.ccc.com

Сортировка по домену адреса.

Max <aaa@bbb.com>

All <bbb@aaa.com>

jim <aaa@aaa.com>

ccc@911.ccc.com

ccc@911.ccc.ar

aaa@911.ccc.uk

> > > >

ccc@911.ccc.ar

ccc@911.ccc.com

aaa@911.ccc.uk

All <bbb@aaa.com>

jim <aaa@aaa.com>

Max <aaa@bbb.com>

Сортировка по домену первого уровня.

Max <aaa@bbb.com>

All <bbb@aaa.com>

jim <aaa@aaa.com>

ccc@911.ccc.com

ccc@911.ccc.ar

aaa@911.ccc.uk

> > > >

ccc@911.ccc.ar

Max <aaa@bbb.com>

All <bbb@aaa.com>

jim <aaa@aaa.com>

ccc@911.ccc.com

aaa@911.ccc.uk

Сортировка по домену второго уровня.

Max <aaa@bbb.com>

All <bbb@aaa.com>

jim <aaa@aaa.com>

ccc@911.ccc.com

ccc@911.ccc.ar

aaa@911.ccc.uk

> > > >

All <bbb@aaa.com>

jim <aaa@aaa.com>

Max <aaa@bbb.com>

ccc@911.ccc.ar

ccc@911.ccc.com

aaa@911.ccc.uk

Если включена опция Сортировать адреса в обратном порядке, то следование адресов в примерах выше будет обратным.


Advanced Email Extractor
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

EmEx 3 предназначен для сбора информации (e-mail адресов, номеров телефонов, номеров ICQ/MSN/Skype и многого другого) из публичных источников, размещенных в сети Интернет.

При создании EmEx были решены наиболее частые задачи, с которыми сталкивались пользователи нашего популярного продукта Advanced Email Extractor (AEE), а так же учтены новейшие технологии защиты e-mail адресов от подобного сбора.

Интерфейс пользователя стал проще и удобнее, а возможности программы - практически неограниченны.

Более 300 поисковых машин по всему миру могут обрабатывать ваши запросы. Мы постоянно отслеживаем актуальность баз данных скриптов для обработки результатов ответов от поисковых машин, поэтому вам не придется обновлять программу если поисковая машина изменила формат возвращаемых данных. При каждом запуске EmEx 3 вы получите обновленные настройки для поиска.

Посмотрите на краткий перечень возможностей EmEx 3 и убедитесь сами:

·Поиск как с заданного источника, так и по поисковым машинам

·Одновременный поиск по более чем 300 поисковым машинам мира

·Поддержка авторизации по HTTP или через веб форму

·Ограничение поиска по стране, доменной зоне или кодовой странице документа

·Гибко настраиваемый фильтр исключений

·"Черный" и "Белый" списки

·Список игнорируемых доменов

·Фильтр ключевых слов, поддерживающий логические выражения

·Фильтр ограничения активности запросов к сканируемым сайтам (анти-хаммер)

·Работа по расписанию

·Динамическая замена содержимого документа

·Маскировка по User-Agent

·Фильтрация по MIME типам

·Многопоточное сканирование, позволяющее обрабатывать до 50 ссылок одновременно

·Ограничение скорости загрузки

·Постоянно обновляемые скрипты для распознавания собираемой информации

·Использование прокси серверов

·Обновляемые списки прокси серверов1

·Возможность создания собственных схем для сбора информации2

·И многое другое!.


High Speed Verifier
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

High Speed Verifier (HSV) программа для быстрой проверки на существование емейл адресов. HSV может проверять тысячи адресов в секунду. Это прекрасное решение для списков содержащих сотни тысяч адресов.

HSV гарантированно определяет около 20-30% неправильных адресов в списках, теоретически до 60-70%. HSV предоставляет оптимальный режим проверки с точки зрения времени и траффика. Более тщательная проверка, занимает в 100 раз дольше и требует 5 раз больше трафика для каждого адреса, следовательно, это не то, что желательно для работы с огромными списками.

High Speed Verifier предлагается как решение для быстрого удаления мусора из списков с сотнями тысяч и более адресов. Высокая скорость HSV с длинными списками обеспечивается тем, что HSV сохраняет результаты всех запросов к DNS-серверам в кэше оперативной памяти, а значит, с более длинными списками попаданий в кэш больше.

HSV является первым профессиональным программным обеспечением предназначен для проверки больших списков рассылки, он был создан профессионалами для профессионалов. Мы надеемся, что с HSV ваш бизнес будет более эффективным и успешным, и вы будете наслаждаться использованием нашего продукта.

Скачать можно с нашего сайта our site.


Регистрация программы
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Регистрация программы платная После регистрации программы Вам будет выслан ключ, который снимет с программы все ограничения. Ключ будет работать и со всеми будущими версиями Mailing List Wizard.

Наша компания принимает все виды оплаты от физических и юридических лиц, предоставляя покупателям необходимые для отчетности финансовые документы. Перейти на страницу регистрации программы можно по прямой ссылке http://www.massmail.ru/purchase/

Приобретая программу легально, Вы стимулируете автора развивать и совершенствовать программу, которая нужна Вам, помогаете создавать в России цивилизованный рынок программного обеспечения.


Ограничения незарегистрированной копии
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Незарегистрированная копия Mailing List Wizard полностью функциональна за исключением одного ограничения - она обрабатывает не более 1000 адресов из списка рассылки. Запросы незарегистрированных пользователей в службу поддержки обрабатываются с меньшим приоритетом.

После регистрации Вы получите серийный номер, который снимет с программы все ограничения. Ваш серийный номер будет работать и со всеми будущими версиями Mailing List Wizard.


Сайт в Интернет
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

На веб-сайте вы можете узнать последние новости, подписаться на список рассылки о программе и скачать последнюю версию программы. Помимо Mailing List Wizard, на нашем сайте Вы найдете еще несколько полезных программ - Advanced Email Extractor, High Speed Verifier и другие.

Не забывайте заходить на наш сайт, мы всегда рады видеть вас! Пожалуйста, обращайтесь в службу технической поддержки, если у вас возникли вопросы, предложения или пожелания.


Техническая поддержка
No contents entries on this page
Menu
Go to previous topic
Go to home topic
This is the last topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Мы обещаем ответить на ваше письмо, если Вы будете придерживаться следующих правил, когда обращаетесь в службу технической поддержки:

·Если Ваш вопрос касается некорректной работы программного обеспечения, то не забудьте сообщить версию операционной системы, пакета обновления и установленного Microsoft Internet Explorer.

·Пожалуйста, сообщите все дополнительные детали, какие сочтете нужными, чтобы разработчики могли в точности воспроизвести вашу ситуацию.

·Ознакомьтесь со списком в Интернет, возможно, что необходимое уже добавлено или исправлено в более новой версии.

·Уважайте чужое время. Мы знаем, где скачать самый лучший мейлер и знаем, почему ваша звонилка не ловит сигнал "занято". Но мы Вам этого не скажем.

·Если Вы зарегистрированный пользователь, то сообщите в письме Вашу регистрационную информацию. Это позволит нам обработать Ваш запрос быстрее.

Связаться со службой технической поддержки можно через web сайт. Также рекомендуем посетить наш сайт в Интернет, на котором можно найти дополнительную информацию о программе.